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Introduction 
Welcome to CustomGuide: Microsoft Word 2003. CustomGuide courseware allows 
instructors to create and print manuals that contain the specific lessons that best meet their 
students’ needs. In other words, this book was designed and printed just for you. 

Unlike most other computer-training courseware, each CustomGuide manual is uniquely 
designed to be three books in one: 
• Step-by-step instructions make this manual great for use in an instructor-led class or as a 

self-paced tutorial. 
• Detailed descriptions, illustrated diagrams, informative tables, and an index make this 

manual suitable as a reference guide when you want to learn more about a topic or 
process. 

• The handy Quick Reference box, found on the last page of each lesson, is great for when 
you need to know how to do something quickly. 

CustomGuide manuals are designed both for users who want to learn the basics of the 
software and those who want to learn more advanced features. 

Here’s how a CustomGuide manual is organized: 

Chapters 
Each manual is divided into several chapters. Aren’t sure if you’re ready for a chapter? Look 
at the prerequisites that appear at the beginning of each chapter. They will tell you what you 
should know before you start the chapter. 

Lessons 
Each chapter contains several lessons on related topics. Each lesson explains a new skill or 
topic and contains a step-by-step exercise to give you hands-on-experience. 

Chapter Reviews 
A review is included at the end of each chapter to help you absorb and retain all that you have 
learned. This review contains a brief recap of everything covered in the chapter’s lessons, a 
quiz to assess how much you’ve learned (and which lessons you might want to look over 
again), and a homework assignment where you can put your new skills into practice. If you’re 
having problems with a homework exercise, you can always refer back to the lessons in the 
chapter to get help.  
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How to Use the Lessons 
Every topic is presented on two facing pages, so that you can concentrate on the lesson 
without having to worry about turning the page. Since this is a hands-on course, each lesson 
contains an exercise with step-by-step instructions for you to follow. 
To make learning easier, every exercise follows certain conventions: 
• Anything you’re supposed to click, drag, or press appears like this. 
• Anything you’re supposed to type appears like this. 
• This book never assumes you know where (or what) something is. The first time you’re 

told to click something, a picture of what you’re supposed to click appears either in the 
margin next to the step or in the illustrations at the beginning of the lesson. 

Lesson 4-2: Formatting Values
Figure 4-3
The Numbers tab of the 
Format Cells dialog box.

Figure 4-4
The Expense Report 
worksheet values before 
being formatted.

Figure 4-5
The Expense Report 
worksheet values after being 
formatted.

Select a number 
category

Select a number 
format

Preview of the 
selected number 
format

Figure 4-3

Figure 4-4 Figure 4-5

In this lesson, you will learn how to apply number formats. Applying number formatting changes 
how values are displayed—it doesn’t change the actual information in any way. Excel is often 
smart enough to apply some number formatting automatically. For example, if you use a dollar 
sign to indicate currency (such as $548.67), Excel will automatically apply the currency number 
format for you.

The Formatting toolbar has five buttons (Currency, Percent, Comma, Increase Decimal, and 
Decrease Decimal) you can use to quickly apply common number formats. If none of these buttons 
has what you’re looking for, you need to use the Format Cells dialog box by selecting Format →
Cells from the menu and clicking the Number tab. Formatting numbers with the Format Cells 
dialog box isn’t as fast as using the toolbar, but it gives you more precision and formatting options. 
We’ll use both methods in this lesson.

Comma Style 
button

1.1. Select the cell range D5:D17 and click the Comma Style button on 
the Formatting toolbar.
Excel adds a hundreds separator (the comma) and two decimal places to the selected cell 
range.

You can also format 
values by using the 
Formatting toolbar 
or by selecting 
Format → Cells 
from the menu and 
clicking the 
Number tab.

2424 Microsoft Excel 2000
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Illustrations show what your 
screen should look like as you 
follow the lesson. They also 
describe controls, dialog boxes, 
and processes. 

An easy-to-understand 
introduction explains the task or 
topic covered in the lesson and 
what you’ll be doing in the 
exercise. 

Clear step-by-step instructions 
guide you through the exercise. 
Anything you need to click 
appears like this. 

Icons and pictures appear in the 
margin, showing you what to 
click or look for. 

Tips and traps appear in the 
margin. 
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• When you see a keyboard instruction like “press <Ctrl> + <B>,” you should press and 

hold the first key (<Ctrl> in this example) while you press the second key (<B> in this 
example). Then, after you’ve pressed both keys, you can release them. 

• There is usually more than one way to do something in Word. The exercise explains the 
most common method of doing something, while the alternate methods appear in the 
margin. Use whatever approach feels most comfortable for you. 

• Important terms appear in italics the first time they’re presented. 
• Whenever something is especially difficult or can easily go wrong, you’ll see a: 

     NOTE:  
immediately after the step, warning you of pitfalls that you could encounter if you’re not 
careful. 

• Our exclusive Quick Reference box appears at the end of every lesson. You can use it to 
review the skills you’ve learned in the lesson and as a handy reference—when you need 
to know how to do something fast and don’t need to step through the sample exercises. 

 

Currency Style
button

Other Ways to Apply
Currency Formatting:
• Type the dollar sign ($)

before you enter a number.

2.2. Click cell A4 and type Annual Sales.
The numbers in this column should be formatted as currency.

3.3. Press <Enter> to confirm your entry and overwrite the existing
information.

4.4. Select the cell range G5:G17 and click the Currency Style button on
the Formatting toolbar.
A dollar sign and two decimal places are added to the values in the selected cell range.

5.5. Select the cell range F5:F17 and click the Percent Style button on
the Formatting toolbar.
Excel applies percentage style number formatting to the information in the Tax column.
Notice there isn’t a decimal place—Excel rounds any decimal places to the nearest whole
number. That isn’t suitable here—you want to include a decimal place to accurately show
the exact tax rate.

6.6. With the Tax cell range still selected, click the Increase Decimal
button on the Formatting toolbar.
Excel adds one decimal place to the information in the tax rate column.
Next, you want to change the date format in the date column. There isn’t a “Format Date”
button on the Formatting toolbar, so you will have to format the date column using the
Format Cells dialog box.
The Formatting toolbar is great for quickly applying the most common formatting options to
cells, but it doesn’t offer every available formatting option. To see and/or use every possible
character formatting option you have to use the Format Cells dialog box. You can open the
Format Cells dialog box by either selecting Format→ Cells from the menu or right-clicking
and selecting Format Cells from the shortcut menu.

7.7. With the Date cell range still selected, select Format → Cells from
the menu, select 4-Mar-97 from the Type list box and click OK.

Formatting a Worksheet  2525

Table 4-2: Number Formatting Buttons on the Formatting Toolbar
Button Name Example Formatting

  Currency $1,000.00 Adds a dollar sign, comma, and two decimal places.

  Percent 100% Displays the value as a percentage with no decimal places.

  Comma 1,000 Separates thousands with a comma.

  Increase Decimal 1000.00 Increases the number of digits after the decimal point by one

  Decrease Decimal 1000.0 Decreases the number of digits after the decimal point by one

 Quick Reference

To Apply Number
Formatting:

• Select the cell or cell range
you want to format and click
the appropriate number
formatting button(s) on the
Formatting toolbar.

Or...
• Select the cell or cell range you

want to format, select Format
→ Cells from the menu, click
the Number tab, and specify
the number formatting you want
to apply.

Or...
• Select the cell or cell range you

want to format, right-click the
cell or cell range and select
Format Cells from the shortcut
menu, click the Number tab,
and specify the number
formatting you want to apply.

That’s all there is to formatting values–not as difficult as you thought it would be, was it? The
following table lists the five buttons on the Formatting toolbar you can use to apply number
formatting to the values in your worksheets.
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Anything you need to type 
appears like this. 

Whenever there is more than 
one way to do something, the 
most common method is 
presented in the exercise and 
the alternate methods are 
presented in the margin. 

Tables provide summaries of the 
terms, toolbar buttons, or 
shortcuts covered in the lesson.

CustomGuide’s exclusive Quick 
Reference is great for when you 
need to know how to do 
something fast. It also lets you 
review what you’ve learned in 
the lesson. 





Chapter One: 
Networks and the 

Internet 
Chapter Objectives: 

• Learn about networks 

• Learn the difference between a LAN and WAN 

• A look at common network hardware 

• Learn about Intranets, Extranets, and network security 

• Understand telephones used to connect to a network 

• Understand Ethernet and wireless networks 

A network is a group of computers that are connected so that they can share equipment and 
information. This chapter will introduce you to the fundamentals of networking. You won’t be 
a certified network engineer after you finish this chapter, but you will know all there is to 
know about getting started. 

This chapter covers common terminology associated with computer networks and the 
Internet, components and benefits of networked computers, the difference between different 
types of networks (for example, LAN and WAN), and how computer networks fit into other 
communications networks (like the telephone network and the Internet). 

 

 Prerequisites 
• Basic knowledge about 

computers. 
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Lesson 1-1: Introduction to 
Networks 
 

OK, so what exactly is a network? A network is several computers, printers, and other devices 
that are connected together with cables or radio signals. This allows the computers to “talk” 
with each other and share information and resources (usually files and printers). Networks 
vary in size; they can be as small as two computers connected to each other by a cable, or they 
can span the entire globe—the Internet is actually the world’s largest network. 

Figure 1-1 

The basic components of 
a peer-to-peer network. 

Figure 1-2 

In a peer-to-peer network, 
everyone stores their files 
on their own computer. 
Anyone on the network 
can access files stored on 
any other computer. 

Figure 1-3 

In a client/server network, 
everyone stores their files 
on a central computer 
called a server. Everyone 
on the network can access 
the files stored on the 
server. 

 IC3 

Objective: 3.1.1.1, 3.1.1.2, 
3.1.1.3, and 3.1.1.4 
Req. File: None 

Shared files 

Shared files Shared files

Workstation

WorkstationWorkstation

Peer-To-Peer Network 
Figure 1-2 

Shared files 
Server 

Workstation Workstation
Client/Server Network 

Figure 1-3 

Network Interface 
Card (NIC) 

Ethernet 
Cables 

Network Hub 
or Switch 

Network Software 
Installed 
(Windows XP Home or 
Professional) 

Figure 1-1 

Cable or DSL 
Modem 
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 Quick 
Reference 
Network Benefits: 
• Share information 
• Share equipment 
• Use network software 

Network Distribution:  

• Local Area Network (LAN) 

• Wide Area Network 
(WAN) 

Basic Types of Networks:  

• Peer-to-peer 
• Client/server 

Basic Network Connection 
Types:  
• Ethernet 
• Wireless or WiFi 

So what are the benefits of networking? Plenty: 
• Share Information: Networks allow you to share files and programs. Before networks, 

people had to save their files on floppy disks in order to exchange information. This 
wasted a lot of time—especially if the computers were located in opposite ends of the 
building! 

• Share Equipment: Computers connected to a network can share equipment to reduce 
costs. For example, rather than buying a printer for each computer, everyone can share 
one central network printer. 

• Use Network Software: Software designed for networks increases communications by 
letting people send and receive electronic mail (e-mail) with other users on the network, 
schedule meetings and workgroups with other users on the network, and share databases. 
When you’re browsing the Web, you’re actually using software designed for a network! 

A Network can be distributed over a small or large area: 
• Local Area Networks (LAN): A network that connects computers in the same 

geographic area or building, using cables. Local Area Networks are what most people 
think of when they think of a network—and what we’ll be discussing throughout the 
chapter. 

• Wide Area Networks (WAN): A network that connects computers across a large 
geographic area using telephone lines or satellites. The Internet is actually a huge Wide 
Area Network. 

Local Area Networks (LANs) are subdivided into two types of network subcategories: 
peer-to-peer (or workgroups) and client/server (or domains), as shown in Figure 1-2 and 
Figure 1-3: 
• Peer-to-Peer Network: In a peer-to-peer network, everyone stores their files on their 

own computer, and anyone on the network can access files stored on any other computer. 
Because you don’t need any additional software (Windows XP includes peer-to-peer 
networking), peer-to-peer networking is an inexpensive way to connect computers in a 
small office or home. The disadvantages of a peer-to-peer network are that it doesn’t offer 
as much security as client/server networks, and it can be difficult to find files that are 
stored on many different computers. Windows XP Home is designed for use in small 
home and office peer-to-peer networks. 

• Client/Server Network: In a client/server network, everyone stores their files on a 
central computer called a server. Everyone on the network can access the files stored on 
the server. Client/server networks are more secure, easier to administer, and much more 
powerful than peer-to-peer networks. That’s why they are used to connect computers in 
most businesses. The types of computers that can be used as servers include mainframe 
computers, minicomputers and powerful PC, Macintosh, or UNIX computers. Clients can 
use PCs, Macintosh computers, handheld devices, etc.  
The disadvantages of client/server networks are that they require special, expensive 
software, such as Windows 2003 Server or NetWare, and they are more complicated to 
install and configure than peer-to-peer networks. Windows XP Professional is designed 
for use in larger client/server networks. 

And, if that weren’t enough, there are two basic ways that you can connect to a network: 
• Ethernet: An Ethernet network lets you connect computers in the same geographic area 

or building using cables. Its high speed, reliability, and simplicity have made Ethernet 
easily the most popular way to connect computers and devices in a network. 

• Wireless or WiFi: A wireless, or WiFi (stands for wireless fidelity) network lets you 
connect computers anywhere in your home or office without wires. A wireless network 
uses the same technology found in cordless phones and allows computers to “talk” to 
each other through radio waves. 

 
A Local Area Network 
(LAN) connects 
computers in the 
same building or 
facility. 

 
A Wide Area Network 
(WAN) connects 
computers over wide 
geographic areas. 
The Internet is an 
example of a WAN. 
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Lesson 1-2: A Look at 
Common Network Hardware 
 

So you’ve decided you want to set up a small home network to share your printer, files, and 
Internet access? Great—let’s go shopping! The biggest networking decision you will have to 
make is if you want an Ethernet-based network or a wireless (WiFi) one. Both have their own 
set of pros and cons, which we’ll cover in detail a little later. This lesson will give you a broad 
overview of the most common network devices, or nodes, and terms that you may come 
across. 

Table 1-1: Common Home Network Hardware Devices 
Network Device Description 

 
Workstation 

Workstations are simply the computers that are connected to the network 
that everyone uses. 

 
Server 

A server is a central computer where users on the network can save their 
files and information. Servers are dedicated to network use and are 
normally not used to run applications or browse the Internet—and 
therefore you normally won’t find a server in most home networks! 

 
Cable or DSL Modem 

A modem connects computers to the Internet through an existing phone 
line or cable connection. Cable modems and DSL modems are both very 
fast and can connect entire networks to the Internet. 

Figure 1-4 

The network shown here 
contains the most 
common components that 
you will find on a small 
network. 

Figure 1-5 

What you’ll need to set up 
a small Ethernet network. 

Figure 1-6 

What you’ll need to set up 
a small wireless or WiFi 
network. 

 IC3 

Objective: 3.1.1.1 
Req. File: None 

Workstation With
Wireless Access

`

Workstation

Wireless Access Point

Firewall

Cable or DSL Modem

Print Server
Printer

Server

Hub or Switch

`

Workstation

Ethernet Shopping List 

• Network Interface Cards 

• Network Hub or Switch 

• Ethernet CAT-5 Cable 

• Cable or DSL Modem 
 

WiFi Shopping List 

• WiFi Network Cards 

• Wireless Access Point or Router 

• Cable or DSL Modem 
 

Figure 1-5 

Figure 1-6 

Figure 1-4 
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 Quick 
Reference 
Hardware Requirements 
for an Ethernet Network: 

• Network Interface Cards 
• Network Hub or Switch 
• Ethernet CAT-5 Cable 
• Cable or DSL Modem 

Requirements for an 
Wireless or WiFi Network: 
• WiFi Network Cards 
• Wireless Access Point or 

Router 
• Cable or DSL Modem 

Network Device Description 

 
Firewall 

A firewall is a system that prevents unauthorized access to or from a 
network. Firewalls can be hardware or software based, or a combination 
of both. Firewalls are often built-in to other products; for example, many 
cable or DSL modems may come with their own built-in firewall. 
Windows XP also comes with a software-based firewall. 

 
Hub or Switch 

A hub is a device where all the cables on a network connect, similar to an 
electrical surge protector. A switch is an “intelligent hub” and manages 
network traffic, ensuring that information gets to the correct destination. 

 
Ethernet Cable 

An Ethernet cable is the wire that physically connects the computers, 
printers, and other equipment on a network. When you buy an Ethernet 
cable make sure that it’s CAT-5. 

 
PCI Desktop 

Network Adapter 

A network interface card (NIC) is a device that physically connects each 
computer to the network and allows your computer to “talk” to other 
computers and devices on the network. Most desktop computers already 
have a built-in network adapter, but if yours doesn’t you can install a PCI 
network adapter. 

 
PCMCIA Notebook 
Network Adapter 

A network interface card (NIC) is a device that physically connects each 
computer to the network and allows your computer to “talk” to other 
computers and devices on the network. Most notebook computers 
already have a built-in network adapter, but if yours doesn’t, you can 
install a PCMCIA network adapter. 
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Print Server 

A print server lets you connect a printer directly to a network instead of a 
computer so that everyone on the network can use it. 

 
Wireless Access 

Point 

A wireless access point normally plugs into a wired Ethernet network and 
acts as the network’s “radio station”, broadcasting and receiving 
information to WiFi-enabled computers and devices on the network. Most 
wireless access points create a 100-foot diameter hotspot where 
computers can connect to the wireless network. 

 
Wireless Router 

Very useful if you are setting up a wireless network from scratch, a 
wireless router is a single device that contains: 1) A port to connect to a 
cable or DSL modem, 2) a firewall, 3) an Ethernet hub, 4) a router, and of 
course, 5) a wireless access point. 

 
PCI Desktop WiFi 

Adapter 

Although desktop computers usually come with a built-in Ethernet card, 
they almost never come with built-in WiFi capability, so you’ll almost 
certainly have to buy and install a PCI WiFi adapter if you want to connect 
a desktop computer to a wireless network. 

 
PCMCIA Notebook 

WiFi Adapter 

Many notebook computers already have a built-in WiFi adapter, but if 
yours doesn’t you can install a PCMCIA WiFi adapter. 
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WiFi Print Server 

A WiFi print server lets you connect a printer directly to a network without 
cables so that everyone on the network can use it. 

Photos courtesy of LinkSys, a Division of Cisco Systems, Inc. 
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Lesson 1-3: Intranets, 
Extranets, and Security on a 
Network 
 

An Intranet is a miniature version of the Internet that works within a company or 
organization. Web sites on an Intranet look and act just like any other Web sites, but can only 
be viewed by users within the company or organization.  A firewall surrounds the Intranet and 
fends off unauthorized access. 

An Extranet is similar to an Intranet, but while an Intranet is generally only accessible to users 
within same company or organization, an Extranet is accessible by authorized outside users. 
Business partners use Extranets to share information. 

Like the Internet itself, Intranets and Extranets are used to share information. Secure Intranets 
are now the fastest-growing segment of the Internet because they are much less expensive to 
build and manage than private networks based on proprietary protocols. 

Figure 1-7 

An Intranet is a miniature 
version of the Internet that 
works within a company or 
organization. 

Figure 1-8 

An Extranet is also like a 
miniature version of the 
Internet, but Extranets are 
accessible to authorized 
users outside of a 
company or organization. 
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Objective: 3.1.1.2, 3.1.1.5, 
and 3.1.1.6 
Req. File: None 

Figure 1-7 

Figure 1-8 
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 Quick 
Reference 
Intranet: 

• A miniature version of the 
Internet that works on a 
network within a company 
or organization. 

Extranet: 

• A miniature version of the 
Internet that allows 
access to authorized 
outside users, such as 
business partners. 

Risks Involved in Working 
in a Network Environment: 

• Potential loss of 
autonomy, privacy, and 
security. 

• Potential of network-wide 
systems failure. 

• Vulnerability to a network 
virus attack. 

So what are the advantages of Intranets and Extranets?  Both Intranets and Extranets can: 
• Share Information: Intranets and Extranets offer a very simple and inexpensive way to 

make internal company documents, such as a phone directory, available to employees.  
• Connect Documents: Documents on an Intranet or Extranet can be connected by 

hyperlinks, so users can easily jump from one related document to another. 
• Use Special Software: Some software can only be used on an Intranet or Extranet, 

such as Web based e-mail programs. 

Working in a network environment isn’t always fun and games, however; there are some 
important risks you need to consider and be aware of:  
• Potential loss of autonomy, privacy, and security: The costs of connecting to a 

network are much greater than a standalone system. 
• Potential of network-wide systems failure: This can result in a loss of access to 

network resources, such as network drives or modems. 
• Vulnerability to a network virus attack: Because of the vast amounts of information 

being sent back and forth on a network, your chances for suffering a virus or hacking 
attack are much greater. 

The risks of networks are managed through careful procedures performed by network 
administrators and other security personnel. A new user will be granted access to the network 
only after a network administrator has set up and authorized a login and password account. 
When a user properly logs on to the network, their login and password is authenticated against 
a list of known users. 
• Authorization of new users by a network administrator: In order to be granted 

access to a network, every user must be authorized and assigned an account by a network 
administrator. 

• Authentication of users through proper login procedures: When a user 
properly logs on to the network, their username and password are authenticated against a 
list of known users. 

• Protection from external threats using protective technology: Networks are 
protected from unauthorized access using hardware and software security systems such as 
firewalls. 

• Regular monitoring of the network: Network administrators and security personnel 
monitor activity on a network to protect against unauthorized access or other security 
violations. 
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Lesson 1-4: Telephones and 
Networks 
 

All this mumbo-jumbo regarding networks probably has you a little confused, so let’s talk 
about something we all can understand: the telephone. We all know that telephones can be 
used to transmit information via voice or fax, but did you know that the telephone can also be 
used to send and receive data on your computer? That’s right—telephones are part of a 
network, too! The worldwide telephone network is a collection of smaller networks all 
working together to allow the transmission of various types of information.  

A modem is a device that translates a computer’s ones and zeros into audio tones, so that it 
can transmit information over the phone lines to other modems. Nearly all digital data now 
flows over fiber-optic lines, and the transfer rate is measured in bits per second (bps), or 
baud. For example, a 300-baud modem can transmit 300 bits per second. The most common 
way people use modems is to connect to the Internet. Common rates for regular modems are 
28.8Kbps, 33.6Kbps, and 56Kbps where the K stands for thousand. By the way, modem 
stands for modulator-demodulator. 

Modems come in two basic flavors:  
• Analog Modems: Computers store information digitally, while telephone lines transmit 

conversations and sounds. An analog modem converts a computer’s ones and zeros to 
tones than can then be transmitted over standard phone lines. Analog modems are limited 
to speeds of 56Kbps. 

• Digital Modems: Use binary ones and zeros to transmit data like a computer. Digital 
modems can transmit information much faster than analog modems. Digital modems are 
often referred to as broadband modems.  

Another important term to familiarize yourself with is bandwidth. Bandwidth refers to the 
amount of data that can be passed along a communications channel in a given period of time. 
“High bandwidth” Internet connections include cable modem, DSL, and T1. “Low 
bandwidth” Internet connections include dial-up via telephone modem. 

Table 1-2: Modem Types and Speeds describes the most common analog (“low bandwidth”) 
and digital (“high bandwidth”) modems out there. The options that are used primarily by large 
organizations are T1 and ADSL, and the options used primarily by home users are telephone 
modem and cable modem. 

Figure 1-9 

An internal modem plugs 
into an expansion slot 
inside a computer. 

Figure 1-10 

An external modem plugs 
into a serial port and sits 
outside a computer. 

Figure 1-11 

Most laptops have a 
built-in modem. 
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Table 1-2: Modem Types and Speeds 
Type Speed (in bps) Description 

A
na

lo
g 

PSTN, PSDN, 
Telephone 

56K or less PSTN stands for Public Switched Telephone Network, 
and is nothing more than your everyday, ordinary 
telephone system based on copper wires. PSTN is often 
referred to as POTS, or plain old telephone service. 
PSDN stands for Public Switched Data Network and is 
just another technical term for the telephone system in 
use today. 

ISDN 56K to 128K ISDN stands for Integrated Services Digital Network. It’s 
one of the older broadband connections. It’s only twice as 
fast as a traditional modem and pretty much obsolete. 

T1 1.544M A T1 line can carry roughly 60 times more data and is 
much more reliable than a traditional modem.  A T1 line is 
a dedicated connection, meaning it is permanently 
connected to the Internet. T1 lines are expensive and are 
generally used only by companies whose business is 
built around the Internet or need to transmit massive 
amounts of data. 

ADSL, DSL 256K to 8,000K ADSL (Asymmetric Digital Subscriber Line) modems take 
advantage of unused frequencies in the phone line, such 
as a pause in conversation. DSL modems are very fast; 
the problem is that you have to be close to a phone 
company in order to get DSL service. 

D
ig

ita
l, 

B
ro

ad
ba

nd
 

Cable 640K to 4,000K A cable modem is the fastest modem you can buy for 
home use. The problem is your cable company has to 
offer cable Internet access in order to use it. 

 

 

 Quick 
Reference 

Analog Modem: 
• Converts a computer’s 

ones and zeros to tones 
that can then be 
transmitted over standard 
phone lines. Analog 
modems are limited to 
speeds of 56Kbps. 

Digital Modem: 
• Uses binary ones and 

zeros to transmit data like 
a computer. Digital 
modems can transmit 
information much faster 
than analog modems. 

PSTN, PSDN: 
• Ordinary, everyday 

telephone network, limited 
to 56Kbps. 

ISDN: 
• An older broadband 

connection, twice as fast 
as a traditional modem at 
128Kbps. 

T1: 
• 60 times as fast as a 

traditional modem at 
1.544Mbps. 

ASDL, DSL: 
• Fast digital connection 

with speeds up to 
8,000Kbps. 

Cable: 
• Fast digital connection 

with speeds up to 
4 000Kbps  
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Lesson 1-5: The Internet 
 

The Internet is the largest computer network in the world. It is often referred to as a “super 
network,” consisting of millions of computers all over the planet, all connected to each other. 

The Internet was born in the 1960s when the United States military worried that a nuclear 
bomb could destroy its computer systems (there weren’t many of them back then). So it 
placed several computers far apart from each other and connected them with some super-fast 
telephone lines so that the computers could talk to each other. If a nuclear bomb blew up one 
computer, another computer could instantly take over; thus, the computer network wouldn’t 
go down. Years passed and other organizations, such as colleges and universities, started 
connecting their computers to this growing network to share information. 

Although the Internet has been around a long time, it wasn’t until 1989 that Tim Berners-Lee 
thought of a wonderful idea called the World Wide Web. Many people use the terms Internet 
and World Wide Web or Web interchangeably, but in fact the terms are two separate, but 
related, things. The Internet is a massive network of networks that connects millions of 
computers to one another. A good analogy would be the cables that provide cable television. 
The World Wide Web is simply one way to communicate and share information over the 
Internet. Using our cable television analogy, the World Wide Web would simply be a single 
channel that is broadcast over the cable system. 

The World Wide Web consists of millions of documents that are stored on hundreds of 
thousands of computers that are always connected to the Internet. These documents are called 
Web pages, and you can find Web pages on every subject imaginable—from your local 
newspaper to online catalogs to airline schedules, and much, much more. 

Web pages are stored on Web servers. A Web server is a computer, not unlike your own 
computer, only bigger and faster. There are hundreds of thousands of Web servers located all 
over the world. Web servers are always connected to the Internet so that people can view their 
Web pages 24 hours a day. 

In order to connect to the Internet, you must first make sure you have all the necessary 
hardware and software. First and foremost, you must have a machine that has the ability to 

Figure 1-12 

The Internet, like a 
telephone network, is 
actually a collection of 
smaller networks all 
communicating and 
working together. 

Figure 1-13 

Web pages are stored on 
Web servers—computers 
that are permanently 
connected to the Internet. 
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connect to the Internet. Computers, handheld devices (such as PDAs), and wireless devices 
(such as cell phones) all have the ability to connect to the Internet.  

Various types of hardware and software required to connect to the Internet include: 
• A modem for accessing a network via telephone lines. 
• Ethernet connectors and cables for direct network connection, or wireless connection 

devices for wireless network connection. 
• Telecommunication software and network operating system software that allows client 

devices and telecommunication devices (such as modems) to communicate with a 
network. 

Once all necessary components are installed, a computer can connect to the Internet via the 
“onramp” of a smaller computer network. For example, a computer user at a small company 
could gain access to the Internet via the company LAN. 

Another way to gain access to the Internet is via an Internet Service Provider. ISPs provide an 
“onramp” to the Internet by maintaining hardware and software and a constant connection to 
the Internet. The responsibility of an ISP includes maintaing and supporting equipment, 
providing customer service and support, and protecting the network from threats and 
unauthorized access. 

So what can you do once you’re connected to the Internet? Plenty. Table 1-3: What Can I do 
on the Internet? shows just a few of the many things there are to do on the Internet. 

Table 1-3: What Can I do on the Internet? 
Task Description 
Send and Receive 
E-mail 

Exchanging electronic mail (or e-mail) is the most used and most popular 
feature on the Internet. Just like regular paper mail, you can send and 
receive e-mail with people around the world, as long as they have access 
to a computer and the Internet. Unlike regular paper mail, e-mail is usually 
delivered to its destination almost instantly. 

Browse the World Wide 
Web 

The World Wide Web is what most people think of when they think of the 
Internet—although it’s really only a part of the Internet. The World Wide 
Web is an enormous collection of interconnected documents stored on 
Web servers all over the world. The World Wide Web has information on 
every subject imaginable.  

Join online discussions 
with newsgroups 

Newsgroups are discussion groups on the Internet that you can join to read 
and post messages to and from people with similar interests. There are 
thousands of newsgroups on topics such as computers, education, 
romance, hobbies, politics, religion, and more. 

Chat with other online 
users 

Chatting lets you communicate with people on the Internet instantly—no 
matter how far away they are! Most chats are text-based, meaning you 
have to type when you converse with people on the Internet. A growing 
number of chats have voice and even video capabilities—all without having 
to pay long distance changes. 

Download software You can download pictures, demo programs, patches and drivers for your 
computer, and many other types of files and save them to your computer. 

Listen to music and 
watch videos 

You can listen to sound on the Web, such as radio stations, or music by 
your favorite artists. 

 Quick 
Reference 

Internet: 
• The Internet is the largest 

computer network in the 
world, connecting millions 
of computers. 

World Wide Web: 
• A way of accessing 

information over the 
Internet. 

Internet Service Provider 
(ISP): 
• An ISP provides its users 

with constant access to 
the Internet. 
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Lesson 1-6: Ethernet 
Networks 
 

Developed in the early 1970s (yes, it’s really that old!), Ethernet is one of the most simple, 
reliable, and long-lived networking protocols ever designed. Its high speed, reliability, and 
simplicity have made Ethernet easily the most common and popular way to connect 
computers and devices in a network. 

To get an idea of how Ethernet works, imagine several people trying to talk in an unmediated 
meeting. There isn’t a schedule of when each person can get a chance to speak; people can 
simply stand up and talk whenever there is silence in the room. And, if two or more people 
stand up and talk at the same time, a collision occurs. When that happens, both parties sit back 
down for a very brief, random amount of time, then one of them will stand up and try talking 
again—hopefully without any interruptions or collisions this time. And, obviously the amount 
of collisions on a network will increase as more computers and network traffic are added. An 
Ethernet switch can greatly reduce the number of collisions on an Ethernet network by 
intelligently managing network traffic. 
Here are some of the basic pros and cons of going with an Ethernet network: 

Ethernet Advantages 

• Reliability: Ethernet has been around for a long, long time and nothing beats it for its 
dependability. 

• Support: Most computers—desktops and laptops alike—already have an Ethernet card 
built right into them! 

• Speed: Ethernet is fast; most Ethernet networks can transfer information at up to 
100 Mbps—usually more than twice as fast as the best wireless networks. And the new 
Gigabit Ethernet standard can handle a jaw-dropping 1,000 Mbps of network traffic. 

• Security: Because it doesn’t broadcast network information over the airwaves like WiFi, 
Ethernet is theoretically more secure—someone would have to tap into the network’s 
lines in order to access it (something called the Internet). 

Ethernet Disadvantages 

• Wires, wires, wires: The computers in an Ethernet network must be physically 
connected by cables that resemble a fat telephone cord. It’s not a big deal if you want to 
connect two computers that are sitting right next to each other, but it is a pain to run all 
that Ethernet cable if you want to connect a computer in your office upstairs with another 
computer in the basement. 

Figure 1-14 

A diagram of a very simple 
Ethernet network. 

Figure 1-15 

Here’s what you’ll need to 
set up an Ethernet 
network. 

 
A hub or switch 
connects all the 
computers and 
devices on a 
network. 
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Objective: 3.1.2.6 
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A network PCMCIA 
adapter for a 
notebook computer. 

`

Desktop Computer

Cable or DSL Modem

Notebook Computer
Hub or Switch

Figure 1-14 

Ethernet Shopping List 

• Network Interface Cards 

• Network Hub or Switch 

• Ethernet CAT-5 Cable 

• Cable or DSL Modem 
 

Figure 1-15 
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 Quick 
Reference 
Ethernet Advantages: 
• Reliability 
• Widely supported 
• Speed 
• Security 

Ethernet Disadvantages: 
• Wiring can be difficult to 

set up. 

Common Ethernet 
Speeds: 
• 10 Mbps (10 Base-T) 
• 100 Mbps (100 Base-T) 
• 1,000 Mbps (Gigabit) 

What You Need to Create an Ethernet Network 
Besides the rather obvious and most important part of the network, which are the actual 
computers, you’ll need a few things to create a small Ethernet network, including: 
• Network Hub or Switch: A hub is a device where all the cables on a network connect, 

similar to an electrical surge protector. A switch is an “intelligent hub” that manages 
network traffic, ensuring that information gets to the correct destination. 

• Ethernet Cable: An Ethernet cable is the wire that physically connects the computers, 
printers, and other equipment on a network. When you buy an Ethernet cable make sure 
that it’s CAT-5. 

• Ethernet Network Interface Cards: A network interface card (NIC) is a device that 
physically connects each computer to the network and allows your computer to talk to 
other computers and devices on the network. Most computers already come with a 
network adapter built-in, but if yours doesn’t you can install one; a PCI network adapter 
for desktops or a PCMCIA network card adapter for laptops. 

• Cable Modem or DSL Modem (Optional): A modem connects computers to the 
Internet through an existing phone line or cable connection. Cable modems and DSL 
modems are both very fast and can connect all the computers in a home or small office 
network to the Internet. If you subscribe to a high-speed Internet service they will almost 
certainly set up the cable modem or DSL modem for you. 

Ethernet devices are available in a number of speeds (although the vast majority uses the 
100 Base-T standard). The following table describes common Ethernet speeds. 

Table 1-4: Ethernet Speeds 
Standard Speed Description 
10 Base-T 10 Mbps Ten years ago, 10 Base-T was the standard speed of most 

Ethernet networks, but it’s all but obsolete now. You may still find 
10 Base-T Ethernet on older network devices, or on devices that 
simply don’t require any more bandwidth, like a cable or DSL 
modem. 

100 Base-T 
(Fast Ethernet) 

100 Mbps 100 Base-T Ethernet is by far the most common Ethernet 
standard in use. It’s fast—ten times faster than 10 Base-T, yet it 
can still communicate with 10 Base-T network devices; at only 
10 Mbps, however. 

Gigabit Ethernet 1,000 Mbps Gigabit Ethernet is a new Ethernet standard that works just like 
10 Base-T Ethernet, only ten times faster. Gigabit Ethernet can 
still talk to 100 Base-T and even 10 Base-T network devices. 
Because it’s so new, Gigabit Ethernet devices are still quite 
expensive. 

 
A network PCI 
adapter for a 
desktop computer. 

Photos courtesy of LinkSys, a 
Division of Cisco Systems, Inc. 
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Lesson 1-7: Wireless 
Networks 
 

One of the hottest new technologies in the computer world is wireless networking or WiFi, 
which lets you connect computers without any wires. Wireless networks allow computers to 
“talk” to each other by broadcasting and receiving radio waves. Wireless networks are often 
simply part of a larger, Ethernet network. 

Of course, WiFi networking has its own set of pros and cons: 
Wireless Networking Advantages 

• Simplicity: Wireless networks are often very simple to set up because there aren’t any 
messy wires involved. 

• Public Availability: If you have a laptop with WiFi capability you can browse the 
Internet and check your e-mail from thousands of wireless hotspots in coffee shops, 
airports, and hotels. 

• Convenience: Wireless networks are downright cool—nothing is more amazing than 
browsing the Web on your laptop while you’re sitting in the living room in front of the 
television or outside on the porch. 

Wireless Networking Disadvantages 
• Security: …or lack thereof. WiFi broadcasts information just like a radio transmitter, so 

it can be easy for an unauthorized computer to listen in and gain access to your network. 
There are a number of ways to secure a wireless network; the problem is that many 
people simply don’t know how to do it. 

• Interference: A wireless network shares the same crowded frequency as other wireless 
networks—and cordless phones too! All those devices can cause a lot of interference and 
as a result many wireless networks are quite unreliable. 

Hotspots and Access Points 
You can find wireless network hotspots that let you browse the Internet and check your e-mail 
in many places outside the home or office. A hotspot is a place where you can connect to a 
wireless network. There are many wireless hotspots now available in such places as 
restaurants, hotels, coffee shops and airports. 

Wireless Security 
Wireless network hotspots can be open or secure. If a hotspot is open, then anyone with a 
wireless network card can access the hotspot. If the hotspot is secure, then the user will 
usually need to know the WEP key to connect to it. WEP stands for Wired Equivalent Privacy, 
and it is a way to encrypt the information that a wireless network sends through the air. There 
are two variations of WEP: 64-bit encryption (really 40-bit) and 128-bit encryption (really 

Figure 1-16 

A diagram of a very simple 
wireless or WiFi network. 

Figure 1-17 

Here’s what you’ll need to 
set up a WiFi network. 
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Wireless routers and 
access points 
broadcast and 
receive network 
information. 

 
A wireless network 
(WiFi) PCMCIA 
adapter for a 
notebook computer. 
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WiFi Shopping List 

• WiFi Network Cards 

• Wireless Access Point or Router 

• Cable or DSL Modem 
 

Figure 1-17 
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 Quick 
Reference 
Wireless Networking 
Advantages: 
• Simple to set up 
• Public availability 
• Convenient to use 

Wireless Networking 
Disadvantages: 
• More security issues and 

problems. 
• Interference and reliability 

problems. 

Wireless (WiFi) Standards 
• 802.11b 

Speed: 10 Mbps 
Range: 150 feet 
Availability: Very common 

• 802.11a 
Speed: 54 Mbps 
Range: 100 feet 
Availability: Rare 

 • 802.11g 
Speed: 54 Mbps 
Range: 150 feet 
Availability: Common – 
also compatible with the 
more common 802.11b 
standard. 

104-bit). 40-bit encryption was the original standard but it was easily broken. 128-bit 
encryption is more secure and is what most wireless networks use. 

What You Need to Add a Wireless Hotspot to an Existing Network 
If you already have several computers connected by an Ethernet network you can easily add a 
WiFi hotspot to the mix. Here’s what you’ll need: 
• Wireless Access Point: A wireless access point normally plugs into a wired Ethernet 

network and acts as the network’s “radio station”, broadcasting and receiving information 
to and from WiFi-enabled computers and devices on the network. Try to get an access 
point that uses the 802.11g wireless standard, described in Table 1-5: WiFi Network 
Standards. 

• Wireless Network (WiFi) Cards: Any computers you want to connect to a wireless 
network must have a wireless network or WiFi card. WiFi is already built in to many 
newer laptops. If your laptop doesn’t have WiFi you can buy a PCMCIA card or an 
external USB port adapter. For desktop computers, you’ll need a PCI card that you install 
inside the machine, or a external USB port adapter. Try to get cards that use the 802.11g 
wireless standard, described in Table 1-5: WiFi Network Standards. 

In a typical home or office, your new hotspot will cover about 100 feet in all directions, 
although walls and floors do dramatically reduce this range. 

What You Need to Create a Wireless Network from Scratch 
Even if you’re starting at the very beginning, there’s no need to get discouraged. Here’s what 
you’ll need: 
• Wireless Access Point or Wireless Router: If you’re building a network from 

scratch you will probably want to use a wireless router instead of a wireless access point. 
A wireless router is a single device that contains: 1) A port to connect to a cable or DSL 
modem, 2) a firewall, 3) an Ethernet hub, 4) a router, and of course, 5) a wireless access 
point. 

• Wireless Network (WiFi) Cards: Once again, any computers you want to connect to 
a wireless network must have WiFi networking cards or adapters installed. 

• Cable Modem or DSL Modem (Optional): A modem connects computers to the 
Internet through an existing phone line or cable connection. Cable modems and DSL 
modems are both very fast and can connect all the computers in a home or small office 
network to the Internet. If you subscribe to a high-speed Internet service they will almost 
certainly set up the cable modem or DSL modem for you. 

If wireless networking wasn’t complicated enough, there are several different wireless 
standards out there that you have to be aware of. Table 1-5: WiFi Network Standards briefly 
describes these standards. 

Table 1-5: WiFi Network Standards 
Standard Speed Range Description 
802.11b 10 Mbps  150 feet 802.11b was the first version to reach the market. It is the 

most common, inexpensive, and, at only 10 Mbps, the 
slowest of all wireless standards. 

802.11a 54 Mbps 100 feet 802.11a was a short-lived standard that was much faster 
(54 Mbps) than 802.11b but had a shorter range. 802.11a is 
incompatible with the 802.11b standard, so don’t expect to 
find it in your local coffee shop. 

 
A wireless network 
(WiFi) PCI adapter 
for a desktop 
computer. 

Photos courtesy of LinkSys, a 
Division of Cisco Systems, Inc. 
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Standard Speed Range Description 
802.11g 54 Mbps 150 feet 802.11g combines the best of both worlds: It has the range 

of 802.11b and the speed of 802.11a. Best of all, 802.11g is 
fully compatible with the very common 802.11b standard. If 
you get any wireless network equipment make sure it 
conforms to the 802.11g wireless standard. 
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Chapter One Review 

Lesson Summary 

Introduction to Networks 

• Network Benefits: The ability to share information, share equipment, and use network software.  

• LAN: Stands for Local Area Network and connects computers in the same geographic area or 
building, using cables. 

• WAN: Stands for Wide Area Network and connects computers across a large geographic area. 

• Peer-to-Peer/Workgroup: Files and resources are shared on every computer. Easier to setup but 
very insecure. 

• Client/Server Network: Files are stored on a single central computer, or server. More secure and 
expensive. 

A Look at Common Network Hardware 

• The four basic hardware requirements for an Ethernet network are network interface cards, a 
network hub or switch, an Ethernet CAT-5 cable, and a cable or DSL modem. 

• The three basic hardware requirements for a wireless or WiFi network are WiFi network cards, a 
wireless access point or router, and a cable or DSL modem. 

Intranets and Extranets 

• Intranet: A miniature version of the Internet that works on a network within a company or 
organization. 

• Extranet: A miniature version of the Internet that allows access to authorized outside users, such 
as business partners. 

• Risks Involved in Working in a Network Environment: The potential loss of autonomy, privacy, 
and security; the potential of network-wide systems failure; and vulnerability to a network virus 
attack. 

Telephones and Networks 

• An analog modem converts a computer’s ones and zeros to tones that can then be transmitted 
over standard phone lines. Analog modems are limited to speeds of 56Kbps. 

• A digital modem uses binary ones and zeros to transmit data like a computer. Digital modems can 
transmit information much faster than analog modems. 

• Bandwidth refers to the amount of data that can be passed along in a given period of time. 

• PSTN, PSDN: Ordinary, everyday telephone network, limited to 56Kbps. 

• ISDN: An older broadband connection, twice as fast as a traditional modem at 128Kbps. 

• T1: 60 times as fast as a traditional modem at 1.544Mbps. 

• ASDL, DSL: Fast digital connection with speeds up to 8,000Kbps. 
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• Cable: Fast digital connection with speeds up to 4,000Kbps. 

The Internet 

• Internet: The Internet is the largest computer network in the world and connects millions of 
computers. 

• World Wide Web: A way of accessing information over the Internet. 

• Internet Service Provider (ISP): An ISP provides its users with constant access to the Internet. 

Ethernet Networks 

• The four main advantages of Ethernet networks are reliability, support, speed, and security. One 
disadvantage is that the wiring can be difficult to set up. 

• The three most common Ethernet speeds are 10 Mbps (10 Base-T), 100 Mbps (100 Base-T), and 
1,000 Mbps (Gigabit). 

Wireless Networks 

• The three main advantages of wireless networking are simplicity, public availability, and 
convenience. Two disadvantages are security and interference/reliability. 

• Three wireless network standards are 802.11b (Speed: 10 Mbps, Range: 150 ft., Availability: Very 
common), 802.11a (Speed: 54 Mbps, Range: 100 ft., Availability: Rare), and 802.11g (Speed: 54 
Mbps, Range: 150 ft., Availability: Common—also compatible with the more common 802.11b 
standard). 

Quiz 

1. Which of the following is NOT a benefit of networking? 

A. The ability to share equipment. 
B. The ability to broadcast information over the Internet. 
C. The ability to use network software. 
D. The ability to share information. 

2. A WAN connects computers in the same building or facility. (True or False?) 

3. What does LAN stand for? 

A. Linked Area Network  
B. Lots of Anarchy and Nonsense 
C. Local Area Network 
D. Linked Applications Node 

4. An Intranet is a miniature version of the Internet that works on a network 
within a company or organization. (True or False?) 
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5. The following are all types of computers that can be used as servers, 
except: 
A. Minicomputers 
B. UNIX computers 
C. Mainframe computers 
D. Handheld computers 

6. Which of the following modems is the slowest? 

A. ISDN 
B. DSL 
C. Cable 
D. Telephone 

7. All users on a network must be authorized by a network administrator. 
(True or False?) 

8. Which one of the following is NOT used to measure data transmission 
rates? 

A. MPH 
B. Kbps 
C. Mbps 
D. Bits per second 

9. The Internet is a relatively small computer network, consisting of hundreds 
of smaller computer networks. (True or False?) 

10. Which of the following are examples of “high bandwidth” Internet 
connections? 

A. Cable modem 
B. Telephone 
C. T1 
D. DSL 

Quiz Answers 
1. False. A WAN connects computers over wide geographic areas. 

2. B. The ability to broadcast information over the Internet is not a benefit of networking. 
It’s not even a component! 

3. C. LAN stands for Local Area Network. 

4. True. An Intranet is a miniature version of the Internet that works on a network within a 
company or organization. 

5. D. Handheld computers cannot be used as servers. 

6. D. A telephone dial-up modem is much slower than the other digital modems. 

7. True. A network administrator is responsible for keeping a network safe and secure for all 
users. 

8. A. MPH stands for miles per hour, and has nothing to do with data transmission rates. 
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9. False. The Internet is the largest computer network in the world, connecting millions of 
computers. 

10. A, C, and D are all examples of “high bandwidth” Internet connections.  

 



Chapter Two: 
Electronic Mail 

Chapter Objectives: 

• Understand e-mail and e-mail addresses 

• Compose and send e-mail 

• Open and close an e-mail message 

• Reply to and forward a message 

• Find and sort messages 

• Work with attachments 

• Use folders 

• Select one or more mail messages 

• Delete messages 

• Marking and flagging messages 

• Saving messages to the hard drive 

• Backing up and archiving mail 

• Work with the address book 

• Understand network etiquette, Spam, and viruses 

Unless you’ve been hiding out in a cave for the past ten years, you already know that e-mail 
lets you send electronic messages to the staff at the office or to people all over the world. You 
probably also already know e-mail is fast (usually instantaneous) and economical (many 
e-mail accounts are completely free). The application that you will be using in this chapter is 
Microsoft Outlook 2000, but there are many, many other e-mail programs available.  

This chapter will teach you the basics of using an e-mail application. You will learn what the 
different Outlook tools are and how they can make you more productive and organized. You 
will learn how to compose and send an e-mail message, find and organize messages, add an 
address to the Contacts list, and much more. Are you ready? Then let’s get started! 

 Prerequisites 
• A computer with 

Outlook 2000 installed. 
• An understanding of 

basic computer 
functions (how to use 
the mouse and 
keyboard).  

• How to start Microsoft 
Outlook and use the 
Outlook bar. 

• How to use menus, 
toolbars, and dialog 
boxes. 
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Lesson 2-1: Understanding E-
mail and E-mail Addresses 
 

Electronic mail can be accessed in many ways, including via electronic mail software such as 
Microsoft Outlook, Eudora, or America Online; via web-based systems such as Hotmail; via 
integrated applications such as Lotus Notes; and via cell phone or other wireless device.  

Microsoft Outlook is a messaging and personal information manager, or PIM. Outlook lets 
you send and receive e-mail messages, schedule appointments, and organize your contacts 
and addresses. It also reminds you of tasks you need to complete. For many people, Outlook 
is often the least-used Microsoft Office application—unless you’re part of a large 
organization, in which case Outlook may be your most-frequently used application. 

Within an organization’s internal network, electronic mail messages are routed from one user 
to another user via network servers. In order to send mail to the correct recipient, the local 
electronic mail software must know who is who on the network. For example, just like you 
need to know a person’s street address if you want to send them a letter, you need to know a 
person’s e-mail address if you want to send that person an e-mail message. Figure 2-1 is an 
example of what a typical e-mail address looks like.  

E-mail addresses consist of three parts: a User Name, a Domain Name, and a Top Level 
Domain (TLD). 
• User Name: The User Name refers to the name of the person’s e-mail account. It is 

similar to the person’s name on an envelope. 
• Domain Name: The Domain Name, also known as the Host Name, refers to the 

location of the person’s account on the Internet. It is similar to the address on an 
envelope. The User Name and Domain name are separated by the @ symbol. 

• Top Level Domain (TLD): The TLD falls at the end of an e-mail address and is 
preceded by a period, or “dot.” This refers to the type of organization or country where 
the person’s e-mail account is located. It is similar to the state or country on an envelope. 

Figure 2-1 
An e-mail address 
consists of a User name, 
Domain Name, and a Top 
Level Domain (TLD). 

 IC3 

Objective: 3.2.1.1, 3.2.1.3, 
3.2.1.5, and 3.2.1.6 
Req. File: None 

JaneDoe@anybusiness.com
Top Level Domain (TLD) 

Figure 2-1 

This is the name of 
the person’s e-mail 
account. It is similar 
to the person’s 
name on an 
envelope. 

This is the location 
of the person’s 
account on the 
Internet. It is similar 
to the address on 
an envelope. 

Domain NameUser Name 
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That’s all there is to an e-mail address. Pretty simple stuff, huh? It is also important to 
remember that e-mail isn’t the only way to send electronic messages. Other popular 
messaging systems include paging or Instant Messaging/Text Messaging delivered via 
computers, cell phones, and wireless devices. 

Move on to the next lesson to learn how to compose and send e-mail. But first, go ahead and 
take a look at the following table for some examples of commonly used Top Level Domains. 

Table 2-1: Examples of Commonly Used Top Level Domains 
TLD Description 
.biz Reserved for businesses only 

.com This is the most common Top Level Domain and it is reserved for commercial 
enterprises. 

.edu Reserved for educational institutions and universities 

.gov Reserved for United States government agencies 

.mil Reserved for the United States military 

.net This is most often used by Internet Service Providers (ISPs), but it is reserved 
for any network group. 

.org Reserved for non-profit organizations 

.info Used in all types of domains 

 

 Quick 
Reference 

Understanding E-mail 
Addresses: 
• User Name: The User 

Name refers to the name 
of the person’s e-mail 
account.  

• Domain Name: The 
Domain Name, also 
known as the Host Name, 
refers to the location of 
the person’s account on 
the Internet.  

• Top Level Domain 
(TLD): The TLD refers to 
the type of organization, 
or the country, where the 
person’s e-mail account is 
located. 
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Lesson 2-2: Composing and 
Sending E-mail 
 

This lesson explains the most basic e-mail task of all: how to compose and send an e-mail 
message. 

Before we begin, however, it is important to take note of the fact that sometimes other forms 
of correspondence are more appropriate than e-mail. Some communication, such as the 
transmission of legal documents that require a signature, should be sent via traditional 
delivery methods rather than electronically. 

11.. Start the Microsoft Outlook program and make sure you are in the Inbox 
folder – click the Inbox button on the Outlook Bar if you’re not. 
The Inbox appears. 

22.. Click the  New Mail Message button..  
An Untitled – Message form appears, as shown in Figure 2-2, ready for you to enter a 
new message. First, you need to specify the recipient’s e-mail address in the To field. 
There are two ways to do this: 
• If you know the e-mail address, you can type it into the To: box. 
• If you don’t know the address, you can click the To: button and select the 

address from your list of contacts. 
In this exercise, we will send the same message to two people, using both methods. 
First let’s enter a name directly into the To box… 

Figure 2-2 

The New Message 
Window. 

Figure 2-3 

The Select Names dialog 
box. 

 IC3 

Objective: 3.2.1.2, 3.2.2.1, 
and 3.2.3.4 
Req. File: None 

 
Inbox button 

 
New Mail 
Message 
button 

To: Enter the recipient(s) of the message.

Cc: Send a copy of the message to these 
recipients. 
Subject: Enter the subject of the message. 

Body: Type your e-mail message here, as you 
would using a word processor. 

Formatting Toolbar 

Figure 2-2 

Standard Toolbar 

Add to To: list 

Add to Cc: list 

Add to Bcc: list 

Select the recipient(s)… 

Figure 2-3 

…then click one of the 
following buttons: 

Provides a space for 
you to type the name of 
a contact or group. As 
you type in a name, 
Outlook will select the 
contact or group from 
the list that matches 
most closely. 
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 Quick 
Reference 
To Compose a Message: 
1. Click the Inbox button on 

the Outlook Bar. 
2. Click the New Mail 

Message on the toolbar. 
3. Type the recipient’s 

address in the To field. 
Or… 

 Click the To button to the 
left of the To text box, 
choose the name of the 
recipient from the Name 
list, then click the To 
button. Click OK when 
you’re finished. 

4. Click the Subject text box 
and enter the message’s 
subject. 

5. Click the pointer in the 
lower pane and type the 
message. 

6. Click the Send button on 
the toolbar to send the 
message. 

33.. Type your e-mail address into the To text box. 
If you need to send a message to more than one person, simply place a comma (,) 
between the recipients’ e-mail addresses—for example: JohnH@acme.com, 
BettyT@yahoo.com. Let’s send this message to another person, this time using the 
address book to address the message. 

44.. Click the To button. 
The Select Names dialog box appears, as shown in Figure 2-3. 

55.. Click the Show Names from the: arrow and select Contacts if 
necessary. 
This will display the names and addresses in the Contacts folder. 

66.. Click the name of any recipient in the Name list and then click the To 
button. 
If you need to send a message to more than one person, you can repeat Step 6 to add 
the other recipients. When you’re finished, move on to the next step. 

77.. Click OK. 
The Select Recipients dialog box closes, and the recipient(s) appear in the To field. 

88.. (Optional) To send a copy of a message to someone, click in the Cc field 
and/or the Bcc field and Repeat Steps 3-7 to enter their e-mail 
addresses, only click the Cc or Bcc button instead of the To button. 
Table 2-2: Ways to Address an E-mail Message describes carbon copies (Cc) and Blind 
Carbon Copies (Bcc). Next, enter the subject of the message so your recipient(s) will 
know what your message is about. The subject will appear in the heading of the 
message in the recipient’s inbox. 

99.. Click the Subject field and type Greetings from Timbuktu! 
Now you can type an actual e-mail message. 

1100.. Click anywhere in the body of the message (in the lower pane) and type: 
Hi everyone – just wanted you to know that my vacation in 
Timbuktu is going great!  

Type the message as you would in a word processor. All the generic Windows 
commands such as cutting, copying, and pasting text work in Outlook.  

1111.. When you’re finished with the message, click the Send Message button 
on the toolbar. 
The message is sent to the Outbox folder and will be sent the next time that you click 
the Send and Receive button. 

1122.. Click the Send and Receive button on the toolbar. 
Outlook sends all the messages that are stored in the Outbox folder and retrieves any 
new e-mail messages it finds on the e-mail server. 

Table 2-2: Ways to Address an E-mail Message 
Address Description 
To Sends the message to the recipient you specify (required). 

Carbon Copy (Cc) Sends a copy of the message to a recipient who is not directly involved, but 
might be interested in the message. 

Blind Carbon Copy 
(Bcc) 

Sends a copy of the message to a recipient without anyone else knowing that 
he or she received the message. You need to select View → Bcc Field from the 
menu to use the Bcc Field. 

 
To button

 
Send Message 

button
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Lesson 2-3: Specifying 
Message Options 
 

Most of the letters you mail are probably delivered by the postal service and require a 
first-class stamp. Sometimes you may need to mail a letter or package that requires special 
delivery options, such as parcel insurance, certification that the letter was received, or 
overnight delivery. Similarly, you can specify options for your e-mail messages. You can mark 
messages as urgent, specify a delivery receipt for e-mail messages, or even redirect certain 
messages to other people. 

11.. Click the New Mail Message button on the toolbar. 
First, let’s compose an e-mail message to ourselves… 

22.. Create the following e-mail message: 
TO: (Enter your own e-mail address here.) 
Subject: Help from Timbuktu! 
Body: Please send money and start trying to get me another 
passport! I lost my wallet! 

An e-mail message this important needs some special delivery options! To specify 
options for an e-mail message, click the Options button on the toolbar. 

33.. Click the Options button on the toolbar. 
The Message Options dialog box appears, as shown in Figure 2-5. Table 2-3: Message 
Options describes the various settings you’ll see in the Message Options dialog box. 

NOTE: If you are using Outlook in an Internet Only environment, some of the options 
will not appear in the Message Options dialog box. 

Figure 2-4 

The Standard toolbar for a 
new mail message. 

Figure 2-5 

The Message Options 
dialog box lets you specify 
such options as the 
message’s level of 
importance and sensitivity. 

 IC3 

Objective: 3.2.2.6 and 
3.2.3.2 
Req. File: None 

 
Options button 

Other Ways to Change a 
Message’s Options: 
• Select View → 

Options from the 
menu. 

Figure 2-5 

Figure 2-4 

Send the message 
to the Outbox 

Save a draft of 
the message 

Cut Copy 

Paste 

Add a 
signature

Open the 
Address Book

Check 
names 

Flag 
message 

Specify other 
message options 

Mark as 
Urgent 

Mark as low 
importance 

Office 
Assistant 

Print 
Attach a 
file 
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 Quick 
Reference 
To Specify Message 
Options: 
1. Click the New Mail 

Message button on the 
toolbar and create the 
message. 

2. Click the Options button. 
3. Specify the message 

options and click OK. 

To Mark a Message as 
Urgent: 
• Click the Importance: 

High button on the 
toolbar. 

You want to mark this message as urgent, and you want to receive notification of when 
the message is delivered and when the recipient opens the e-mail to read it. Let’s start 
with marking the message as high importance. 

44.. Click the Importance list arrow and select High from the list. 
Actually, you don’t have to open the Message Options dialog box at all to mark a 
message as urgent. Simply click the Importance: High button on the toolbar instead. 
Next, you want to request both a delivery receipt and a read receipt for the message. 
Here’s the difference bewteen the two: 
• Delivery Receipt: Outlook will send you notification when the message is 

successfully delivered to the recpient (which is usually almost instantanous.) 
• Read Receipt: Outlook will send you notification when the recpient opens and 

(hopefully) reads the message. 
55.. Check both the Request a delivery receipt for this message and the  

Request a read receipt for this message boxes. 
Those are all the options we need to this particular e-mail. 

66.. Click Close to close the Message Options dialog box. 
Let’s send our urgent message! 

77.. Click the Send Message button on the toolbar. 
Depending on how Outlook is configured on your computer, you may have to perform 
the next step to send the e-mail message out immediately. 

88.. Click the Send and Receive button on the toolbar. 
Outlook sends all the messages that are stored in the Outbox folder and retrieves any 
new e-mail messages it finds on the e-mail server. 
You can also insert automatic signatures, create out-of-office messages, and even 
specify mail format. We’ll discuss these options later on in the chapter. 

 Table 2-3: Message Options 
Option Description 
Importance Specifies whether the message is of high, normal, or low importance. 

Sensitivity Displays a tag indicating how the recipient should treat the message. 

Security Encodes the message so it is not readable by anyone except the recipients.  

Use voting buttons Allows the sender to tally votes over email. 

Tell me when this 
message has been 
delivered 

Returns a message to you verifying the date and time the message arrived at 
the post office of the recipient. 

Tell me when this 
message has been 
read 

Returns a message to you verifying the date and time the message was 
opened by the recipient. This feature can be extremely beneficial, especially if 
something goes wrong and your messages are not being sent or received. 

Have replies sent to Sends replies to this message to someone else, such as an assistant. 

Save sent message 
to 

Saves a copy of the sent message in the specified folder. 

Do not deliver before Keeps the message in your Outbox folder until the date and time you specify. 

Expires after Makes the message unavailable after the specified date and time. 

Other Ways to Mark a 
Message as Urgent: 
• Click the  

Importance: High 
button on the toolbar. 

 
Send button 

Other Ways to Send an 
E-mail: 
• Press <Alt> + <S>. 

 
Send and 

Receive button
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Lesson 2-4: Opening and 
Closing an E-mail Message 
  

This lesson explains how to receive and read your e-mail messages in Outlook – and then 
what you can do to your messages after reading them. You’ll find it’s a lot easier to retrieve 
and read e-mail messages than it is to sort through and read postal mail – no envelopes to tear 
open, and no scribbled handwriting to decipher. Let’s get started! 

11.. If necessary, click the Inbox button on the Outlook Bar. 
The contents of the Inbox folder appear in the upper-right pane of the Outlook window, 
as shown in Figure 2-6. Let’s check and see if you have any new e-mail. 

22.. Click the Send and Receive button on the Outlook bar. 
Normally, Outlook automatically checks your mail server for new messages every 30 
minutes. If it finds any new messages on your mail server, it downloads them and saves 
them to your computer. You can force Outlook to check for new messages by clicking 
the Send and Receive button. If you connect to the Internet with a modem connection, 
outlook will automatically dial out and connect to the Internet to establish a connection 
with your mail server. 
Your new messages are saved in the Inbox folder. Any new, unread messages appear in 
bold and have an unopened message icon next to them. Here’s how to open and read a 
message. 

33.. Click the Greetings from Timbuktu! message you sent yourself earlier. 
The contents of the message appear in the lower right-hand pane of the Outlook 
program screen, and the From and Subject information appear at the top of this pane. 
You can also open a message in its own window – this is especially helpful when you 
want to read a long message. Simply double-click the message you want to read.  

Figure 2-6 

The Inbox. 

 IC3 

Objective: 3.2.2.1 
Req. File: Message created 
in Lesson 2-2: Composing 
and Sending E-mail. 

 
Send and 

Receive button 
Other Ways to Check for 
New Messages: 
• Press <F5> or  

<Ctrl> + <M>. 
• Select Tools → Send 

and Receive and select 
your account from the 
menu. 

This area displays the 
messages in the 
highlighted folder.  Click or 
double-click the message 
you want to read. 
 
Messages that have not 
been opened appear in 
bold and have a closed 
envelope ( ). A paper 
clip ( ) indicates an 
attached file. 

The contents of the 
selected message appear 
in this area.

Figure 2-6 
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 Quick 
Reference 
To Receive and Read 
E-mail Messages: 
1. Click the Inbox button on 

the Outlook bar. 
2. Click the Send and 

Receive button on the 
toolbar. 

3. Click or double-click the 
message you want to 
read. 

 Or… 
 Select File → Open from 

the menu. 

To Close an E-mail 
Message: 
• Click the Message 

window’s Close button. 
Or… 
• Select File → Close from 

the menu. 
Things you can do with an 
E-mail Message: 

• Reply to the message 
• Forward the message 
• View or download any 

attachments 
• Print the message 
• Delete the message 
• Move the message to a 

different folder 
• Ignore the message. 

44.. Double-click the Greetings from Timbuktu! message. 
The message appears in its own window. You can close the message window when 
you’re finished reading it by clicking the window’s close button. 

55.. Close the message window by clicking its Close button. 

The message window closes and you return to the Inbox. 
Once you have received a message, there are several things that you can do with it. You 
can select the message and do one or more of the following: 
• Reply to the Message: When you reply to a message, Outlook opens a 

Message form that contains the e-mail address, subject, and body of the message 
you are responding to. To reply to a message, click the Reply button on the 
toolbar. 

• Forward the Message: When you forward a message to another recipient, 
Outlook opens a Message form that contains the subject and body of the 
message you are forwarding. You must specify to whom you want to forward the 
message in the To box. To forward a message, click the Forward button on the 
toolbar. 

• View or Download any Attachments: Messages with a  icon have one or 
more files attached to them. To view and/or download these files, click the 
paperclip icon on the message header and select the files you want to open or 
view. 

• Print the Message: To print a message, click the Print button on the toolbar. 
• Delete the Message: To delete a message, press the <Delete> key. 
• Move the Message to a Different Folder: If you’re the type of person who 

has your desk and filing cabinets neatly organized, you can create your own set 
of folders and move important messages that you want to save to those folders. 
We will discuss creating and working with your own folders later. 

• Ignore the Message: Most people don’t do anything with their messages, and 
let them fill their inbox like a stack of unpaid bills. Having lots of old e-mail 
messages in your Inbox makes it more difficult to find important messages. 

Check out Table 2-4: Message Icons for explanation of the icons that appear with your e-mail 
messages and then move on to the next lesson to learn how to Reply to an e-mail message! 

Table 2-4: Message Icons 
Icon Description 

  Unopened Message This message has not yet been read or opened. 

 Opened Message This message has been read (or at least opened). 

 Reply You have replied to this message. 

 Forward This is a forwarded e-mail message. 

 Attachment This message has one or more files attached to it. 

! Urgent This message is marked as urgent—you better look at it fast! 

 Flagged This message has been flagged to remind you about something. 

Other Ways to Close an 
E-mail Message: 
• Select File → Close 

from the menu. 
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Lesson 2-5: Replying to a 
Message 
  
  

You can reply to an e-mail message just like you would answer a letter. Replying to an e-mail 
message is incredibly easy—you don’t even need to know the person’s e-mail address; just 
click the Reply button, write your response, and Outlook takes care of the rest. Read on to 
find out how! 

11.. Select the Greetings from Timbuktu! message you sent to yourself 
earlier. 
Next, you need to decide who you want to respond to. You have two choices: 
• Reply: Sends the reply only to the author of the message. 
• Reply to All: Sends the reply to everyone who received the message. 

NOTE: Sometimes “Reply to All” can lead to people being sent inappropriate or 
irrelevant mail messages that can embarrass the sender or inconvenience the 
recipient(s). If you select this option, make sure everyone is applicable. 

22.. Click the Reply button on the toolbar. 
A new Message form appears where you can type your reply. Outlook automatically 
fills in the recipient’s e-mail address and subject line in the new Message form—
although you can change this information if you want. 

Figure 2-7 

A reply to a message with 
a copy of the original 
message included. 

Figure 2-8 

Copied information in a 
Reply. 

 IC3 

Objective: 3.2.2.1, 3.2.3.2, 
and 3.2.3.5 
Req. File: Message created 
in Lesson 2-2: Composing 
and Sending E-mail. 

 
Reply button 

 
Reply to All 

button 

Type your reply here. 

When you reply to a message, 
Outlook fills in the address and 
subject fields for you. 

A copy, or quote, of the original 
message is included to help the 
reader know which message 
you are replying to. 

Figure 2-7 

Figure 2-8 

Oftentimes, web-based 
e-mail applications will 
format copied information 
in a reply message.  

Characters, such as 
carets, are used to 
indicate the message is 
not original.   



 Chapter Two: Electronic Mail 39 

Institute of Applied Technology 

 Quick 
Reference 
To Reply to a Message: 
1. Find and open the 

message you want to 
reply to. 

2. Click the reply option you 
want to use: 

 Reply sends the reply 
only to the author of the 
message. 

 Reply to All sends the 
reply to everyone who 
received the message. 

3. Type your reply and click 
the Send button on the 
toolbar when you’re 
finished. 

To Delete the Original 
Message Copy: 
• Select the original 

message text and press 
the <Delete> key. 

Notice that Outlook also includes a copy, or quote, of the original message in order to 
help the reader know which message you are replying to (see Figure 2-8). This helps 
track the “history” of the e-mail message, and comes in handy when you are answering 
a question and want to include the original question in your reply. Most e-mail 
programs will automatically copy selected information from one e-mail message to the 
other, but if you don’t want to include this information, it’s easy to delete it. 

33.. Select all of the original message text and press the <Delete> key. 
The copy of the original message is deleted. You now have a blank Message form. 
After what we talked about, however, it’s probably a good idea to include the original 
message. Let’s undo your last action. 

44.. Press <Ctrl> + <Z>. 
The original message reappears. 
Now all you have to do it enter a response to the message. 

55.. Press <Ctrl> + <Home> to go to the beginning of the message and type 
Glad to hear you’re having such a great time. By the way, 
you left your wallet here at the office. 
We’re ready to send the message. 

66.. Click the Send button on the toolbar. 
The message is sent to the Outbox folder, and will be sent the next time that you click 
the Send and Receive button. 

Actually, some people think replying to an e-mail message is too easy. If you don’t respond to 
your e-mail messages, no one will buy your “I received your message but I haven’t had time 
to write back” and “I’m sorry, I somehow misplaced your address” excuses. 

Other Ways to Undo: 
• Select Edit → Undo 

from the menu. 

 
Send button 

Other Ways to Send an 
E-mail: 
• Press <Alt> + <S>. 
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 Quick 
Reference 
To Forward a Message: 
1. Find and select the 

message you want to 
forward and click the  
Forward button on the 
toolbar. 

2. Enter the recipient’s e-
mail address in the To 
field. 

3. (Optional) Enter your own 
comments in the 
message body area. 

4. Click the Send button on 
the toolbar. 

Lesson 2-6: Forwarding a 
Message 
 

After you’ve read a message, you can add your own comments and forward it to someone 
else. Forwarding a message is very similar to replying to a message, except that you send the 
message on to someone else instead of back to the original sender. Besides the typical 
business correspondence, many people like to forward e-mails, called forwards, that contain 
jokes, inspirational (but almost always untrue) stories, and urban legends. 

This lesson explains how to forward a message. 

11.. Select the Help from Timbuktu! message you created earlier. 
Here’s how to forward the message to another recipient: 

22.. Click the Forward button on the toolbar. 
A new Message form appears with the message you are forwarding. You need to 
specify the recipient to whom you want to send, or forward, the message. 

33.. Click the To button. 
The Select Names dialog box appears. 

44.. Click the Show Names from the arrow and select Contacts, if 
necessary. 
This will display the names and addresses in the Contacts folder. 

55.. Click the name of any recipient in the Name list, click the To button, and 
then click OK. 
The Select Recipients dialog box closes and the recipient(s) appear in the To: field. You 
can also add your own comments about the message you are forwarding. 

66.. Click the message body area and type Can you take care of this? 
We don’t really need to send this e-mail, so you can close it without saving any 
changes. 

77.. Close the message window and click No when asked if you want to save 
your changes. 

Figure 2-9 

A forwarded message. 

 IC3 

Objective: 3.2.2.1 
Req. File: Message created 
in Lesson 2-3: Specifying 
Message Options. 

 
Forward button 

When you forward a message, 
Outlook fills in the subject field 
for you. 

Type your reply here. 

A copy, or quote, of the original 
message is included. 

Figure 2-9 



 Chapter Two: Electronic Mail 41 

Institute of Applied Technology 

Lesson 2-7: Finding Messages 
 

The longer you use Outlook, the more cluttered your Inbox becomes, and the more difficult it 
becomes to find a specific e-mail message. Luckily, Outlook comes with a great Find feature, 
which can search for and track down your lost e-mails. Find searches the From field, Subject 
field, and message text of your e-mails for a specified word or phrase. Even if you can only 
remember a little bit about an e-mail message, the Find feature can probably retrieve it. 

In this lesson, you will learn how to use Outlook’s Find feature to search for e-mail messages 
in your Inbox. 

11.. Click the Find button from the toolbar. 
The Find pane appears at the top of the message window. Normally, all you have to do 
is type the word or phrase you’re looking for in the “Look for” box and click the Find 
Now button. 

22.. Type Timbuktu in the Look for box and make sure the Search all text 
in the message box is checked. 
The “Search all text in the message” box ensures that Outlook looks in the actual text 
of the messages for the specified word or phrase. Let’s see how many e-mail messages 
contain the word, “Timbuktu”.  

33.. Click the Find Now button. 
Outlook searches the Inbox for messages that contain the word and displays the results 
at the bottom of the screen. 
You can close the Find pane when you’re finished using it. 

44.. Click the Close button, located in the upper right-hand corner of the 
Find pane. 
The Find pane closes and Outlook once again displays all the messages in your Inbox. 

The Find feature is a lot more advanced than it looks. By clicking the Advanced Find button, 
you can search for messages specifically by date, subject, importance, and more. 

Figure 2-10 

Outlook’s Find feature lets 
you find e-mail messages 
that contain a specified 
word or phrase. 

 
Find button 

Other Ways to Use Find: 
• Select Tools → Find 

from the menu. 
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Objective: 3.2.2.1 
Req. File: Message created 
in Lesson 2-2: Composing 
and Sending E-mail 

 Quick 
Reference 

To Find a Message: 
1. Click the Find button on 

the toolbar. 
 Or… 
 Select Tools → Find 

from the menu.  
2. Enter the text you want to 

search for in the Look for 
text box. 

3. Check the Search all text 
in the message check 
box to search the actual 
text in your e-mail 
messages. 

4. Click the Find Now 
button.  

Enter the word or 
phrase you want 
to find in a 
message. 

Outlook displays 
the results of the 
search here. 

Click the Find 
button to search 
for a message in 
the Inbox. 

Figure 2-10 
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Lesson 2-8: Sorting Messages 
 

Oftentimes, you will want to view a message that’s buried in your Inbox. You can quickly sort 
your messages by clicking any of the column headings in your Inbox. Clicking the 
“Received” column, for example, sorts the Inbox by when the messages were received. 

Let’s explore some of the sorting options available in your Inbox. 

11.. Make sure you are in Inbox view. 
First, let’s try sorting the e-mail messages in your Inbox by subject. Remember that all 
you have to do to sort your e-mail messages in Microsoft Outlook is to click any of the 
column headings in your Inbox.  

22.. Click the From column heading. 
The messages in your Inbox are sorted by the sender’s name and listed in ascending 
alphabetical order. Let’s see what happens if you click the From column heading again. 

Figure 2-11 

The Inbox with the 
messages sorted by 
subject and listed in 
ascending order. 

Figure 2-12 

The same Inbox with the 
messages sorted by 
sender and listed in 
ascending order. 
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Objective: 3.2.2.1 
Req. File: None 

Figure 2-11 

Figure 2-12 
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 Quick 
Reference 
To Sort Messages: 
• Click the column 

heading you want to use 
to sort the Inbox. 

33.. Click the From column heading again. 
The list of e-mail messages changes order. The messages are sorted according to their 
senders’ names, but now they are listed in descending alphabetical order, rather than 
ascending alphabetical order. 
Next, go ahead and see what the Received column heading does. 

44.. Click the Received column heading. 
This time the messages are sorted chronologically according to the date that they were 
received. 
Take some time and try out some of the other column headings. Try and determine 
which column heading is most useful for sorting your Inbox. 

Although there are many types of fields available for sorting your Inbox, take a look at the 
following table for a description of some of the most common Inbox column headings. 

Table 2-5: Commonly Used Inbox Column Headings 
Sort Description 
Importance Sorts messages according to importance. 

Icon Sorts messages according to icon type. 

Flag Status Sorts messages according to flag status. 

Attachment Separates messages that contain attachments from those who don’t. 

From Sorts messages according to the sender’s name. 

Received Sorts messages chronologically according to the date that they were 
received. 

Subject Sorts messages according to the subject. 
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Lesson 2-9: Attaching and 
Deleting a File 
  

One of the most powerful and useful features of e-mail is the ability to supplement an e-mail 
message with additional information, including attaching one or more files to a message. Such 
files are called attachments and can be pictures, documents, and more. Attachments allow the 
immediate sharing of files with other users. The recipient of an attachment opens the attached 
file in the program in which it was created.  

In this lesson, you will learn how to attach a file to an e-mail message. 

11.. Click the New Message button on the toolbar. 
First we’ll compose another e-mail message to ourselves… 

22.. Create the following e-mail message: 
TO: (Enter your own e-mail address here.) 
Subject: Assault Suspect 
Body: Chief, I received these files in my e-mail this 
morning. I thought you might want to take a look at them.  
It’s a good idea to leave some space between your message and any attachments. 

33.. Press <Enter>. 
OK! You’re ready to attach a file to this e-mail message. Here’s how: 

44.. Click the Insert File button on the toolbar. 
The Insert File dialog box appears. Now you have to find the file you want to attach. 

55.. Navigate to your Practice folder. 
If you do not know where your practice files are located, ask your instructor for 
assistance. 
You use the Look in list and Up One Level button to navigate to the various drives and 
folders on your computer. 

Figure 2-13 

You can attach one or 
more files, called 
attachments, to an e-mail 
message. 

 
Insert File 

button 
Other Ways to Insert a 
File: 
• Select Insert → File 

from the menu. 
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Objective: 3.2.1.2, 3.2.2.2, 
3.2.2.3, and 3.2.3.6 
Req. File: Lineup Letter.doc 
and Suspect.jpg Figure 2-13 

Click the Insert File button to 
attach one or more files to an 
e-mail message. 

Any file attachments appear 
here. 
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 Quick 
Reference 
To Attach a File to an 
E-mail: 
1. Click the New Mail 

Message on the toolbar 
and create the message. 

2. Click the Insert File 
button on the toolbar. 

 Or… 
 Select Insert → File from 

the menu. 
3. Browse to, find, and 

double-click the file you 
want to attach. 

4. To attach additional files, 
repeat Steps 2 and 3. 

To Delete an Attachment: 
• Select the attachment and 

press the <Delete> key. 

66.. Find and double-click the Lineup Letter file. 
An icon representing the Lineup Letter appears at the bottom of the e-mail. You can 
attach more than one file to an e-mail—just repeat the procedures in Steps 4-6. 

77.. Repeat Steps 4-6 and attach the Suspect file. 
It’s just as easy to delete an attachment. All you have to do is select the attachment and 
press the <Delete> key. 

88.. Click the Suspect file to select it and then press the <Delete> key. 
The attachment is deleted. Pretty easy, huh?  
We’re going to need that attachment for the next lesson, so undo your last action. 

99.. Press <Ctrl> + <Z> to undelete the Suspect attachment. 
You’re ready to send this e-mail. 

1100.. Send the e-mail by clicking the Send button on the toolbar. 

You can also 
supplement an e-
mail with hyperlinks 
or graphics 
embedded into the 
body of the 
message. 
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Lesson 2-10: Opening and 
Saving an Attachment 
  

In the previous lesson, you learned how to attach a file to an e-mail message. In this lesson, 
you will learn how to view an e-mail attachment and save it to your hard disk. Let’s get 
started!  

11.. Click the Send/Receive button on the toolbar. 
You should receive the message you sent yourself in the previous lesson. Notice the 
message has a paper clip icon next to it, indicating the message contains an attachment. 

22.. Select the Assault Suspect message. 
A paperclip icon appears on the message header in the Preview pane. To view the 
message’s attachment(s), simply click this icon and select the file you want to view. 

33.. Click the paper clip icon. 
A list of the attachments appears, as shown in Figure 2-14. 

Figure 2-14 

E-mail messages with a 
 paper clip icon have 

attachments. 

Figure 2-15 

Outlook gives you the 
option of opening an 
attachment or saving it to 
a file on your hard disk. 

 IC3 

Objective: 3.2.2.2, 3.2.2.3, 
3.2.3.2 and 3.2.3.6 
Req. File: Previous Lesson  

A paper clip ( ) 
indicates an 
attached file. 

To view an 
attachment, click 
the  icon and 
select the file you
want to open. 

Figure 2-14 

Figure 2-15 
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 Quick 
Reference 
To Open an Attachment: 
• In Preview Mode click 

the paper clip icon, 
select the attachment you 
want to view, select Open 
it, and click OK. 

Or… 
• Open the E-mail by 

double-clicking it and then 
double-click the 
attachment you want to 
view. 

To Save an Attachment to 
Your Hard Disk: 
1. In Preview Mode click 

the paper clip icon, 
select the attachment you 
want to view, select Save 
it to disk and click OK. 

 Or… 
 Open the E-mail by 

double-clicking it, then 
right-click the attachment 
and select Save As from 
the shortcut menu. 

2. Specify a file name and 
location for the 
attachment and click OK. 

44.. Select the Lineup Letter file from the attachment list. 
Outlook opens the Lineup Letter in Microsoft Word. 

NOTE: Not all recipients may be able to open and view certain attachments. 
Oftentimes it is difficult to receive large attachments, and some recipients 
may not be able to display embedded URLs, graphics, or media. It is 
important to know what types of attachments your recipient’s e-mail 
application can handle before sending out loads of critical information. 

55.. Close Microsoft Word. 
Sometimes Outlook will ask you what you want to do with an attachment. Let’s try 
opening the suspect file. 

66.. Click the paper clip icon and select the Suspect file from the 
attachment list. 
The Opening Mail Attachment dialog box appears, as shown in Figure 2-15. Outlook 
displays the Opening Mail Attachment dialog box when its not sure what to do with an 
attachment. You have two choices: 
• Open it: Opens the file in the program that created it (if it’s installed on your 

computer). Since some files can contain viruses, it is recommended that you use 
the Save it to disk option to save files to your hard disk and scan them using an 
anti-virus program before opening them. 

• Save it to disk: Saves the file to your hard disk. Make sure you keep track of 
where you save the file or you may not be able to find it later. 

For this lesson we’ll open the Suspect file. 
77.. Select the Open it option and click OK. 

Outlook opens the Suspect file in a graphics program (provided you have one installed 
on your computer). 

88.. Close the Suspect window. 
You’re back in Microsoft Outlook. 
Attachments are sometimes easier to work with when the e-mail is opened in its own 
form. 

99.. Double-click the Assault Suspect message. 
The Assault Suspect message opens in its own window, and the two attachments appear 
at the bottom of the screen. You can easily save any attachment to your hard disk. 

1100.. Right-click the Suspect attachment and select Save As from the 
shortcut menu. 
The Save Attachment dialog box appears. Make sure that you keep track of the folder 
where you save the attachment. You don’t need to save the Suspect attachment to the 
hard disk, so you can close the Save Attachment dialog box.  

1111.. Click Cancel to close the Save Attachment dialog box and then close the 
Assault Suspect message window. 

One final note on attachments: If you’ve been paying attention to the news the past few years, 
you’ve undoubtedly heard about computer viruses and the havoc they can cause. Many 
computer viruses are spread as e-mail attachments. For example, the dreaded “Melissa” and “I 
Love You” viruses that shut down thousands of computers a few years ago were both e-mail 
attachments. So how do you avoid such viruses? First, never open an attachment that looks 
suspicious or that is from someone you don’t know. Second, make sure you have a good anti-
virus program installed on your computer and that you save files to your hard disk before 
opening them. 
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Lesson 2-11: Managing E-mail 
 

Many people prefer to use e-mail as their primary form of communication. In fact, many 
regard their personal computer e-mail application as their most important program. In recent 
years, the uses for e-mail have expanded rapidly. At first, e-mail was only used as a quick, 
easy, and inexpensive form of communication that offered instantaneous results. E-mail 
applications have developed rapidly and are now used to conduct business transactions; carry 
on extended conversations or contract negotiations; manage daily, weekly, or even monthly 
tasks; and many other types of activities. The result of this “e-mail revolution” is that users 
can end up sending and/or receiving hundreds of e-mail messages every single day, and that 
can be a lot to handle! 

There are multiple types of e-mail messages that may be received in a given day, such as 
online newsletters, business e-mails, personal e-mails, Web order forms, invoices, and the list 
goes on and on. That certainly is a lot of messages to have to deal with on a daily basis! 

This lesson is an overview of the basic Inbox management tasks covered in this chapter. Take 
a look at the suggestions below on managing your e-mail messages effectively and then move 
on to the subsequent lessons to for a more detailed description of each one.  

Use Folders to Organize Your Inbox 
A filing cabinet organizes information into related folders; similarly, e-mail application 
programs store items in their own separate folders. You may be used to folders in Microsoft 
Windows, where they are used to organize files and programs. In Outlook, each module stores 
its information in its own folder, which you can view using the Folder List. 

Just like the folders in a filing cabinet or in Microsoft Windows, sometimes you may find that 
one of your Outlook folders is getting too big to manage and you will need to organize and 
move its information into several new folders or subfolders. For example, you could create a 
“Personal” folder to store all of your personal e-mail messages. Remember that once you have 
created these folders, it is important that you move messages to the appropriate folders right 
away so you do not end up with a cluttered Inbox. 

Many people don’t use the Folder List because the Outlook Bar includes the folder choices 
that people use frequently. If you don’t send and/or receive much e-mail, you probably won’t 
need to work with the Folder List. On the other hand, if you’re having difficulty sorting 

Figure 2-16 

Use folders to organize 
your Inbox so that you can 
save time, prevent 
unnecessary frustration, 
and stay productive. 

Figure 2-17 

If you’re having trouble 
remembering all of the 
contact information for the 
people you communicate 
with on a regular basis, try 
using the address book. 
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Objective: 3.2.2.4, 3.2.2.5, 
3.2.3.2, and 3.2.3.8 
Req. File: None 

Figure 2-16 Figure 2-17 
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through the deluge of e-mail you receive on a daily basis, you will definitely want to read on 
into this chapter to learn how you can use folders to organize your Inbox. 

Delete Unimportant E-mails Immediately 
This may seem fairly obvious, but sometimes this step can be overlooked. When you receive 
an e-mail message, take a second and decide what to do with it. If it is important, or relevant 
to something that you are doing, move the message to an appropriate folder. If the e-mail is 
not important, for example, a note from your daughter asking if she can make spaghetti for 
dinner, delete the message immediately. Deleting unimportant e-mails keeps your Inbox neat 
and tidy, thus preventing “Inbox Overflow.” If you do not delete unimportant e-mails right 
away, your Inbox can become overrun and cluttered, making it difficult to find e-mails that 
are truly important.  

Don’t be afraid to delete e-mail messages. Most applications offer you at least one chance to 
retrieve the message before it is permanently deleted. Outlook, for example, moves deleted e-
mail messages to the Deleted Items Folder. This folder must be emptied for the contents to be 
deleted permanently. If you are familiar with Microsoft Windows, this folder is similar to the 
Recycle Bin that is found on your desktop.  

Use the Address Book and Distribution Lists 
An address book is similar to a phone directory, except it can also store e-mail addresses, 
departments at work, mailing addresses, job titles, and much more! You can use an address 
book both to look up individual addresses and phone numbers and to address e-mail 
messages. Unless you only correspond with two or three people, it’s almost impossible to 
memorize the phone numbers, mailing addresses, and e-mail addresses of everyone that you 
know. Fortunately, if you use the address book, you won’t have to. 

A distribution list, or group, is an entry contained within the address book that is comprised of 
several names. You should use distribution lists to send an e-mail message to every member of 
a group in a single mailing. These groups may include employee groups that work in the same 
department, members working on the same project or committee, or groups of friends. 
Distribution lists show up as items in your address book, much as any other individual entry 
would. You use a distribution list to address an e-mail message just as you would with any 
other contact. Again, these topics will be covered more extensively in lessons to come. 

Managing your e-mail messages may sound complicated now, but when you are finished with 
this chapter, your messages will be neat and tidy. We have a lot of ground to cover in this 
chapter, so let’s quit reading and start doing! 

Table 2-6: E-mail Folders 
Folder Description 

 Inbox 
Stores the messages you’ve received. 

 Outbox 
Temporarily stores any messages that you’ve composed but have not been 
sent. 

 Sent Items 
Stores copies of messages you have sent. 

 Deleted 
Items 

Stores messages that you’ve deleted. 

 Drafts 
Stores draft messages that you haven’t completed yet. 

 Quick 
Reference 

Managing E-mail 
Effectively: 
• Use folders to organize 

your Inbox so you don’t 
have to sift through 
unrelated e-mail 
messages to find the one 
you are looking for. 

 Or… 
• Delete unimportant e-mail 

messages immediately so 
they don’t clutter your 
Inbox. 

• Use the Address Book 
and distribution lists to 
keep your contact 
information current and 
organized. 
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Lesson 2-12: Using Folders to 
Organize Information 
  

A filing cabinet organizes information into related folders; similarly, Outlook stores its 
various items in their own separate folders. You may be used to folders in Windows 95 or 98, 
which are used to organize your files and programs. You can copy, move, and delete files to 
and from the folders on your hard drive. Outlook has its own set of folders for storing the 
items you create in various modules: appointments, contacts, e-mail messages, and so on. 
Each module stores its information in its own folder, which you can view in the Folders List. 

Just like the folders in a filing cabinet or in Windows, sometimes you may find that one of 
your Outlook folders is getting too big to manage and you will need to organize and move its 
information into several new folders or subfolders. For example, you could create a 
“Personal” folder to store your personal e-mail. 

Many people don’t use the Folder List because the Outlook Bar includes the folder choices 
that people normally use. If you don’t receive and/or send much e-mail, you probably don’t 
need to work with the Folder List, either. On the other hand, if you’re having difficulty sorting 
through the deluge of e-mail you seem to receive on a daily basis, you will definitely want to 
review the next few lessons, which explain how you can use folders to organize your Outlook 
information. 

Figure 2-18 

How information is stored 
in a file cabinet. 

Figure 2-19 

How information is stored 
in Microsoft Outlook. 
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organized and grouped into 
folders. 

A folder may contain several 
files and even several 
subfolders. 

Outlook organizes related 
information into folders. 

A folder may contain several 
items and subfolders. 

Figure 2-18 
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Lesson 2-13: Creating a 
Folder 
 

Outlook normally saves all your incoming e-mail messages in the Inbox folder, but sooner or 
later you may need to expand your horizons and create your own folders to help you better 
organize your e-mail messages and other Outlook items. This lesson will show you how to 
create a new folder to hold and organize your e-mail messages.  

11.. Open the Folder List by selecting View → Folder List from the menu. 
The Folder List opens on the left-hand side of the screen. 

22.. Right-click anywhere in the Folder List and select New Folder from the 
menu. 
The Create New Folder dialog box appears, as shown in Figure 2-20. You have to 
specify three things: 1) The name of the new folder, 2) The type of item you want to 
keep in the new folder, and 3) Where you want to place the new folder. 

33.. Click in the Name text box and type Picnic. 
Next, we need to specify what we want to keep in the new folder. 

44.. Ensure Mail Items appears in the Folder contains list. 
Finally, you need to specify where you want to keep the new folder. In this lesson, you 
place the new folder in the Sent Items folder. 

55.. Click the Sent Items folder icon.  
OK—you’re ready to create your new folder. 

66.. Click OK. 
You’re not finished yet! After you create a new folder, Outlook asks if you would like 
to add a shortcut to the folder on your Outlook Bar, as shown in Figure 2-21. 

77.. Click No. 
Outlook creates the new folder under the Sent Items folder. 

Figure 2-20 

The Create New Folder 
dialog box. 

Figure 2-21 

After you create a new 
folder, Outlook asks if you 
would like to add a 
shortcut to the folder on 
your Outlook bar. 
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Enter the name of the new folder. 

Specify the type of item you want to keep in 
the new folder. 

Select where you want to place the new 
folder. You can display the hidden folders 
within a folder by clicking the  plus sign 
beside the folder. 

Figure 2-21 

 Quick 
Reference 

To Create a New Folder: 
1. Right-click anywhere in 

the Folder List and select 
New Folder from the 
shortcut menu. 

 Or…  
 Select File → New → 

Folder from the menu. 
2. Enter the folder’s name in 

the Name text box. 
3. Specify what you want to 

keep in the new folder by 
making a selection form 
the Folder contains list. 

4. Specify where you want 
to keep the new folder by 
clicking the appropriate 
folder’s icon. 

5. Click OK. 
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Lesson 2-14: Renaming, 
Copying, Moving, and Deleting 
a Folder 
  

You probably don’t reorganize the folders in your file cabinet very often—and you probably 
won’t need to move or copy your Outlook folders very often, either. When you find you do 
need to move or copy a folder, however, you can do so by using one of simple methods: 
• Clicking and dragging 
• Using the toolbar or menu 

You’ll learn how to copy and move folders using both methods in this lesson. You’ll also learn 
how to rename and delete a folder. 

11.. Make sure the Folder List is open and locked in place. 
Remember: to open the Folder List, click the Folder banner or select View → Folder 
List from the menu. 

Figure 2-22 

To move a folder, drag it to 
a new location on your 
computer. 

Figure 2-23 

The Copy Folder dialog 
box. 
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Figure 2-22 

Figure 2-23 

You can move 
folders in the Folder 
List by clicking and 
dragging them to 
the desired location.
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 Quick 
Reference 
To Do Any of the 
Following, First Lock the 
Folder List in Place… 
1. Open the Folder List by 

clicking the Folder 
Banner or by selecting 
View → Folder List from 
the menu. 

2. Lock the Folder List in 
place by clicking the 
Push Pin button. 

Then… 
To Rename a Folder: 
• Right-click the folder, 

select Rename from the 
shortcut menu, and enter 
the new name. 

To Delete a Folder: 
• Select the folder you want 

to delete, press <Delete>, 
and click Yes to confirm 
the deletion. 

To Move a Folder: 
• Click and drag the folder 

to the desired location. 

22.. Right-click the Picnic folder and select Rename Picnic from the 
shortcut menu. 
Now you can rename the Picnic folder. 

33.. Type Picnic Project. 
There are several ways to move and/or copy a folder. One of the most common 
methods is clicking and dragging. 

44.. Click and drag the Picnic Project folder to the Inbox folder located 
under the Practice folder, as shown in Figure 2-22.  
You can copy a folder and its contents by holding down the <Ctrl> key as you drag the 
folder. 
You’re probably already beginning to suspect that there are several methods for doing 
exactly the same thing in Outlook. Another popular way of moving or copying folders 
is to use the menu. 

55.. Select the Picnic Project folder and select Edit → Copy to Folder from 
the menu. 
The Copy Folder dialog box appears, as shown in Figure 2-23. All you have to do here 
is specify where you want to copy the folder. 

66.. Click the Notes folder located under the Practice folder. 
This will copy the Picnic Project to the Notes folder. 

77.. Click OK. 
Outlook copies the Picnic Project folder to the Notes folder, although you will have to 
expand the Notes folder to see it. 

88.. Click the expand button ( ) beside the Notes Folder. 
There’s the copied Picnic Project folder. Here’s how to delete a folder: 

99.. Click the Picnic Project folder to select it, and then press the <Delete> 
key. 
A dialog box may appear, asking you to confirm the folder deletion. 

1100.. Click Yes to delete the folder. 
The Picnic Project folder and all its contents are deleted and disappear from the 
window. Outlook places any deleted files or folders in the Deleted Items folder in case 
you change your mind later on and decide you want to restore the folder. 

NOTE: Deleting a folder can be dangerous. Before you delete a folder, make sure it 
doesn’t contain any important information. If you don’t know what the 
contents of a folder are, you shouldn’t delete it. 

There’s no better way to organize Outlook than by creating and using your own folders to 
categorize information—especially if you receive several dozen e-mails every day.  
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Lesson 2-15: Selecting One or 
More Mail Messages 
   

The advantage of selecting Outlook items is that you can move, copy, and/or delete many 
items at once instead of individually. For example, you could select all the e-mail messages 
pertaining to a particular project and move them to a Project folder instead of having to move 
each e-mail message individually. 

In this lesson, you will learn how to select more than one Outlook item at a time so that you 
can move, copy, or delete a group of items at the same time. 

11.. Make sure the Folder List is open. 

22.. Click the Inbox folder.  
Your Inbox may contain several messages that pertain to one subject. You can select 
random, or non-adjacent, items by holding down the <Ctrl> key and then clicking each 
item you want to select. 

33.. Hold down the <Ctrl> key as you click each e-mail message that contains 
the subject, as shown in Figure 2-25. 
Now you can move, copy, or delete any the selected items all at once. 

44.. With the e-mail messages still selected, click and drag any of the selected 
messages to the folder that you created in the last lesson. 
If the folder you created earlier isn’t visible, click the  plus symbol beside the Inbox 
Folder. 
If the items you want to select are adjacent to one another, you can click the first item 
you want to select and then hold down the <Shift> key as you click the last item of the 
group of you want to select. 

55.. Click the first e-mail message, hold down the <Shift> key, and click the 
last message. 
You’ve selected the first message, the last message, and all the messages in between. 

66.. Click anywhere outside the selected messages to deselect them. 
Move on to the next step and close the Folder List. 

77.. Close the Folder List. 

Figure 2-24 

When you want to select a 
group of adjacent items, 
select the first item you 
want to select, hold down 
the <Shift> key and click 
the last item. 

Figure 2-25 

Use the <Ctrl> key when 
you want to select several 
nonadjacent items. 
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Nonconsecutive Items
Press the <Ctrl> key as 
you click each item that 
you want to select. 

Consecutive Items 
Click the first item you 
want to select, press 
and hold down the 
<Shift> key, and click 
the last item you want 
to select. 

Figure 2-24 Figure 2-25 

 Quick Reference 

To Select Several 
Consecutive Items: 

• Click the first item 
you want to select, press 
and hold down the <Shift> 
key and click the last item 
you want to select. 

To Select Several 
Nonconsecutive Items: 

• Press the <Ctrl> 
key as you click each item 
that you want to select. 

To Move E-mail Messages 
to a New Folder: 

• With the desired 
e-mail message(s) selected 
in the Inbox, click and drag 
any of the selected 

 t  th  d i d 
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 Quick 
Reference 
To Delete a Message: 
• Select the message and 

click the Delete button 
on the toolbar. 

Or… 
• Select the message and 

press the <Delete> key. 

To View Deleted Items: 
• Click the Deleted Items 

button on the Outlook 
Bar. 

To Empty the Deleted 
Items Folder: 
• Right-click the Deleted 

Items button on the 
Outlook Bar, select 
Empty "Deleted Items" 
Folder from the shortcut 
menu, and click Yes to 
confirm the deletion. 

Lesson 2-16: Deleting Messages 
 

When you delete an e-mail (or any Outlook item), Outlook places it in the Deleted Items 
folder. Like the Windows Recycle Bin, the Deleted Items folder contains deleted Outlook 
items. If you change your mind and decide you need a deleted message, it’s easy to find and 
retrieve it. This lesson will show you how to open the Deleted Items folder, restore a deleted 
message, and empty the Deleted Items folder. 

11.. Select the Assault Suspect message in your Inbox and press <Delete>. 
Outlook removes the Assault Suspect message from the Inbox and places it in the 
Deleted Items folder. 

22.. Switch to the Deleted Items folder by clicking the Deleted Items button 
on the Outlook Bar. 
The Deleted Items folder displays all the messages you have recently deleted. If you 
accidentally delete a message, you can easily retrieve it. 

33.. Find and select the Assault Suspect message, click the Move to 
Folder button on the toolbar, and select the Move to Folder option. 
Select Inbox from the folder list and click OK. 
Outlook moves the Assault Suspect message back to the Inbox. Occasionally, you will 
want to empty the Deleted Items folder. Here’s how: 

44.. Right-click the Deleted Items button on the Outlook Bar, select the 
Empty "Deleted Items" Folder option from the shortcut menu, and 
click Yes to confirm the deletion. 
Outlook permanently deletes the contents of the Deleted Items folder. 

You can also have Outlook automatically empty the Deleted Items folder every time you quit 
Outlook. Simply select Tools → Options from the menu, click the Other tab, and check the 
“Empty the Deleted Items folder upon exiting” box. Be very careful when deleting all 
messages in the Deleted Items folder, however, because once you do so there is no way to 
retrieve them. 

Figure 2-26 

The Deleted Items folder 
stores all your deleted 
e-mail messages—as well 
as other deleted Outlook 
items. 
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To retrieve a 
message from the 
Deleted Items 
folder, click the 
Move to Folder 
button and select 
the appropriate 
folder (usually the 
Inbox). 

Empty the 
Deleted Items 
Folder by right-
clicking the 
Deleted Items 
button on the 
Outlook Bar and 
selecting the 
Empty Deleted 
Items Folder from 
the shortcut menu. Figure 2-26 



56 IC3 Module 3 – Living Online 

© 2005 CustomGuide, Inc. 

Lesson 2-17: Marking 
Messages as Read or Unread 
 

Sometimes, after you have read an e-mail message, you may want to mark the message as 
unread. You may also want to mark an unread e-mail message as having been read. Doing this 
will change the status of your Inbox.  

To mark an e-mail message as read or unread, you must first open the Edit menu. There are 
several e-mail message status choices here: 
• Mark as Read: Marks an unread e-mail message as having been read. 
• Mark as Unread: Marks an already viewed e-mail message as not having been read. 
• Mark All as Read: Marks all messages in the Inbox as Read so that it appears that there 

are no new e-mail messages waiting to be read. 

11.. Select the Help from Timbuktu! message you created earlier. 
All you have to do to select a message is to click on it. 
You have already read this message, so you want to mark it as not having been read. 

22.. Select Edit → Mark as Unread from the menu. 
The message is now marked as unread, as seen in Figure 2-27. You know that the status 
has changed, because the envelope icon that appears to the left of the message has 
changed from being open to being closed. Also, the message text appears in bold face. 
All new messages appear in bold.  
Go ahead and mark all of the messages in your Inbox as having been read. 

3. Select Edit → Mark All as Read from the menu. 
All of the messages are now shown as having been read. They each have an open 
envelope icon next to the message text and they do not appear in bold.  

Figure 2-27 

The Inbox with the 
“Greetings from Timbuktu” 
message marked as 
unread. 
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Figure 2-27 

 Quick 
Reference 

To Mark an E-mail 
Message as Read or 
Unread: 
1. Select an e-mail message 

from the Inbox. 
2. Select Edit from the 

menu and then choose an 
e-mail message status 
option. 

 Or… 
 Right-click the e-mail 

message and select an e-
mail message status 
option from the shortcut 
menu. 
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 Quick 
Reference 
To Flag an Item: 
1. Right-click the item and 

select Flag for Follow Up 
from the shortcut menu. 

2. Click the Flag to list 
arrow and select a 
category. 

3. (Optional) Click the Due 
by list arrow and select 
the day you want to be 
reminded of the flagged 
item. 

4. Click OK. 

Lesson 2-18: Flagging Items 
  

Flagging is an easy way to remind yourself to follow up on an important e-mail message, 
contact, or task. When you flag an item, a small  icon appears next to the item. You can 
specify a category for a flagged item, such as “Follow up” or “Call” and a reminder date, so 
that Outlook reminds you to follow-up with an item when the specified date arrives. Flags are 
also very useful when used with Outlook’s various views. For example, you can filter out only 
those e-mail messages, contacts, or tasks that are flagged. 

Whether you’re working with a message, task, or contact, the procedure for flagging items is 
the same. Here it is… 

11.. Right-click the Help from Timbuktu! message that you sent yourself 
earlier and select Flag for Follow Up from the shortcut menu. 
The Flag for Follow Up dialog box appears, as shown in Figure 2-29. Here you can 
specify the reason you are flagging the message and add an optional reminder. 

22.. Click the Flag to list arrow. 
As you can see, there are many different categories you can choose from. We’ll use the 
standard Follow Up description for now.  

33.. Choose the Follow Up option from the drop-down list. 
You can also add a reminder to a flag. 

44.. Click the Due by list arrow and select the date of your choice from the 
drop-down calendar. 
That’s all there is to flagging an Outlook item. 

55.. Click OK. 

When you have followed up on a flag, you can either clear it or mark it as complete. Simply 
right-click the item, select Flag for Follow Up from the shortcut menu, and click the Clear 
Flag button or check the Completed box. 

Figure 2-28 

You can flag any Outlook 
Item for follow up by right-
clicking the item and 
selecting Flag for Follow 
Up from the menu. 

Figure 2-29 

The Flag for Follow Up 
dialog box. 
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Figure 2-28 

Figure 2-29 
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Lesson 2-19: Exporting 
Information 
 

When you export Outlook information, you save it in a different format so that it can be 
understood and opened by different programs. For example, you might export your Contact 
list to an Excel worksheet.  

In this lesson, you will learn how to export information from an Outlook folder and save it in 
an external file. 

11.. Select File → Import and Export from the menu. 
The Import and Export Wizard dialog box appears, as shown in Figure 2-30. 

22.. Select the Export to a file option and click Next. 
The Export to a File dialog box appears, as shown in Figure 2-31. Here is where you 
tell Outlook the type of file you want to export to. 

33.. Select a file type from the list and click Next. 
The third step in the Export Wizard appears, as shown in Figure 2-32. Here you need to 
select the folder whose data you want to export. 

44.. Select the folder whose data you want to export and click Next. 
The final step in the Export Wizard appears, as shown in Figure 2-33. Now you can 
save the exported information. 

Figure 2-30 

The Import and Export 
Wizard dialog box. 

Figure 2-31 

Step two of the Export 
Wizard: specifying the 
type of file you want to 
export to. 

Figure 2-32 

Step three of the Export 
Wizard: specifying the 
folder whose information 
you want to export. 

Figure 2-33 

The final step of the 
Export Wizard: specifying 
the location where you 
want to save the 
information. 
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Figure 2-32 Figure 2-33 
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 Quick 
Reference 
To Export Information: 
1. Select File → Import 

and Export from the 
menu. 

2. Select the Export to a 
file option from the list 
and click Next. 

3. Select the desired file 
format from the list and 
click Next. 

4. Select the folder whose 
data you want to export 
and click Next. 

5. Specify the name and 
folder where you want to 
save the exported 
information, click Next 
and then click Finish. 

55.. Specify the name and folder where you want to save the exported 
information and click Next. 
Remember that you can use the Browse button to navigate to the folder where you 
want to save the exported file. 

66.. Click the Export check box and click Finish. 
Outlook saves the information to the file. 

Outlook can read and write to a number of different file formats. The following table lists the 
more common file formats that people import and/or export information to and from. 

 Table 2-7: Exportable File Formats and Extensions 
File Format Extensions 
Personal Folder File .pst 

Text (Comma delimited) .csv 

Text (Tab delimited) .txt 

Microsoft Access .mdb 

Microsoft Excel .xls, .xlt 

Microsoft FoxPro .dbf 
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Lesson 2-20: Manually 
Archiving Information 
 

Your Outlook folders become larger as more items are stored in them. As your folders become 
larger, Outlook becomes slower, and finding items can become increasingly difficult. This is 
where archiving becomes useful. When you archive Outlook information, you transfer old 
items to a storage file, thus removing the information from its original location. There are two 
ways to archive information in Outlook: 
• Manually: You can manually transfer old items from a selected folder by selecting 

File → Archive on the menu. 
• Automatically using AutoArchive: Once you configure Outlook’s AutoArchive 

feature, Outlook will automatically archive old information. Several Outlook folders are 
set up with AutoArchive already turned on. These folders and their default aging periods 
are Calendar (6 months), Tasks (6 months), Journal (6 months), Sent Items (2 months), 
and Deleted Items (2 months). Inbox, Notes, Contacts, and Drafts do not have 
AutoArchive activated automatically. 

Remember that when you archive information, the original items are copied to the archive file 
and then removed from the current folder—so be cautious about what you archive. 

This lesson explains how to manually archive Outlook information. 

11.. Select File → Archive from the menu. 
The Archive dialog box appears, as shown in Figure 2-34. Here is where you determine 
what you want to archive: 

22.. Make sure the Archive This Folder and all subfolders option is 
selected. 
Checking this option tells Outlook to archive the folder(s) you select. 

Figure 2-34 

The Archive dialog box. 

 IC3 
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Move items that are older than the date 
you specify to the archive file. 

Display the name of the file that archived 
items are moved to. To change the file, 
type a name, or click Browse. 

Select the folder(s) you want to archive. 

Figure 2-34 
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 Quick 
Reference 
To Manually Archive 
Items: 
1. Select File → Archive 

from the menu. 
2. Ensure the Archive This 

Folder and all 
subfolders option is 
selected. 

3. Select the folder that you 
want to archive. 

4. Click the Archive items 
older than list arrow and 
select the date to specify 
how old items must be in 
order to be archived. 

5. (Optional) Specify the 
name and folder of the 
archive file in the Archive 
File box. 

6. Click OK. 

33.. Select the folder that you want to archive. 
If you use e-mail frequently, the Inbox and Sent folders make excellent archive 
candidates.  
Next, you need to specify how old the items must be before they can be archived. For 
example, you could specify to archive any e-mail messages that are older than 3 
months. 

44.. Click the Archive items older than list arrow and select a date from the 
list. 
Next you need to specify the name and folder of the archive file, if you so choose. 

55.. (Optional) Specify the name and folder of the archive file in the Archive 
File box. 
By default, Outlook saves the archive file in a rather obscure folder that you will 
probably have a great deal of trouble finding. You may want to specify a file name and 
folder that will make it easier for you to find if you plan on looking at any archived 
information later. 

NOTE: If you decide to specify the name and folder of the archive file, make sure that 
you use this same file when you archive information in the future. When you 
archive information, Outlook doesn’t overwrite the archive file but appends 
any new items to it. By using the same archive file, you can keep all your old 
Outlook information in the same place. 

66.. Click OK. 
Outlook archives the items in the specified folder that are older than the specified date, 
saving them in the archive file and then removing them from their original locations. 

The most important thing to remember when archiving information is that Outlook actually 
removes any items that are older than the date you specify—so make sure that you check and 
see if there are any important items that are older than the specified date before you archive a 
folder. 
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Lesson 2-21: Adding New 
Address Book Entries 
  

If you use the Microsoft Outlook Address Book, you don’t have to memorize lots of 
confusing phone numbers and e-mail addresses. Simply enter the names and e-mail addresses 
of the people to whom you regularly send messages, and you’ll never have to remember 
another obscure e-mail address again. This lesson will show you how to add an e-mail address 
to the Microsoft Outlook Address Book. 

11.. Click the Address Book button on the toolbar. 
The Address Book window appears. 

22.. Click the New Entry button on the toolbar. 
The New Entry dialog box appears, as shown in Figure 2-35. First, you need to specify 
where you want to save the new Address Book entry. Most of the time, you will want 
to save entries in the Contacts list. 

33.. In the Put this entry panel, click the In the list arrow and select Contacts. 
Because there are many different types of e-mail and messaging systems, the Address 
Book can create several different types of entries. More than likely, if your 
organization is using Microsoft Outlook, they’re using Microsoft Exchange as well. 
Microsoft Exchange is Microsoft’s own e-mail messaging system, and it runs on a 
Windows NT or Windows 2000 server. 
The most common types of entries are Internet Addresses (the typical 
name@domain.com) and Microsoft Mail Addresses (if your organization is using 
Microsoft Exchange as its mail server). 

44.. Select Internet Address and click OK. 
The New Internet Address Properties dialog box appears, as shown in Figure 2-36. 

55.. Type your name in the Display name field. 
Next, specify your e-mail address. 

66.. Enter your e-mail address in the E-mail address text box. 
To add additional information about the recipient, such as a mailing address or phone 
number, click the appropriate sheet tabs and enter the information. 

Figure 2-35 

The New Entry dialog box. 

Figure 2-36 

The New Internet Address 
Properties dialog box. 

 
Address Book 

button 
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New button 

Other Ways to Create a 
New Contact: 
• Press <Ctrl> + <N>. 

Figure 2-35 

Figure 2-36 Select the type of 
entry you want to 
create… 

…and where 
you want to 
put it. 
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 Quick 
Reference 
To Add an Entry to the 
Address Book: 
1. Click the Address Book 

button on the toolbar. 
2. Click the New button on 

the toolbar. Then, select 
the type of contact you 
want to enter and the 
address book you want to 
enter it into. 

3. Enter the desired 
information about the 
contact. 

4. Click OK and close the 
Address Book window. 

77.. Click OK to close the New Internet Address Properties dialog box. 
You return to the Address Book window. If you aren’t in the Personal Address Book 
view, select it from the “Show Names from the” text box. In your Personal Address 
Book, you will see the entry you just made. 

88.. Close the Address Book window. 

When you add entries to the Address Book, you can add as much or as little information as 
you want. For example, you could enter a person’s department, mailing address, and phone 
numbers—or, you could just enter their name and e-mail address. 

As mentioned earlier, you can create and work with several different types of Address Book 
entries. The following table describes the most common Address Book entries. 

Table 2-8: Types of Address Book Entries 
Entry Description 
cc: Mail Address Sends e-mail messages to Lotus cc: mail users. 

Fax Address Sends faxes to the specified phone number. 

Microsoft Mail Address Sends e-mail messages to Microsoft Exchange users. 

MacMail Address Sends e-mail messages to MacMail users. 

Internet Address Sends e-mail messages to users on the Internet (using typical 
name@domain.com e-mail address). 

X.400 Address Sends e-mail messages to X.400 users. 

Other Address Uses Other Address entries when you don’t have a person’s e-mail 
address, but still want to store their name, phone number, and address. 

Personal Distribution 
List 

A distribution list is composed of several Address Book entries so you can 
send an e-mail message to several people at once. 
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Lesson 2-22: Adding and 
Updating Contacts Using E-
mail Messages 
 

You just learned how quickly and easily you can add contacts to your Address Book. 
However, it can get pretty tedious typing all of that contact information if you have a lot of 
people to add to your Address Book at once. Also, if one of your contacts changes e-mail 
addresses, it can be a pain to have to find their name in your Address Book just to change one 
facet of their information. Luckily, there is an easier way to add and update entries in your 
Address Book: use the e-mail messages from your Inbox. All you have to do is click and drag 
the e-mail message to the Contacts icon in the Outlook Bar (any information contained in 
your Contacts list should also translate into your Address Book). Let’s try it out. 

1. Click the Send and Receive button to see if you have any new 
messages. 
Any new messages now appear in your Inbox. 

Figure 2-37 

The message that you 
want to click and drag to 
the Contacts icon in the 
Outlook Bar. 

Figure 2-38 

The New Contact dialog 
box with the information 
from the e-mail message 
automatically filled in. 
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Figure 2-37 

Figure 2-38 
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First, you need to choose a message that contains the contact information you want to 
add to your Address Book. 

2. Select the message from your Inbox that contains the contact information 
that you want to add or update to your Address Book. 
The message will appear highlighted when it has been selected. Now all you have to do 
is click and drag the message over to the Contacts icon that is located in the Outlook 
Bar. 

3. Click and drag the message over to the Contacts button in the Outlook 
Bar, then release the mouse button. 
The New Contact dialog box appears, as shown in Figure 2-38. Notice that all of the 
contact information contained in the e-mail message has been automatically filled in 
the New Contact form.  
Here you can add any additional information about the contact such as mailing address, 
job title, or phone number. When you are finished, save and close the new contact 
information. 

4. Click the Save and Close button located on the toolbar. 
If the name or the e-mail address for the new contact already exists somewhere in the 
Address Book, the Duplicate Contact Detected dialog box will appear. There are two 
options to choose from: 
• Add this as a new contact anyway: Add a new contact even if some of the 

information is a duplication of another contact. 
• Update new information from this contact to the existing one: 

Change the information contained in the existing contact so that it is up-to-date. 
If you need to view the existing contact before you can make a decision, click the Open 
Existing Contact button. When you are finished… 

5. Click OK. 
The contact has either been added or updated. To view the updated or added contact, 
click the Address Book button and navigate to your Contacts list. 

Pretty easy, huh? Move onto the next lesson to learn how to create a distribution list so you 
can send one e-mail message to an entire group of people all in one simple step.  Quick 

Reference 

To Do This: 
1. Click the Address Book 

button on the toolbar. 
2. Click the New button on 

the toolbar. Then, select 
the type of contact you 
want to enter and which 
address book you want to 
enter it into. 

3. Enter the desired 
information about the 
contact. 

4. Click OK and close the 
Address Book window. 
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Lesson 2-23: Creating a 
Distribution List 
   

A distribution list or group is an Address Book entry comprised of several names from the 
Address Book. You use distribution lists to send an e-mail message to each member in the 
group in a single mailing. You can use distribution lists to quickly send e-mails to: 
• All employees in the same department or organization. 
• Members on the same project or committee. 
• Generic messages to a group of friends, such as a humorous e-mail or a notice that your 

address has changed. 

Distribution lists show up as items in your Address Book and Contact list, just like a person’s 
name. You use a distribution list to address an e-mail message just as you would with any 
other contact. 

In this lesson, you will learn how to create a distribution list that you can use to send e-mails 
to multiple recipients. 

Figure 2-39 

The New Personal 
Distribution List Properties 
dialog box. 

Figure 2-40 

The Edit Members dialog 
box. 

 IC3 

Objective: 3.2.2.5 
Req. File: None 

Enter name of the 
Distribution List or 
Group. 

Specify the people you 
want to add or remove 
to or from the 
distribution list. 

Figure 2-39 

Figure 2-40 

Displays contacts in the Address Book. 
Double-click each contact you want to 
add to the group or select each contact 
and click Members. 

These contacts are included in the new 
group or distribution list. 

Displays the current 
members of the 
distribution list. 
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 Quick 
Reference 
To Create a Distribution 
List: 
1. Click the Address Book 

button on the toolbar. 
2. Click the New Entry 

button on the toolbar. 
3. In the Put this entry panel, 

click the In the list arrow 
and select Personal 
Address Book. 

4. Select Personal 
Distribution List from the 
Select the entry type text 
box and click OK. 

5. Type a name for the 
distribution list in the 
Name text box. 

6. Click the Add/Remove 
Members button. 

7. Find and double-click the 
names you want to add to 
the distribution list. Click 
OK when you’re finished. 

8. Close the Address Book. 

11.. Click the Address Book button on the toolbar. 
The Address Book dialog box appears. 

22.. Click the New button on the toolbar. 
The New Entry dialog box appears. First, you need to ensure that Outlook saves the 
new group in your Personal Address Book. 

33.. Click the In the list arrow and select Contacts. 
Now let’s create our distribution list! 

44.. Select Personal Distribution List from the Select the entry type box 
and click OK. 
The New Personal Distribution List Properties dialog box appears, as shown in Figure 
2-39. First, we need to give our new group, or distribution list, a name. 

NOTE: Distribution lists and groups are the same thing—so don’t be confused when 
you see Outlook interchanging these terms. 

55.. Click the Name text box and type Luau Committee Members. 
Always try to give your groups a meaningful name so that they make sense to both you 
and to other Outlook users. Now let’s add some members to this group. 

66.. Click the Add/Remove Members button. 
The Edit New Personal Distribution List Members dialog box appears, as shown in 
Figure 2-40. The left side of the dialog box displays contacts from your Address Book, 
and the right side displays the members of the group. To add members to the group, 
simply double-click the contact names you want to add. 

77.. Find and double-click your name from the list. 
Outlook adds your name to the Luau Committee Members personal distribution list. 

88.. Add 2 or 3 more contacts of your choice to the distribution list. 
That’s all there is to creating a distribution list! 

99.. Click OK to close the Edit New Personal Distribution List Members dialog 
box. 
The Edit New Personal Distribution List Members dialog box closes and you’re once 
again looking at the New Personal Distribution List Properties dialog box. This time, 
the dialog box contains the names that you just added to the distribution list in the 
lower panel. 

1100.. Click OK to close the New Personal Distribution List Properties dialog 
box. 
The New Personal Distribution List Properties dialog box closes and you’re back at the 
Address Book. 

1111.. Click the Show Names from the: list arrow and select Personal 
Address Book. 
This displays the contents of your Personal Address Book. Notice that the new 
personal distribution list you created appears among your personal Address Book 
entries. 

1122.. Close the Address Book dialog box. 

People come and go on distribution lists, just like anywhere else. Luckily you can easily edit 
any distribution list. Just open either the Address Book or the Contacts List, and find and 
double-click the name of the distribution list. To remove a member from the list, select the 
name and click the Remove button. To add a new member to the list, click Select Members 
and double-click the contacts you want to add to the list. 

 
New button 

Other Ways to Create a 
New Contact: 
• Press <Ctrl> + <N>. 
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Lesson 2-24: Deleting 
Contacts and Distribution 
Lists 
    

You can delete any entry from your Contacts folder or distribution list. Unless you’re the 
corporate network administrator, however, you can’t delete any Global Address List entries 
from the Address Book. 

11.. Click the Address Book button on the toolbar. 
The Address Book dialog box appears. 

22.. Click the Show Names from the: list arrow and select Contacts. 
The Address Book now displays only the entries contained in your Contacts folder. 
Deleting a contact is very easy. 

33.. Find and select your name from the list, then click the Delete button on 
the toolbar. 
Outlook asks you to confirm the deletion, as shown in Figure 2-42. 

44.. Click Yes to confirm the deletion. 
Outlook deletes your entry from the Contacts list. 
You delete distribution lists just as easily. Let’s try it. 

55.. Click the Show Names from the: list arrow and select Contacts. 
The Address Book now displays only entries from your Contacts list. Deleting a 
distribution list is very easy. 

Figure 2-41 

You can easily delete 
contacts and distribution 
lists from the Address 
Book. 

Figure 2-42 

Outlook asks you to 
confirm any Address Book 
deletions. 
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Delete button 

Other Ways to Delete a 
Distribution List or 
Contact: 
• Select the contact or 

distribution list and 
press the <Delete> key. 

To Delete a Contact: Select the 
name of the contact or distribution 
list and press the <Delete> key, 
or click the Delete button. 

Figure 2-41 

Figure 2-42 
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66.. Find and select the Luau Committee Members distribution list from the 
Contacts list and click the Delete button on the toolbar. 
Once again, you need to confirm the deletion. 

77.. Click Yes to confirm the deletion. 
Outlook deletes the Luau Committee Members distribution list from the Address Book 
and the Contacts list without affecting any of its members’ individual contact 
information. 

88.. Close the Address Book. 

 

 Quick 
Reference 

To Delete a Contact or 
Distribution List: 
1. Click the Address Book 

button on the toolbar. 
2. Find and select the 

contact or distribution list 
you want to delete. 

3. Click the Delete button 
on the toolbar. 

 Or… 
 Press <Delete>. 
4. Click Yes to confirm the 

deletion. 
5. Close the Address Book 

window. 
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Lesson 2-25: Sending a Message 
Using the Address Book 
 

You learned in a previous lesson that distribution lists are used to send an e-mail message to 
each member of a group in a single mailing. You can use distribution lists to quickly send e-
mails to all employees in the same department or organization, members on the same project 
or committee, or generic messages to a group of friends (such as a humorous e-mail). 

Distribution lists show up as items in your Address Book and Contacts list, just like a person’s 
name. You can use a distribution list to address an e-mail message just as you would with any 
contact. 

11.. Make sure that you are in the Inbox – click the Inbox button on the 
Outlook Bar if you’re not. 
The Inbox View appears. 

22.. Click the New Mail Message button..  
An Untitled – Message form appears, as shown in Figure 2-43, ready for you to enter a 
new message. First, you need to specify the recipient’s e-mail address in the To field.  

33.. Click the To button. 
The Select Names dialog box appears. 

44.. Click the Show Names from the list arrow and select Contacts if 
necessary. 
This will display the distribution lists in the Contacts folder. 

55.. Click the name of any distribution list in the Name list then click the To 
button. Then click OK. 
If you actually wanted to send this message to everyone in the distribution list, you 
would click the Send button. We don’t really need this e-mail, so go ahead and close it. 

66.. Click the Message window’s Close button and click No when it asks if 
you want to save your changes. 

Figure 2-43 

A new e-mail message 
being sent to a distribution 
list. 
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Figure 2-43 

 Quick 
Reference 

To Send a Message Using 
the Address Book: 
1. Click the New Mail 

Message button. 
2. Click the To button. 
3. Click the Show Names 

from the list arrow and 
select Contacts if 
necessary. 

4. Click the name of any 
distribution list in the 
Name list and click the To 
button. Click OK. 

5. Click the Send button to 
send the message. 
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Lesson 2-26: Using the Out of 
Office Assistant 
 

So you’re finally taking that much-deserved vacation and going to Mexico next week? 
Congratulations! Before you leave, you should set up the Out of Office Assistant to notify 
other people that you will be out of the office for the next few days. When other users send 
you e-mail messages, they will automatically receive the out-of-office message that you 
created. The Out of Office Assistant is another Outlook feature that only works in a 
workgroup environment—so if you use Outlook in an Internet-only environment, you’re out 
of luck—there’s no Out of Office Assistant. 

In this lesson, you will learn how to set up the Out of Office Assistant. 

11.. Select Tools → Out Of Office Assistant from the menu. 
The Out Of Office Assistant dialog box appears, as shown in Figure 2-44. 

22.. Select the I am currently Out of the Office option. 
Now you have to specify the message people will automatically receive when they 
send you e-mail messages. 

33.. Click in the AutoReply only once to each sender with the following 
text box and type your message. 
For example, you might type something like “I will be out of the office from 
February 1st through February 10th. If you have any questions about the new network 
server, please contact my assistant Bob at extension x3081.” When you’re finished, 
move on to the next step. 

44.. Click OK. 

So how do you turn off the Out of Office Assistant? Easy—the next time you start Microsoft 
Outlook, a dialog box will appear, asking you if you want to turn the Out of Office Assistant 
off. Simply click Yes to deactivate the Out of Office Assistant. 

Figure 2-44 

The Out of Office 
Assistant. 
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Figure 2-44 

Enter the message the 
people will 
automatically receive 
when they send you 
e-mail messages. 

 Quick 
Reference 

To Set Up the Out of Office 
Assistant: 
1. Select Tools → Out of 

Office Assistant from the 
menu. 

2. Select the I am currently 
Out of the Office option. 

3. Click in the appropriate 
text box and type your 
message. 

4. Click OK. 
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Lesson 2-27: Changing the 
Message Format 
 

People in different countries speak different languages, so it makes sense that e-mail programs 
use and understand different types of message formats. And, just like some people can speak 
more than one language, many e-mail programs—including Microsoft Outlook—can read and 
write in different message formats. Microsoft Outlook is actually somewhat of a linguist 
expert and can create messages in four different formats, as shown in Table 2-9: Available 
Message Formats. 

More complex message formats, such as Microsoft Word format, have more formatting 
options but are less likely to be understood by some e-mail programs. Less complex message 
formats have fewer formatting options but are recognized by more e-mail programs. 

Some common problems caused by using the wrong message format include: 
• Not being able to format a message 
• Not being able to use stationery or images in a message 
• Messages not being understood by the recipient’s e-mail program 

So which of the formats listed in Table 2-9: Available Message Formats should you use? 
That’s a decision you’ll have to make, depending on which formatting features are important 
to you and who you send your e-mail messages to. 

Figure 2-45 

Font and paragraph 
formatting aren’t available 
for messages in Plain Text 
format. 

Figure 2-46 

You can change the 
default message format by 
selecting Tools → Options 
from the menu, clicking 
the Mail Format tab, and 
selecting the message 
format. 

 IC3 

Objective: 3.2.2.6, 3.2.3.2 
and 3.2.3.3 
Req. File: None 

The Formatting 
toolbar is available 
for messages in 
Rich Text or HTML 
format. 

The Formatting 
toolbar is not 
available for 
messages in 
Plain Text format.

Figure 2-45 

Figure 2-46 

Select the e-mail format you want to use for new 
messages. See Table 2-9: Available Message 
Formats for a description of each of the 
available options. 
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 Quick 
Reference 
To Change the Message 
Format: 
1. Select Tools → Options 

from the menu and click 
the Mail Format tab. 

2. Click the Compose in 
this message format: 
arrow and select the 
desired message format. 

3. Click OK. 

11.. Select Tools → Options from the menu and click the Mail Format tab. 
The Options dialog box appears, as shown in Figure 2-46. 

22.. Click the Compose in this message format: list arrow. 
This list contains the formats you can use to create your new messages. Table 2-9: 
Available Message Formats gives a detailed description of each of these messages, 
including the formatting features and the pros and cons of using it. For now you can 
leave the message format as it is. 

33.. Close the Options dialog box. 

Here’s some information about the various message formats available to Microsoft Outlook: 

Table 2-9: Available Message Formats 
Format Description 
HTML HTML (Hypertext Markup Language) is the same language that is used to 

create web pages. HTML gives you many formatting options and is compatible 
with most e-mail programs. 

Formatting Options Available: Text and paragraph formatting, numbering, 
bullets, alignment, horizontal lines, backgrounds, HTML styles, and Web 
pages. 
Pros: Compatible with most e-mail programs. 
Cons: Older e-mail programs may not recognize HTML formatted messages. 

Microsoft Outlook 
Rich Text 

Microsoft Outlook Rich Text is a good in-between message format that has a 
moderate amount of text formatting and compatible with virtually all e-mail 
programs. 

Formatting Options Available: Text formatting, alignment, and bullets 
Pros: Compatible with most e-mail programs. 
Cons: Older e-mail programs may not recognize these formatted messages. 

Plain Text Plain Text is the most compatible message format and can be understood by 
virtually all e-mail programs—even much older ones. Because Plain Text 
messages have no formatting options, the Formatting toolbar is disabled when 
you’re working with them. 

Formatting Options Available: None 
Pros: Universally understood by all e-mail programs. 
Cons: No formatting options. 

Microsoft Word This format lets you use Microsoft Word—a very powerful word processor—to 
compose your e-mails as Microsoft Word documents. This option gives you the 
most formatting options and lets you use Microsoft Word’s powerful features. 
The downside? Microsoft Word messages are the least compatible format and 
cannot be understood by many e-mail programs. Unless you only use Outlook 
for internal office use, you’re probably better off using a different format. 

Formatting Options Available: All formatting available to Microsoft Word 
documents, such as tables, WordArt objects, and more. 
Pros: Lets you take advantage of Microsoft Word’s powerful features and 
provides the most formatting options. 
Cons: Many e-mail programs cannot understand messages in Microsoft 
Word format.  
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Lesson 2-28: Understanding the 
Advantages of Web-based E-mail 
 

There are tons of advantages to using e-mail. In fact, there are too many to list in a single 
lesson. However, there are three key advantages that every Web-based e-mail user should be 
aware of: speed of delivery, low cost, and accessibility. 

Speed of Delivery 
When compared to other methods of communication, such as postal mail, e-mail is much 
faster! In fact, when you send an e-mail, it reaches its destination almost instantaneously. 
Whether you’re sending an e-mail to the co-worker in the cubical next to yours, or to your 
sister who is vacationing in Australia, the time of delivery will be the same. 

Low Cost 
If you are concerned about having to pay for an e-mail program in order to send and receive 
e-mail messages, set those feelings aside. If you’re connected to the Internet and have a Web 
browser, you don’t even need an e-mail application to send and receive messages – you can 
do it right from the Web! Web-based e-mail is usually free, and it allows you to compose, 
send, and receive e-mail messages using a Web page instead of an e-mail program.  

Accessibility 
Your e-mail is easy to access if you’re using Web-based e-mail. In fact, many people prefer to 
use Web-based e-mail instead of an e-mail program because it’s free and can be accessed 
anywhere that there is a computer with an Internet connection. Hotmail, as shown in Figure 
2-47, owned by Microsoft (who else?), is the largest Web-based e-mail program in the world. 
Other examples of Web-based e-mail programs include Yahoo!, Fastmail, and Netscape. 

If you’re looking to purchase an e-mail application, you have lots of choices. Although we’ll 
be working with Microsoft Outlook throughout the duration of this chapter, Outlook is by no 
means the only program you can use to send and receive e-mail. There are many different e-
mail programs that can send and receive e-mail, such as GroupWise, Lotus Notes, and 
America Online (AOL). And remember – there is always the option of using Web-based e-
mail. 

So you already know the basics regarding e-mail, but how should an e-mail message be 
composed? Move on to the next lesson to find out!  

Figure 2-47 

Many people prefer to use 
Web-based e-mail, such 
as Hotmail, since you can 
use it anywhere on any 
computer that has a 
connection to the Internet. 

 IC3 

Objective: 3.2.3.1 
Req. File: None 

 Quick 
Reference 

Understanding the 
Advantages of E-mail: 
• E-mail is fast. In fact, it 

reaches its destination 
almost instantaneously. 

• Most Web-based e-mail is 
free, and it allows you to 
compose, send, and 
receive e-mail messages 
using a Web page instead 
of an e-mail application. 

• Web-based e-mail can be 
accessed anywhere there 
is a computer with an 
Internet connection. 

Figure 2-47 
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Lesson 2-29: Understanding 
Network Etiquette 
 

E-mail has evolved as a unique communication medium that combines the formality of a 
letter and the informality of a telephone call. Despite its informal approach, communicating 
via e-mail is no excuse for a lack of professionalism. Messages should follow the same 
guidelines as correspondence via written mail, possessing an appropriate level of formality 
based on its content. 

To show good network etiquette, or netiquette, keep the following in mind as you write your 
messages:  

Accurate Subject Fields 
Subject fields need to be accurate. You want the receiver to know what they are going to read, 
and how urgent the message may be, before they even open it.  For example, let’s say you are 
going to send your employees an e-mail regarding tomorrow’s staff meeting. There are staff 
meetings scheduled for Tuesday and Thursday as well. If you just enter “Meeting” into the 
Subject field of your e-mail, the receivers will not be aware that this particular e-mail is 
regarding the meeting scheduled for tomorrow. It can’t be stressed enough that being 
articulate within your Subject fields is important. 

Be Brief 
When you create or respond to an e-mail, be brief. It is much easier for the receiver to glance 
over two sentences versus two pages. For example, if a coworker sends you a message asking 
what time the meeting is scheduled for tomorrow, don’t send an annotated version of your 
schedule for the week along with wishes for a good day. Simply respond politely and 
succinctly with the time and place of the staff meeting. It is also important to be aware of the 
tone your messages exude. Using all capitals to emphasize a point should be avoided, as it 
appears as “SHOUTING” to the recipient. 

Check Your Spelling 
It is imperative that your e-mail messages stay free from spelling errors. Not only is it 
unprofessional, but spelling errors could cause confusion as to the actual meaning of your 
message. It is also important to remember that while most e-mail applications come with a 
spell checker, it will not catch all spelling errors. 

Figure 2-48 

An example of an e-mail 
message composed using 
good netiquette. 
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 Quick 
Reference 

Understanding Network 
Etiquette: 
• Subject fields need to be 

accurate so that the 
receiver is aware of the 
urgency and the subject 
of a message before they 
even open it. 

• Be brief with e-mail 
responses. It is much 
easier for a receiver to 
glance over a two-
sentence response 
versus a two-page one. 

• Check spelling so that 
your e-mail appears more 
professional, and to 
prevent confusion. 

Figure 2-48 

To: Enter the recipient(s) of the 
message. 

Subject: Enter an accurate 
subject for the message 

Body: Type your e-mail message 
here, making sure that it is free of 
spelling errors before you send it 
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Lesson 2-30: Understanding 
Unsolicited E-mail 
 

Isn’t it nice when you open your Inbox in the morning and find important e-mail messages 
like the ones in Figure 2-50 waiting for you? Probably not. These are all examples of Spam. 
Spam is, quite easily, one of the most annoying aspects of e-mail. 

What is Spam? 
If the e-mail meets both of the following criteria, it can be defined as Spam. 
• The e-mail message was unsolicited: This means that the message was sent to you even 

though you never asked for it. Usually, Spams are sent in an effort to get you to buy a 
particular product or service. Most, but not all, Spams are commercial in nature.  
Not all unsolicited e-mails are Spam. Your long-lost friend from preschool in Kansas 
could send you an e-mail trying to get back in touch. You would certainly not want this e-
mail classified as Spam simply because you didn’t solicit it. Therefore, there must be 
another criterion by which to define Spam. 

• The e-mail message was sent in bulk and without discrimination: If this message was 
sent to a large group of random people, it is most likely Spam. Spammers do not 
discriminate to whom their junk mail is sent. They will send to anyone and everyone in 
an attempt to earn a sale.  
Your friend obviously did not send her e-mail to a large group of people. Therefore, the e-
mail message does not meet both criteria and should not be classified as Spam. 

How can you prevent Spam? 
It is almost impossible to prevent businesses and other organizations from sending you Spam. 
However, most e-mail programs on the market nowadays include some sort of a junk mail 
filter or encryption software. While these filters cannot repel Spam, they can most certainly 
keep it away from your Inbox. Unfortunately most of these filters prove to be quite 
ineffective, simply because they are based on a limited lexicon. If a Spammer uses different 
vocabulary than you might expect to find in a Spam, the filter will allow it into your Inbox. 

Luckily, there is another anti-Spam feature in most e-mail applications. They allow you to 
create a junk mail sender’s list. When you add a name to this list, that person can no longer 
send you e-mails, junk or not.  Adding a name to a junk mail sender’s list is like telling your 
postal worker, “Don’t deliver any more mail from Publisher’s Clearing House.” 

Figure 2-49 

You may feel 
overwhelmed by the 
amount of junk e-mail you 
receive on a daily basis. 

Figure 2-50 

Some examples of Spam. 
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 Quick 
Reference 

Understanding Spam: 
• Spam is an unsolicited e-

mail that was sent in bulk 
and without 
discrimination. 

• Most Spams are 
commercial in nature. 

• Most e-mail applications 
on the market these days 
contain features that allow 
you to filter e-mail content 
or block the sender 

Figure 2-49 Figure 2-50 

DON’T LET BAD 
CREDIT HOLD YOU 
BACK! 

Make MONEY on the 
Internet with our 
(almost) free software!

Leran to ytpe at 300 
wrods pre mniuet!!  
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Lesson 2-31: Computer 
Viruses 
 

What is a virus? 
The average keyboard has thousands of germs on it, but that’s not how computers get viruses. 
A computer virus is a small computer program created by a malicious programmer for the 
purpose of damaging other computers. When viruses become installed on a computer, the 
computer is infected and the virus carries out the damage it is programmed to do.  

There are many different types of viruses. Most viruses attack computer hard drives by 
erasing data and damaging system files, but programmers can write the virus to do anything 
they want. If your computer isn’t working the way it usually does, you have probably been 
infected with a virus. 

One of the most devastating effects of a virus is that the virus often has the ability to spread 
from computer to computer. The most malicious viruses—such as the “I Love You” and 
“Melissa” viruses—have caused billions of dollars in damage worldwide. 

How are viruses spread? 
The most damaging computer viruses are programmed with the ability to reproduce and infect 
more computers. Many viruses invade computers through e-mail programs by riding the backs 
of e-mail messages, or through networks and file sharing. Viruses can also be found in storage 
devices like diskettes, CD-ROMs, or zip disks. The Internet is a host to many viruses as well.  

What can I do to prevent a virus? 
Good judgement is the first line of defense against a virus. Installing anti-virus software on 
your computer will keep out most viruses, but you can do a lot to prevent contracting a virus 
as well. Here are a few guidelines to keep in mind: 
 • Do use an anti-virus program. Installing an anti-virus software program on your 

computer is a must if you are going to be working on the Internet. 
• Don’t post your e-mail address in a public place. Once a spammer gets a hold of 

your e-mail, it’s almost impossible to avoid receiving unsolicited e-mails that may or may 
not contain a virus. 

• Don’t open messages from unknown senders. Viruses are often sent through e-
mail messages. If you don’t know the sender, don’t open the message. 

Figure 2-51 

Malicious programmers 
create viruses that infect 
computers. 

Figure 2-52 

Computers are 
unresponsive and 
inefficient when infected 
with a virus. 
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Understanding Viruses: 
• A virus is a small 

computer program 
created by a malicious 
programmer for the 
purpose of damaging 
other computers. 

• Most viruses are 
programmed to reproduce 
and infect other 
computers through file 
sharing, networks, or e-
mail messages. 

• The best way to prevent a 
virus infection is to install 
a virus-scanning program 
on your computer, so 
viruses are detected 
before they attack your 
computer. 

• You are the first line of 
defense against viruses: 
don’t open messages or 
attachments that are 
unrecognizable.

Figure 2-51 Figure 2-52 
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• Don’t open attachments from unknown senders. A virus has to be opened to 
install itself on your computer. Even if the sender is familiar, think twice before opening 
the attachment. 
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Chapter Two Review 

Lesson Summary 

Understanding E-mail Addresses 

• User Name: The User Name refers to the name of the person’s e-mail account. 

• Domain Name: The Domain Name, also known as the Host Name, refers to the location of the 
person’s account on the Internet. 

• Top Level Domain (TLD): The TLD refers to the type of organization, or the country, where the 
person’s e-mail account is located. 

Composing and Sending E-mail 

• To Compose a Message: Click the Inbox button on the Outlook Bar and click the New Mail 
Message on the toolbar. Type the recipient’s address in the To: field, or click the To button to the 
left of the To text box, choose the name of the recipient from the Name list, and then click the To 
button. Click the Subject text box and enter the message’s subject, click the pointer in the lower 
pane, and type the message. Click the Send button on the toolbar to send the message. 

Specifying Message Options 

• To Specify Message Options: Click the New Mail Message button on the toolbar and create the 
message. Click the Options button, specify the message options, and click OK. 

• To Mark a Message as Urgent: Click the Importance: High button on the toolbar. 

Opening and Closing an E-mail Message 

• To Receive and Read E-mail Messages: Click the Inbox button on the Outlook bar. Click the 
Send and Receive button on the toolbar. Click or double-click the message you want to read. Or, 
select File → Open from the menu. 

• To Close an E-mail Message: Click the Message window’s Close button. Or, select File → 
Close from the menu. 

• Things you can do with an E-mail Message: Reply to the message; forward the message; view 
or download any attachments; print the message; delete the message; move the message to a 
different folder; and ignore the message. 

Replying to a Message 

• To Reply to a Message: Find and open the message you want to reply to, and then click the reply 
option you want to use: 
   Reply sends the reply only to the author of the message. 
   Reply to All sends the reply to everyone who received the message. 
Type your reply and click the Send button on the toolbar when you’re finished. 

• To Delete the Original Message Copy: Select the original message text and press the <Delete> 
key. 
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Forwarding a Message 

• To Forward a Message: Find and select the message you want to forward and click the Forward 
Message button on the toolbar. Enter the recipient’s e-mail address in the To field. (Optional) 
Enter your own comments in the message body area. Click the Send button on the toolbar. 

Finding Messages 

• To Find a Message: Click the Find button on the toolbar, or select Tools → Find from the menu. 
Enter the text you want to search for in the Look for text box. Check the Search all text in the 
message check box to search the actual text of your e-mail messages. Click the Find Now 
button. 

Sorting Messages 

• To Sort Messages: Click the column heading you want to use to sort the Inbox. 

Attaching and Deleting a File 

• To Attach a File to an E-mail Message: Click the New Mail Message on the toolbar and create 
the message. Click the Insert File button on the toolbar or select Insert → File from the menu. 
Browse to, find, and double-click the file you want to attach. 

• To Delete an Attachment from an E-mail Message: Select the attachment and press the 
<Delete> key. 

Opening and Saving an Attachment 

• To Open an Attachment in Preview Mode: Click the paper clip icon, select the attachment you 
want to view, select Open it, and click OK. 

• To Open an Attachment in the Message Form: Open the e-mail by double-clicking it and then 
double-click the attachment you want to view. 

• To Save an Attachment to Your Hard Disk in Preview Mode: Click the paper clip icon, select 
the attachment you want to view, select Save it to disk, and click OK. Specify a file name and 
location for the attachment and click OK. 

• To Save an Attachment to Your Hard Disk in the Message Form: Open the E-mail by double-
clicking it. Then right-click the attachment and select Save As from the shortcut menu. Specify a 
file name and location for the attachment and click OK. 

Managing E-mail Effectively 

• Use folders to organize your Inbox so you don’t have to sift through a plethora of unrelated e-mail 
messages in order to find the one you are actually looking for. 

• Delete unimportant e-mail messages immediately so they don’t clutter your Inbox. 

• Use the Address Book and distribution lists to keep your contact information current and organized. 

Creating a Folder 

• To Create a New Folder: Right-click anywhere in the Folder List and select New Folder from the 
shortcut menu. Or, select File → New → Folder from the menu. Enter the folder’s name in the 
Name text box. Specify what you want to keep in the new folder by making a selection from the 
Folder contains list. Specify where you want to keep the new folder by clicking the appropriate 
folder’s icon. Click OK. 
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Renaming, Copying, Moving, and Deleting a Folder 

• To Lock the Folder List in Place: Open the Folder List by clicking the Folder Banner or by 
selecting View → Folder List from the menu, then click the thumbtack button.  

• To Rename a Folder: Right-click the folder, select Rename from the shortcut menu, and enter the 
new name. 

• To Delete a Folder: Select the folder you want to delete, press <Delete>, and click Yes to confirm 
the deletion. 

• To Move a Folder: Click and drag the folder to the desired location. 

Selecting One or More Mail Messages 

• To Select Several Consecutive Items: Click the Inbox button on the Outlook bar. Click the first 
message you want to select, press and hold down the <Shift> key, and click the last message you 
want to select. 

• To Select Several Nonconsecutive Items: Click the Inbox button on the Outlook bar. Press the 
<Ctrl> key as you click each item that you want to select. 

Deleting Messages 

• To Delete a Message: Select the message and click the Delete button on the toolbar. Or, select 
the message and press the <Delete> key. 

• To View Deleted Items: Click the Deleted Items button on the Outlook Bar. 

• To Empty the Deleted Items Folder: Right-click the Deleted Items button on the Outlook Bar, 
select Empty “Deleted Items” Folder from the shortcut menu and click Yes to confirm the 
deletion. 

Marking E-mail Messages as Read or Unread 

• To Mark an E-mail Message as Read or Unread: Select an e-mail message from the Inbox. 
Select Edit from the menu and then choose an e-mail message status option. Or, right-click the e-
mail message whose status you want to change and then select an e-mail message status option 
from the shortcut menu. 

Flagging Items 

• To Flag an Item: Right-click the item and select Flag for Follow Up from the shortcut menu. Click 
the Flag to list arrow and select a category. (Optional) Click the Due by list arrow and select the 
day you want to be reminded of the flagged item. Click OK. 

Exporting Information 

• To Export Information: Select File → Import and Export from the menu. Select the Export to a 
file option from the list and click Next. Select the desired file format from the list and click Next. 
Select the folder whose data you want to export and click Next. Specify the name and folder where 
you want to save the exported information, click the Export box, and click Finish. 
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Manually Archiving Information 

• To Manually Archive Items: Select File → Archive from the menu. Ensure the Archive This 
Folder and all subfolders option is selected, and then select the folder that you want to archive. 
Click the Archive items older than arrow and select the date to specify how old items must be in 
order to be archived. (Optional) Specify the name and folder of the archive file in the Archive File 
box. Click OK to archive the folder(s). 

Adding New Address Book Entries 

• To Add an Entry to the Address Book: Click the Address Book button on the toolbar. Click the 
New button on the toolbar. Then, select the type of contact you want to enter and which address 
book you want to enter it into. Enter the desired information about the contact. Click OK and close 
the Address Book window. 

Adding and Updating Contacts Using E-mail Messages 

• To Add or Update an Address Book Entry Using E-mail Messages: Select any message from 
your Inbox that contains the contact information that you want to add to the Address Book. Click 
and drag the e-mail message to the Contacts icon on the Outlook Bar. Then, release the mouse 
button. Enter any additional information about the contact in the New Contact dialog box. Click the 
Save and Close button on the toolbar. If necessary, make a selection in the Duplicate Contact 
Detected dialog box and click OK. 

Creating a Distribution List 

• To Create a Distribution List: Click the Address Book button on the toolbar. Click the New 
Entry button on the toolbar. In the Put this entry panel, click the In the list arrow and select 
Personal Address Book. Select Personal Distribution List from the Select the entry type text 
box and click OK. Type a name for the distribution list in the Name text box. Click the Add/Remove 
Members button. Find and double-click the names you want to add to the distribution list. Click 
OK when you’re finished. Close the Address Book. 

Deleting Contacts and Distribution Lists 

• To Delete a Contact or Distribution List: Click the Address Book button on the toolbar. Find 
and select the contact or distribution list you want to delete. Click the Delete button on the toolbar, 
or press the <Delete> key. Click Yes to confirm the deletion. Close the Address Book window. 

Sending a Message Using the Address Book 

• To Send an E-mail Message Using the Address Book: Click the New Mail Message button. 
Click the To button. Click the Show Names from the arrow and select Personal Address Book if 
necessary. Click the name of any distribution list in the Name list and click the To button. Then, 
click OK. Click the Send button to send the message. 

Using the Out of Office Assistant 

• To Use the Out of Office Assistant: Select Tools → Out Of Office Assistant from the menu. 
Select the I am currently Out of the Office option. Click in the appropriate text box and type your 
message, then click OK. 

Changing the Message Format 

• To Change the Message Format: Select Tools → Options from the menu and click the Mail 
Format tab. Click the Compose in this Message format: arrow and select the desired message 
format. Click OK. 
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Understanding the Advantages of Web-based E-mail 

• E-mail is fast. In fact, it reaches the destination almost instantaneously. 

• Most Web based e-mail is free, and it allows you to compose, send, and receive e-mail messages 
using a Web page instead of an e-mail application. 

• Web based e-mail can be accessed anywhere there is a computer with an Internet connection. 

Understanding Network Etiquette 

• Subject fields need to be accurate so that the receiver is aware of the urgency and the subject of a 
message before they even open it. 

• Be brief with e-mail responses. It is much easier for a receiver to glance over a two-sentence 
response versus a two-page one. 

• Check that everything in your e-mail is spelled correctly so that it appears more professional and to 
prevent confusion. 

Understanding Unsolicited E-mail 

• Spam is an unsolicited e-mail that was sent in bulk and without discrimination. 

• Most Spams are commercial in nature. 

• Most e-mail applications on the market these days contain features that allow you to filter e-mail 
content or to block the sender. 

Understanding Viruses 

• A virus is a small computer program created by a malicious programmer for the purpose of 
damaging other computers. 

• Most viruses are programmed to reproduce and infect more computers through file sharing, 
networks, or e-mail messages. 

• The best way to prevent a virus infection is to install a virus-scanning program on your computer, 
so that viruses are detected before they attack your computer. 
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Quiz 

1. Which of the following is NOT a part of an e-mail address? 
A. Domain Name 
B. Network Name 
C. Top Level Domain (TLD)  
D. User Name 

2. To reply to a message, click the Forward button on the toolbar. (True or 
False?) 

3. You’ve just received an e-mail entitled “I Love You!” from someone you 
don’t know. The message has an attachment. What do you do? 

A. Open the attachment immediately and see what it is! 
B. Forward the e-mail to your significant other to show them that at least other people 

appreciate you. 
C. The e-mail may likely contain a virus, so treat the e-mail and its attachment with 

extreme caution. Either delete it or save it to your hard disk but ONLY if you have an 
up-to-date anti-virus program installed. 

D. Pull the personal ad you posted last month from the Internet. 

4. Which of the following does NOT describe a distribution list? 

A. You should use a distribution list to sent an e-mail message to each member of a 
group in a single mailing. 

B. You should use a distribution list to send a humorous e-mail to a group of friends. 
C. You should use a distribution list to address an e-mail message just as you would 

with an individual contact. 
D. You should use a distribution list to send an e-mail to your mother-in-law. 

5. Which of the following are ways to find an e-mail message? (Select all that 
apply.) 

A. Click the Find button on the toolbar. 
B. Click the New Mail Message button on the toolbar. 
C. Select Tools → Find from the menu. 
D. Select Edit → Find Message from the menu. 

6. When you receive an unimportant e-mail message, you should: 
A. Keep it in your Inbox. 
B. Move it to your “Important” folder. 
C. Delete it. 
D. Forward it to all of your friends. 
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7. Which of the following is an advantage of e-mail?  

A. Low Cost 
B. Accessibility  
C. Speed of Delivery 
D. All of the above are advantages of e-mail 

8. It is not important to use good network etiquette when composing an e-
mail. (True or False?) 

9. Most Spams are commercial in nature. (True or False?) 

10. Which of the following is a method for marking an e-mail message as read 
or unread? (Select all that apply.) 

A. Select File → Message Status from the menu. 
B. Select Edit from the menu and then choose an e-mail message status option. 
C. Right-click an e-mail message and choose a status option from the shortcut menu. 
D. Double-click an e-mail message and choose a status option from the shortcut menu. 

Homework 
1. Start Microsoft Outlook. 

2. Open the Inbox by clicking the Inbox button on the Outlook bar. 

3. Create a new e-mail message using the following information: 
  To: (your own e-mail address) 
  Subject: Outlook Homework  

4. Send the e-mail message. 

5. Check to see if you have any new e-mail messages by clicking the Send and Receive 
button. 

6. Add a new entry to your Address Book. 

7. Create a distribution list named “Friends.” 

8. Add at least three entries to the Friends distribution list. 

9. Sort the contents of your Inbox by Subject. 

10. Close the Microsoft Outlook program. 

Quiz Answers 
1. B. Network Name is not part of an e-mail address. 

2. False. You reply to a message by clicking the Reply button on the toolbar, of course. 

3. C. While an e-mail titled “I Love You” with an attachment could come from a secret 
admirer, it’s much more likely that it contains virus. Either delete the message or save the 
file to your hard disk, but ONLY if you have an up-to-date anti-virus program installed. 

4. D. Distribution lists are meant to be used to send one e-mail message to every member of 
a group, not to send an e-mail message to an individual. 
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5. A and C. To find a message, either click the Find button on the toolbar, or select Tools → 
Find from the menu. 

6. C. Any e-mail message that you do not need should be deleted immediately. 

7. D. Speed of delivery, low cost, and accessibility are all advantages of using e-mail. 

8. False. It is very important to use good network etiquette when composing and sending e-
mail. 

9. True. Most Spams that are sent out are in an attempt to get you to buy a product or 
service. 

10. B and C. You can mark a message as read or unread either by right-clicking the message 
and selecting a status from the shortcut menu, or by selecting Edit from the menu and 
then choosing a status option from the menu. 



Chapter Three: 
Using the Internet 
Chapter Objectives: 

• Understand key terms 

• Understand Web browsers and addresses 

• Understand protected Web sites and information quality 

• Display a specific Web page 

• Navigate a Web site and use hyperlinks 

• Display and delete a history of visited Web pages 

• Add a Web page to Favorites 

• Save Web pages for offline viewing 

• Copy and paste images, URLs, and text 

• Preview and Print a Web page 

• Download images and files 

• Change your Home page 

• Use a search engine 

Unless you’ve been living on a deserted island for the past five years, you already know that 
the Internet is the biggest thing to happen to computers since…well, computers! You can’t 
ignore it – the Internet is not going away and it’s already changing the world we live in. 
Fortunately, for the most part, the Internet is incredibly easy to use. Even the most computer-
phobic users seem to feel right at home on the Internet. 

This chapter explains the ins and outs of the Internet. If you’ve ever spent a sleepless night 
wondering exactly what the Internet is and how to get started, you’ll finally learn it all. You 
will learn many useful terms, such as cookie, cache, HTTP, and FTP; how to navigate to a 
specific Web address; how to activate a hyperlink within that address; how to work with 
Favorites; and more! 

By the end of this chapter, you’ll be surfing the big waves of the World Wide Web like a pro! 

 Prerequisites 
• How to use the mouse 

to click, double-click, 
drag and drop, and 
right-click. 

• How to use menus, 
toolbars, and dialog 
boxes. 

• How to start programs 
in the Start menu. 
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Lesson 3-1: Understanding 
Key Terms 
 

Before you start working on the World Wide Web, there are some key terms that you should 
familiarize yourself with. This lesson is only meant to help you get acquainted with frequently 
used World Wide Web jargon. Relax, you don’t have to memorize anything! Reference Figure 
3-1 as you work your way through the following terms: 

Table 3-1: Understanding Key Terms 
Term Definition 
HTTP HTTP stands for Hypertext Transfer Protocol. It is a set of rules for transferring 

files on the World Wide Web. HTTP files can be text, graphics, sound, video, or 
any other multimedia file type. HTTP works like this: your browser (for example, 
Microsoft Internet Explorer) sends an HTTP request to a server for a certain 
group of Web pages. The server receives this request and sends the page(s) 
back to your computer. 

HTML HTML stands for Hypertext Markup Language. It is a set of special codes 
referred to as “tags,” that describe the general structure of various kinds of 
documents that are linked together on the World Wide Web. 

URL URL stands for Uniform Resource Locator. This is an address for a file that is 
located somewhere on the Internet. Each URL is unique to the Web page that it 
links to. URLs are structured so that they contain a protocol, domain name, 
resource, and extension. Don’t worry about these terms for now, because URLs 
will be covered more extensively in another lesson. 

Hyperlink A hyperlink is a link from one word or image to another. Most commonly, a 
hyperlink will appear on a page as a blue underlined word or phrase (as seen in 
Figure 3-1), but they can also be images or animations. To use a hyperlink, you 
simply click on it with your mouse and it will instantly take you to the destination. 

Figure 3-1 

The Yahoo home page.  

 IC3 

Objective: 3.3.1.1 and 
3.3.1.3 
Req. File: None 

Text link 
Figure 3-1 

Uniform Resource Locator (URL) Graphic link 

Button 
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Term Definition 
ISP ISP stands for Internet Service Provider. An ISP is a lot like a phone company, 

except instead of letting you make telephone calls to other people, an Internet 
Service Provider lets your computer connect to the Internet. Just like your 
telephone company, Internet Service Providers charge for their services – 
currently, the average rate seems to be about $20 per month for unlimited 
usage. You’ve probably already heard of the most famous Internet Service 
Provider – America Online, or AOL. 

Plug-in A plug-in is a small piece of software that enriches a larger piece of software by 
adding features or functions. For example, a plug-in extends the capabilities of 
a Web browser, such as Microsoft Internet Explorer, by allowing the browser to 
run multimedia files.  

FTP FTP stands for File Transfer Protocol. Much like HTTP, FTP is a set of rules for 
transferring files on the World Wide Web.  FTP is commonly used to transfer 
Web page files from the Web page developer’s computer to the Web server. 
FTP is also used to download files to your computer from another server. 

Cookie A cookie consists of one or more pieces of information that are stored as text 
files on your computer. A Web server sends the cookie and the browser stores 
it. Each time the page is referenced, the browser resends the cookie to the 
original server. Cookies are most commonly used to store frequently used 
information, such as user ID numbers. They are not harmful, as their rotten 
reputation implies. They cannot transmit viruses, nor can they take any 
information from your computer back to the server. In fact, cookies can be 
helpful because they allow a server to recall any user-specific information. 

Cache You automatically request files when you look at a Web page. These files are 
stored in a cache. A cache is simply a temporary storage place that is located in 
a subdirectory beneath the main directory for your browser. Caches are created 
so that when you return to a page that you have recently visited, the browser 
can get the page from the cache, rather than going back to the server. This 
saves time and reduces the amount of Internet traffic. Most Web browsers will 
allow you to manipulate the size of your cache. 

Encryption When you encrypt something, you are putting it into a code that only authorized 
people can understand. This prevents unauthorized users from accessing 
personal or confidential information. 

Firewall A firewall is a group of related programs that protect a private network from 
users from other networks. Basically, a firewall screens all incoming information 
before sending it off to its intended destination so the network stays secure - 
free from hackers, viruses, and any other types of security breaches. 
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Lesson 3-2: Understanding 
Web Browsers 
 

A Web browser is a software application that allows your computer to connect with, view, and 
navigate the World Wide Web. The Web browser is what finds, displays, and allows you to 
interact with and look at Web pages. Most Web browsers are graphical in nature, which 
means that they have the capability to show both text and images. 

Why can’t I see certain images with my browser? 
Some browsers may have trouble showing certain images or text. Most of the time, this has to 
do with an out-of-date browser. For example, if you have an older version of Netscape 
Navigator, you may not be able to see graphics and animations created using Macromedia 
Flash. This is because the browser does not understand what these graphics are. 

Why do annoying advertisements keep popping up while I am using my browser? 
Pop-ups are annoying advertisements windows that disrupt your browsing on the Web. 
Depending on the security settings, these annoying pop-ups may or may not show up while 
you are browsing the Web. Newer versions of Web browsers contain a handy-dandy program 
called a pop-up blocker that does just that: blocks unwanted pop-up ads from cluttering your 
computer screen. Make sure your computer security settings are up to date, and, if you don’t 
have a pop-up blocker, it would be in your best interest to install one. 

What are some commonly used browsers? 
Two of the most commonly used browsers are Internet Explorer (owned by Microsoft) and 
Netscape Navigator (owned by AOL). There are several other reputable browsers available for 
use. Take a look at Table 3-2: Commonly Used Web Browsers for more information. 

Figure 3-2 

Using Microsoft Internet 
Explorer to display the 
MSN Home page. 

 IC3 

Objective: 3.3.1.1, 3.3.1.2, 
and 3.3.2.12 
Req. File: None 

Figure 3-2 
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Table 3-2: Commonly Used Web Browsers 
Web Browser Description 
Internet Explorer Owned by Microsoft, the most popular browser on the market. 

Netscape 
Navigator 

Owned by AOL, Netscape comes in at a close second to Microsoft’s Internet 
explorer. 

Opera Opera is an international Web browser that comes from Norway. It is new to the 
market and causing quite a stir with its popularity. 

MSN Explorer Microsoft combined features from Internet Explorer, Outlook Express, MSN 
Messenger, and Windows Media Player into one application. 

 

 Quick 
Reference 

Understanding Web 
Browsers: 
• A Web browser is a 

program that allows your 
computer to view and 
navigate the World Wide 
Web. 

• If you are having trouble 
viewing certain images or 
animations with your 
browser, it means that 
your browser is not 
compatible with specific 
software applications or 
that the browser is simply 
out of date. 

• The two most commonly 
used Web browsers are 
Microsoft’s Internet 
Explorer and AOL’s 
Netscape Navigator. 
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Lesson 3-3: Understanding 
Web Addresses 
 

Web addresses, also called URLs (Uniform Resource Locators), are the unique addresses for 
documents, Web sites, and other resources available for browsing and downloading on the 
World Wide Web. Once a Web page has been requested using a Web address, a Web server (a 
computer that contains the Web site or other resource) sends the pages back to the computer 
that made the request. Figure 3-3 is an example of what a typical Web address looks like. 

Web addresses consist of four parts: a protocol, a domain name, a resource to be located, and 
an extension. 
• Protocol: The protocol tells the server which type of resource you are trying to locate. 

The most common protocol is http://, or HyperText Transfer Protocol, as seen in Figure 
3-3. This protocol tells the server that you are looking for a Web site. Most browsers 
assume that your are searching for a Web site, so when you type in the address you can 
usually leave the http:// out. 

• Domain Name: The domain name is the address of the main Web page. The domain 
name indicates the company or individual that maintains the Web site. In our example, 
www.customguide.com indicates that CustomGuide, Inc. is the host of the site. Take a 
look at Table 3-4: Commonly Used Domain Name Extensions to familiarize yourself with 
the most common domain name extensions and the purposes for which they serve. 

• Resource: A resource can be almost any computer-related item. You could be searching 
for a file, program, printer, disk drive, data, or memory. In Figure 3-3, the resource is 
computer_training. This indicates that this address belongs to the “About Us” portion of 
the CustomGuide, Inc. Web site. 

• Extension: The extension indicates what type of code or program is running the Web 
site. In Figure 3-3, the extension is .htm. This is a standard extension that indicates the 
site is running on UNIX machines or on a PC using Microsoft Windows. Addresses with 
an .htm extension run only static pages – meaning the content cannot be manipulated. 

That’s all there is to a Web address. Pretty simple stuff, huh? Go ahead and take a look at the 
following table for some other examples of commonly used extensions. 

Table 3-3: Examples of Commonly Used Extensions 
Extension Description 
.html This site is run on UNIX machines, or PCs using Microsoft Windows. Addresses 

with an .html extension run only static pages – the content cannot be 
manipulated. 

.shtml These sites are more flexible than .htm or .html sites. They contain tags that 
enable quick and easy changes to the content. In other words, these sites are 
not static. 

Figure 3-3 

An example of a Web 
address, or URL. 

 IC3 

Objective: 3.3.1.4 and 
3.3.2.1 
Req. File: None 

http://www.customguide.com/computer_training.htm 

Protocol Domain name Resource Extension

Figure 3-3 
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Different types of Web sites can be identified simply by looking at their extension. Take a 
look at the following table to familiarize yourself with the most common ones.  

Table 3-4: Commonly Used Domain Name Extensions 
TLD Description 
.biz Reserved for businesses only 

.com This is the most common Top Level Domain and it is reserved for commercial 
enterprises. 

.edu Reserved for educational institutions and universities 

.gov Reserved for United States government agencies 

.mil Reserved for the United States military 

.net This is most often used by Internet Service Providers (ISPs), but it is reserved 
for any network group. 

.org Reserved for non-profit organizations 

.uk or .jp Web sites located outside of the U.S. will include a country code, such as .uk for 
the United Kingdom and .jp for Japan 

.info Used in all types of domains 

 

 Quick 
Reference 

Understanding Web 
Addresses: 
• Protocol: The protocol 

tells the server which type 
of resource you are trying 
to locate. 

• Domain Name: The 
domain name indicates 
the company or individual 
that maintains the site. 

• Resource: The resource 
can be almost any item, 
including files, programs, 
and data. 

• Extension: An extension 
indicates what type of 
program or code is 
running the Web site. 
.htm and .html are the 
most commonly used 
extensions.
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Lesson 3-4: Understanding 
Secure Web Sites and 
Information Quality 
 

A secure Web site is basically any site that contains information that is not for general public 
use. Either the information is confidential, or the user is simply a member of the site’s 
organization or a customer of the site’s company. For example, you may want to shop at a 
department store online. When you start your online shopping trip, you will most likely be 
asked to enter a user name and a password – and maybe some additional personal 
information. This is so that the next time you visit the Web site, you will have an ID and will 
be able to access the product in no time. Also, no one else will be able to shop under your user 
name or password, which provides you with an added sense of online security. 

In order to gain access to the information provided on a protected Web site, one is required to 
enter both a user name and a password. You may be familiar with these terms, because most 
people employ a user name and password when they log onto their computers, or attempt to 
gain access to a private network. Read on for a more detailed description of each term. 

User Name 
A user name is an assigned name, or a name that you choose for yourself, that you must enter 
in order to gain access to a secure Web site, network, or computer. Usually, a user name is an 
abbreviation of the user’s full name. For example, if your name is John Doe, the abbreviation 
might be something like “JDoe.” A user name may also be an alias, or nickname. 

A user name isn’t enough to gain access to a secure Web site. You must use the name in 
conjunction with a password. 

Password 
A password is a group of characters (letters, numbers, and/or symbols). Passwords are usually 
4-16 characters long, depending on the Web site that you are trying to gain access to. They are 
used to determine whether or not the user that is requesting admittance to the secure Web site 
is actually the person they claim to be. Passwords generally do not have spaces. When you 
enter your password into the text box, it is usually replaced with bullets or another symbol so 
that no one else could read it off of your screen.  

Take a look below for some tips on creating “unbreakable” passwords: 
• Do not pick a password that could easily be guessed by someone who knows you well. 

Many people like to use the names of their pets, social security number, or birth date. 
This is not a good idea. 

Figure 3-4 

Gain access to secure 
Web sites by entering a 
user name and password. 

Figure 3-5 

An example of a secure 
Web site sign-in box. 

 IC3 

Objective: 3.3.1.5, 3.3.3.5, 
and 3.3.3.6 
Req. File: None 

Figure 3-4 Figure 3-5 
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 Quick 
Reference 
Understanding Secure 
Web Sites: 
• Secure Web Site: A 

secure Web site contains 
information not available 
to everyone. 

• User Name: A name, 
either assigned or chosen 
by the user, that a person 
must enter along with a 
password in order to gain 
access to a secure Web 
site. 

• Password: A group of 
characters (usually 4-16 
depending on the site) 
used to determine 
whether or not the user 
trying to gain access to a 
secure Web site is who 
they claim to be. 

Criteria for Evaluating the 
Quality of Information: 
• Relevance 
• Reliability 
• Validity 
• Potential bias 
• Sufficiency 
 

• Do not use a word that directly relates to current affairs. Chances are, if it’s on your 
mind, it will be on someone else’s too. 

• Do use a mixture of letters and numbers. This makes the amount of combinations almost 
endless! 

• Do use a word that you’ll remember. You don’t want to keep yourself from accessing the 
secured information! 

• Do change your password often, and when you do, don’t make your new password 
similar to the old one. Chances are, over time you will have told at least one person what 
your password is. Constantly changing things around ensures that your password remains 
secure. 

That’s about all there is to know about user names, passwords, and using secure Web sites, but 
there is one more thing we need to cover before we move on to the next lesson. 

Unfortunately, the ease of publishing information on the Internet translates to a medium with 
no oversight or “quality control,” leaving it up to the user to determine the value of online 
resources.  

Criteria for evaluating the quality of information found on the Internet include: 
• Relevance: Does the information relate to specified needs?) 
• Reliability: Does the information come from a source that can be trusted to provide true 

and accurate content? 
• Validity: Can information be verified from more than one source? 
• Potential bias: Could there be a potential commercial or political bias on behalf of the 

site’s owner? 
• Sufficiency: Is the information sufficient enough for a specific purpose? 

Ways to determine the quality of information on a Web site include:  
• Analyzing the source of a site 
• Communicating with the creator of a site 
• Analyzing internal links within a site 
• Evaluating search engine ranking results 
• Comparing information found on the Internet with other “offline” sources, such as 

professional journals found at the library, to clarify ambiguous or incomplete information 
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Lesson 3-5: Opening and 
Closing a Web Browser 
 

There are three things you’ll need to connect to the Internet: 
• An Internet Service Provider (ISP): An Internet Service Provider is a lot like a 

phone company, except instead of letting you make telephone calls to other people, an 
Internet Service Provider lets your computer connect to the Internet. Just like your 
telephone company, Internet Service Providers charge for their services—currently the 
average rate seems to be about $20 a month for unlimited usage. You’ve probably already 
heard of the most famous Internet Service Provider—America Online, or AOL. 

• A Web Browser: A Web browser is a program that lets your computer view and 
navigate the World Wide Web. One of the most popular Web browsers is Microsoft’s own 
Internet Explorer. Another Web browsing program that is very popular is Netscape 
Navigator. 

Figure 3-6 

Microsoft’s Internet 
Connection Wizard will set 
you up with an Internet 
Service Provider. 

Figure 3-7 

The Internet Start Web 
page. 

 IC3 

Objective: 3.3.2.2 
Req. File: None 

 
Internet 
Explorer 

Other Ways to Open 
Internet Explorer: 
• Click the  icon on 

the Windows Quick 
Launch toolbar. 

Figure 3-6 

Figure 3-7 
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 Quick 
Reference 
To Connect to the Internet: 
1. Double-click the Internet 

Explorer icon on the 
desktop. 

 Or… 
 Click the Internet 

Explorer icon on the 
Quick Launch toolbar. 

 Or… 
 Click the Windows Start 

button and select 
Internet Explorer from 
the menu. 

2. If necessary, enter your 
user name and password 
and click Connect. 

To Close a Web Browser: 
• Click the Internet Explorer 

window’s Close button. 
 Or… 
 Select File → Close from 

the menu. 

• A Phone Line and Modem or Other Connection: A modem is your computer’s 
very own telephone that lets it talk to other computers over the telephone line. Your 
existing phone line will work just fine with your modem, although it will be tied up 
whenever you’re connected to the Internet. If you or someone in your home is a heavy 
Internet user, you might consider getting a second phone line for your computer. An 
increasingly popular type of connection is DSL (Digital Subscriber Line) which is much 
faster than a dial-up connection, and is connected 24-hours a day. This type of connection 
is similar to what most workplaces have.  

11.. Click the Windows Start button and then select Internet Explorer to 
start Microsoft Internet Explorer. 
If you have America Online, you would select America Online from the Start menu 
instead. 
If this is the first time you’ve ever tried connecting to the Internet, you may be greeted 
by the Internet Connection Wizard, as shown in Figure 3-6. Microsoft included the 
Internet Connection Wizard to help you get connected to the Internet and find an 
Internet Service Provider. If you want, you can follow the step-by-step instructions and 
let the Internet Connection Wizard help find you an Internet Service Provider (ISP)—
or, you can find your own. Ask a computer-savvy friend or an employee at a local 
computer store for the name and number of a local Internet Service Provider. Once you 
are set up with an ISP, come back finish the rest of this lesson. 

22.. Enter your user name and password, if necessary, and click Connect. 
If you have previously entered your user name and password and checked the Save 
password option, the user name and password characters will already appear in their 
respective text boxes. (Your password will appear masked by asterisks or bullets.) 
If you listen to your computer, you should hear a dial tone, then your modem dial the 
phone, and finally a screeching sound as your ISP answers the phone. 

NOTE: If you’re connected to the Internet through a network at work, an ISDN or 
DSL line, or a cable modem, you won’t hear anything at all, since these are all 
digital connections. Actually, it would probably pay off if you checked to see 
if the Internet is available in your area by cable or DSL connections. If it is, 
it’s probably worth the extra ten or twenty dollars a month to get a connection 
to the Internet that is at least ten times faster than a standard phone 
connection. Plus, you don’t have to worry about people getting busy signals 
when you’re using the Internet. 

After a connection to the Internet has been established, Internet Explorer appears on 
screen and displays your home page.  
Once you’re finished with the Internet Explorer program, close it. 

33.. Click the Close button on the Microsoft Internet Explorer title bar. 
The program closes and you are back at the Windows desktop. 

It is important to note the difference between a browser’s home page and a Web site’s home 
page. A home page for a browser is the Web page that your Web browser displays when it first 
connects to the Internet. The default start page for Microsoft Internet Explorer is MSN (what 
else did you think it would be?), but you can easily change your home page—more about that 
in another lesson. Move on to the next lesson to learn more about the home page for a Web 
site. 

 
 
Point to this icon and 
wait a few seconds 
to see what your 
connection speed to 
the Internet is. 
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Lesson 3-6: Displaying a 
Specific Web Page 
    

Web addresses are everywhere—on television advertisements, in magazine and newspaper 
articles, and even on business cards. Just like there is a house, office, or building behind a 
postal address, there is a Web page behind every Web address, and every Web address is 
unique to that Web page. Unlike postal addresses, through the magic of technology, you can 
arrive instantly at a Web page by typing its Web address into your Web browser. Well, 
hopefully instantly… if you’ve already been on the Internet for any amount of time, you 
probably know that sometimes the Internet gets busy and net congestion can cause a Web 
page to come up slowly—if at all!  

This lesson will show you how to visit the Web sites behind all the Web addresses you’ve 
seen. 

Figure 3-8 

The Microsoft Web site 
open in Internet Explorer. 

Figure 3-9 

When a Web page is 
currently unavailable, this 
screen is displayed in 
Internet Explorer. 

Other Ways to Enter an 
Internet Address: 
• Press <Ctrl> → <L>. 

 IC3 

Objective: 3.3.1.1, 3.3.2.1, 
3.3.2.2, 3.3.2.3, and 3.3.2.12 
Req. File: None 

Address bar 
Type the address of the Web 
page you want to view here 
and press <Enter>. 

Figure 3-8 

Figure 3-9 
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11.. Connect to the Internet. 
It doesn’t matter where you are on the Internet—you can always enter a Web address.  

22.. Click the words in the Address bar. 
The text in the Address bar becomes highlighted. 

33.. Type the address of the Web page you want to view. In our example, we’ll 
use www.microsoft.com and press <Enter>. 
Web addresses are preceded by http://. For example, the address we want is 
http://www.microsoft.com. Technically, you don’t need to add the http:// before typing 
the Web address—save yourself some time and leave it out. 

NOTE: If you forget the www in front of a Web address or a .com a feature of 
Internet Explorer, called IntelliSense®, attempts to correct the Web address 
by adding the www or .com for you. Sometimes it works, sometimes it 
doesn’t. 

After a moment, you’re connected to the Microsoft Web site, as shown in Figure 3-8. 
Let’s try going to another Web site. 

44.. Type www.customguide.com in the Address bar and press <Enter>. 
The CustomGuide, Inc. home page appears. The home page is the main page of a 
specific Web site.  
Just like a metro highway system at rush hour, the Internet often becomes congested 
when too many users try to view the same Web site at the same time. When this 
happens, it may take a long time for the Web page to appear on screen, or you may get 
an error message. 
If this happens, try refreshing the sluggish or difficult Web page.  

55.. Click the Refresh button on the toolbar. 
Nothing happens here, because the CustomGuide, Inc. home page was working 
properly to begin with. There are two basic reasons to refresh a Web page: 
• To attempt to view a Web page that is not loading.  
• To update a Web page that contains information that is constantly changing, such as 

headline news stories or financial information. 

Sometimes when you’re browsing the World Wide Web, you’ll see a screen like one in Figure 
3-9. This means the Web site is unavailable. Several things can cause a Web page not to load: 
• The computer where the Web page is stored is down. 
• Too many users are trying to view the same Web page at the same time. 
• You’ve lost your connection to the Internet. 
• The Web page no longer exists, or maybe it never existed in the first place (did you type 

in the correct Web address?). 

For all these cases, try going to the Web site again later. Whatever was causing the problem 
might be fixed a few minutes or hours later. 

You can leave off the 
http:// when you 
type a Web page 
address. For 
example, type 
www.nbc.com 
instead of 
http://www.nbc.com. 

 
Address Bar

 
Refresh button 

 Quick 
Reference 

To Display a Specific Web 
Page: 
• Type the Web address in 

the Address bar and 
press <Enter>. 

 Or… 
• Press <Ctrl> + <L>, type 

the Web address, and 
press <Enter>. 

To Refresh a Web Page: 
• Click the Refresh button 

on the toolbar. 
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Lesson 3-7: Navigating a Web 
Site and Using Hyperlinks 
 

Luckily, the World Wide Web is remarkably easy to navigate. It’s so easy, in fact, that most 
users seem to have the uncanny ability to browse through Web pages without any previous 
training—even if they have difficulty with other computer programs. This chapter explains 
how to find your way through the millions of Web pages that are on the Internet. Even if you 
already think you have browsing down, you should read this chapter—you might learn a trick 
or two you didn’t already know. 

In addition to covering the navigation techniques involved in browsing the Web, you will also 
learn how to use a hyperlink. Let’s get started! 

11.. If necessary, go to the CustomGuide, Inc. home page by clicking the 
Address bar, typing www.customguide.com, and pressing <Enter>. 
The CustomGuide home page fills the screen. Many of the underlined words and 
pictures you see on the page are actually hyperlinks. When you position the pointer 
over a hyperlink, it changes to a . Clicking a hyperlink will automatically: 
• Take you to a different page within the same Web site. 

Figure 3-10 

The Internet Explorer 
toolbar. 

Figure 3-11 

The CustomGuide, Inc. 
home page. 

 IC3 

Objective: 3.3.2.2 and 
3.3.2.5 
Req. File: None 

Figure 3-11 

Brings you back to 
the previously 
viewed Web page 

Brings you 
forward to the 
next viewed Web 
page 

Reloads or 
refreshes the 
current Web 
page 

 
Brings you to 
your home 
page 

Shows your favorite 
Web pages that  
you bookmarked 

 
Opens your 
e-mail program

Figure 3-10 

Prints the 
current Web 
page 

Stops loading a 
Web page 

Searches 
the Web for 
specified 
information

Finds Web 
pages 
you've 
recently 
visited 
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 Quick 
Reference 
To Use a Hyperlink: 
• Click the hyperlink with 

the  pointer. 

To Go Back to the 
Previous Page: 
• Click the Back button on 

the toolbar. 

To Go Forward to an 
Already Viewed Page: 
• Click the Forward button 

on the toolbar. 

• Take you to a different page in a different Web site. 
• Take you to a different part of the same Web site. 
• Allow you to download a file. 
• Send an e-mail to a specified e-mail address.  
• Play a video or sound. 

22.. Position the pointer over the About Us hyperlink at the top of the 
CustomGuide, Inc. home page. 
The pointer changes into a  any time it is positioned over a link. Remember, links can 
be either text or images (as in this example), but most often they appear as blue 
underlined text. 

33.. Click the About Us hyperlink text or icon. 
The About Us Web page appears. Notice the address bar displays the address of the 
new Web page, http://www.customguide.com/computer_training.htm. 
You can easily move back to the previous Web page. 

44.. Click the Back button on the toolbar.  
You’re back at the CustomGuide, Inc. home page. The Forward button moves forward 
through the Web pages you have viewed. 

55.. Click the Forward button on the toolbar. 
You return to the About Us Web page.  
Sometimes it may take a bit of “drilling down” in a Web site to find the exact 
information that you need. Be patient—it’s most likely there somewhere!  

That’s all there is to navigating Web sites! Move on to the next lesson to learn how to display 
and delete a history of recently visited Web sites.  

Tip: Instead of 
repeatedly clicking 
the Back and 
Forward buttons, you 
can click their down 
arrows to display a 
list of previous Web 
pages. 

 
Back button 

 
Forward button 
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Lesson 3-8: Displaying and 
Deleting a History of Visited 
Web Pages 
  

Can’t find your way back to that that really neat “101 Lutefisk Recipes” Web site you were 
looking at yesterday? Don’t worry—Internet Explorer keeps track of the Web pages you’ve 
visited during the past 20 days. You can use Internet Explorer’s history feature to easily return 
to any of these sites, and that’s the topic of this lesson. 

11.. Make sure your Web browser is open and you’re connected to the 
Internet. 

22.. Click the History button on the toolbar to display a list of the Web pages 
you have recently visited. 
A history of all the Web pages you’ve visited recently appears in the left-hand side of 
the Internet Explorer window. The history is grouped chronologically—all you have to 
do it click the day or week you last viewed the Web page that you want to view again. 

33.. Click the day or week you last viewed the Web page that you want to 
view again. 
If you can’t remember the day or week off hand, don’t worry.  Finding the Web page 
that you want to view in the History folder may take a bit of trial and error, because 
who really remembers the exact day when they visited a specific Web page?  
When you click a day or week, the Web sites you viewed during that day or week 
appear. A Web site symbol appears to the left of each Web site. 

44.. Click the Web site you want to view again. 
The Web site’s individual Web pages appear with a Web page symbol beside them. 

55.. Click the Web page you want to view.  
The Web page appears. 

Figure 3-12 

Internet Explorer displays 
a history of previously 
visited Web sites. 

 IC3 

Objective: 3.3.2.4 
Req. File: None 

 
History button 

Select the Web 
site ( ) then the 
specific Web 
page ( ). 

Select the day or 
week when you last 
viewed the Web 
page 

Figure 3-12 



 Chapter Three: Using the Internet 103 
 

Institute of Applied Technology 

 Quick 
Reference 
To Display a History of 
Visited Web Pages: 
1. Click the History button 

on the toolbar. 
2. Click the day or week you 

last viewed the Web 
page. 

3. Click the Web site you 
want to view again. 

4. Click the specific Web 
page you want to view. 

5. Click the History button 
on the toolbar when 
you’ve finished working 
with your history of 
recently view Web pages. 

To Delete a History of 
Visited Web Pages: 
1. Select Tools → Internet 

Options from the menu. 
2. If necessary, click the 

General tab. 
3. In the History folder, click 

the Delete History 
button. 

4. Click Yes. Then click OK 
to close the Internet 
Options dialog box.  

If your History folder is getting full, you should go ahead and delete the contents. You 
can clear your History folder using the Internet Options dialog box. 

66.. Select Tools → Internet Options from the menu. If necessary, click the 
General tab. 
The Internet Options dialog box appears with the General tab in front. Here, you can 
clear your History folder and change the number of days that you would like pages 
kept in the folder. The default number of days is 20. 
Go ahead and delete the contents of the History folder. 

77.. In the History folder, click the Delete History button.  
A dialog box appears, asking if you are sure that you want to delete the contents of 
your History folder. 
You may want to go back to the Yahoo home page, so you’d better not delete it just yet. 

88.. Click No and then click the Cancel button to close the Internet Options 
dialog box. 
The Internet Options dialog box closes and you return to the Internet Explorer program 
window with the History folder still open. 
When you are finished working with the History folder, go ahead and close it. 

99.. Click the History button on the toolbar. 
The History folder disappears. 

Move on to the next lesson to learn how to add a Web page to the Favorites list!  
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Lesson 3-9: Adding a Web 
Page to Favorites 
 

You have finally found a Web page about hippopotamus food, and you want to return back to 
it later. What should you do? Well, you don’t have to write down the Web address on a Post-It 
note and stick on your monitor—you can add the Web page to Internet Explorer’s Favorites so 
you can always quickly return back to any Web page in the list! In this lesson, you’ll learn 
how to bookmark your favorite Web sites using Internet Explorer.  

11.. Make sure you’re connected to the Internet and that your browser is 
open. 

22.. Navigate to a Web page that you visit frequently. 
It doesn’t matter how you get to the Web site—type the page’s Web address in the 
Address bar (if you know it) or navigate there by clicking a hyperlink from another 
Web site. When the desired Web page appears on your screen, you can add it to your 
Favorites so you can always easily return to it later.  

Figure 3-13 

The Add Favorite dialog 
box. 

Figure 3-14 

Click the Favorites button 
to display a list of your 
favorite Web pages. 

 IC3 

Objective: 3.3.2.6 
Req. File: None 

Other Ways to Add a 
Web Page to Favorites: 
• Right-click anywhere on 

the Web page and 
select Add to 
Favorites from the 
shortcut menu. 

Figure 3-14 

Click the Web page you want 
to visit. If the Web page is in 
a folder, click the folder ( ). 

Figure 3-13 The name of the Web page automatically 
appears here, but you can change it to 
something more meaningful. 
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33.. Select Favorites → Add to Favorites from the menu. 
The Add Favorites dialog box appears, as shown in Figure 3-13. The name of the Web 
page appears in the name box—if you want, you can replace the Web page’s default 
name with one that is more meaningful to you. If you want to add a shortcut to the 
folder, click the Create In button. 
When you are finished, go ahead and add the Web page to Favorites. 

44.. Click OK to add the Web page. 
A shortcut to the Web page is added to your list of favorites. 
Here’s how to display your favorite Web sites: 

55.. Click the Favorites button on the toolbar. 
A list of your favorite Web pages appears in a panel on the left side of Internet 
Explorer, as shown in Figure 3-14. 

66.. Click the favorite Web page you want to view. 
If your favorite Web page is in a folder, just click the folder and then the favorite Web 
site. The Web page you clicked appears in the right-hand panel of the Internet Explorer 
program window. 

Move on to the next lesson to learn how to create folders so you can organize your favorite 
Web sites.  
 

 
Favorites 

button 
Other Ways to View Your 
Favorite Web Pages: 
• Select Favorites from 

the menu and then 
select the Web page. 

 Quick 
Reference 

To Add a Web Page to 
Favorites: 
• Go to the Web page, 

select Favorites → Add 
to Favorites from the 
menu, and click OK. 

 Or… 
• Go to the Web page, 

right-click anywhere on 
the Web page and select 
Add to Favorites from 
the shortcut menu. 

To Go to a Favorite Web 
Page: 
• Click the Favorites 

button on the toolbar and 
select the Web page from 
the left-hand side of the 
Internet Explorer program 
window. Click the 
Favorites button when 
you’re finished. 

Or… 
• Select Favorites from the 

menu and then select the 
Web page. 
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Lesson 3-10: Creating 
Favorite Folders and Deleting 
Favorites 
 

If you’ve added a lot of Web pages to your list of favorites, it can be difficult to find a specific 
Web page out of all those entries. You can organize your favorites list by creating subfolders 
to keep related Web pages together—for example, you might create a folder called “Travel” to 
keep all your travel related Web pages together, and another folder called “Financial” to hold 
your financial and investment related Web pages. Here’s how to organize your list of 
favorites: 

11.. Select Favorites → Organize Favorites from the menu. 
The Organize Favorites dialog box appears, as shown in Figure 3-15. Your unorganized 
list of favorite Web sites appears on the right-hand side of the dialog box. Let’s create a 
new folder. 

Figure 3-15 

The Organize Favorites 
dialog box. 

Figure 3-16 

Favorites with new folders 
added. 

 IC3 

Objective: 3.3.2.6 
Req. File: None 

Figure 3-15 

Figure 3-16 



 Chapter Three: Using the Internet 107 
 

Institute of Applied Technology 

22.. Click the Create Folder button. 
A new folder appears in the Favorites list with the default “New Folder” name 
highlighted, as shown in Figure 3-15. All you have to do is give the folder a name. 

33.. Type a name for the folder and press <Enter>. 
The folder is renamed. To add Web pages to the folder, simply drag and drop them into 
the new folder. 

44.. Drag one of your favorite Web pages until it is positioned over the new 
folder. Then, release the mouse button. 
The Web page disappears. Don’t worry, it’s not gone. The Web page has been inserted 
into the new folder. To view the contents of the new folder, simply click it. 

55.. Click the folder you just added to the Favorites list. 
The contents of the folder appear indented and below the folder.  
There may come a time that one of your favorite Web pages just isn’t your favorite 
anymore. When this happens, it’s time to clean out your Favorites list.  
To delete a Web page from your Favorites list… 

66.. Click the Web page that you want to delete from your Favorites list to 
select it. 
When you select a Web page, it becomes highlighted. Now delete it. 

77.. Click the Delete button. 
A dialog box appears asking if you are sure that you want to remove the Web page 
from your Favorites list. 

88.. Click Yes. 
The Web page is now erased from the list. 

99.. Close the Organize Favorites dialog box. 

Ever wish you could view a Web page without being connected to the Internet? Move on to 
the next lesson to learn how.  

Other Ways to Add Web 
Pages to a Folder: 
• Select the Web page, 

click the Move to 
Folder button, select 
the desired folder from 
the list, and click OK. 

Other Ways to Delete 
Web Pages from your 
Favorites List: 
• Select the Web page 

and press the <Delete> 
key.  Quick 

Reference 

To Create a New Favorite 
Folder: 
1. Select Favorites → 

Organize Favorites from 
the menu.  

2. Click the Create Folder 
button.  

3. Rename the folder. 
To Add Web Pages to a 
Favorite Folder: 
• Drag the Web page so 

that it is positioned over 
the desired folder. Then, 
release the mouse 
button. 

 Or… 
• Select the Web page, 

click the Move to Folder 
button, select the desired 
folder from the list, and 
click OK. 

To Delete a Web Page 
from your Favorites 
List: 

• Select the Web page that 
you want to delete from 
your Favorites list and 
click the Delete button. 

Or… 
• Select the Web page and 

press the <Delete> key. 
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Lesson 3-11: Saving a Web 
Page 
 

If you have found an incredibly useful Web page, but it contains more information than you 
have time to look at in one sitting, you may want to save the Web page to a location on your 
computer’s hard disk. This way, you can access the page’s content without having to be 
connected to the Internet. In this lesson, you’ll learn how to save a Web page. 

Let’s try saving the CustomGuide, Inc. Web site. 

11.. If necessary, open your Web browser and navigate to the CustomGuide, 
Inc. Web site by typing www.customguide.com into the Address bar. 

22.. Select File → Save As from the menu. 
The Save Web Page dialog box appears, as shown in Figure 3-17. This is where you 
give the Web page a name so that you can return to it later. 

33.. Type CustomGuide in the File name text box. 
You also have to specify where you would like to save the Web page. 

44.. Click the Look in list arrow and navigate to the folder in which you want 
to save the Web page. 
Your computer stores information in files and folders, just like you store information in 
a filing cabinet.  
The Save dialog box has its own toolbar that makes it easy to browse through your 
computer’s drives and folders. Two controls on this toolbar are particularly helpful: 
• Look In List: Click to list the drives on your computer and the current folder, 

then select the drive and/or folder whose contents you want to display. 
• Up One Level button: Click to move up one folder level. This is especially 

helpful when sifting through folders within folders 
Follow your instructor’s directions to select the appropriate drive and folder to save 
this Web page. 

Figure 3-17 

The Save Web Page 
dialog box. 
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Figure 3-17 
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 Quick 
Reference 
To Save a Web Page: 
1. Select File → Save As 

from the menu. 
2. Type a name for the Web 

page in the File name text 
box. 

3. Click the Save as type 
list arrow and select the 
desired file type. 

4. Click the Save button. 

Saving a Web page is a little different than saving a document or spreadsheet. You need 
to specify a file type. 

55.. Click the Save as type list arrow. 
You have several options here: 
• Web Page, complete: This option will save every file that is needed to 

display the current Web page. This includes style sheets, frames, graphics, 
animations, etc. Each individual file is saved in its original format. This can be a 
very large file. 

• Web Page, HTML only: This option will save just the information contained 
in the Web page. It will not save graphics, animations, sounds, videos, etc. All of 
the text will maintain its original formatting and placement. 

• Text Only: This option will save just the information contained in the Web 
page, much like the HTML only option. However, the Text Only option, will 
save the file in straight text format.  

66.. Choose the Web Page, HTML only option. 
If you actually wanted to save this Web page, you would go ahead and click the Save 
button. You don’t want to save the page, so… 

77.. Click the Cancel button in the Save Web Page dialog box. 
The Save Web Page dialog box closes and you return to the Internet Explorer program 
window. 
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Lesson 3-12: Copying and 
Pasting Images, URLs, and 
Text 
 

In your various searches of the World Wide Web, you may come across some text, an image, 
or even a URL that you want to copy into a word-processing program. For example, if you are 
creating a memo for your company and you would like to include the logo that is posted on 
your company’s Web site, you could open the site, copy the image, and paste it into the 
document. 

It is important to note that Internet users are not granted permission to copy just anything off 
of the Web. Some Web pages are copyrighted, which means that you would be breaking the 
law if you copied anything from the page and then used it yourself. Some Web sites allow you 
to copy items, while others do not. Be careful when you choose to use items from someone 
else’s Web site. In most cases, it is best to ask the Web master, or site creator, for permission 
before you copy anything from a Web page.  

In this lesson, you’ll learn how to copy an image, some text, and a URL and then paste them 
into a word-processing program.  

11.. Make you are connected to the Internet and that your Web browser is 
open. 
First, you need to navigate to a Web page that you would like to copy items from. In 
this lesson, we’re going to use the CustomGuide, Inc. Web site. 

22.. Navigate to the CustomGuide, Inc. Web site by typing 
www.customguide.com into the Address bar. 
The CustomGuide home page appears in the browser’s window. Next, you need a 
program to copy the items into. You can use any word-processing program, but in this 
lesson we’re going to use Microsoft Word. 

Figure 3-18 

The copied items pasted 
into a word-processing 
program. 
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Other Ways to Copy Text 
and Web Addresses: 
• Press <Ctrl> + <C>. 
• Click the right-mouse 

button and select Copy 
from the shortcut menu. 

Figure 3-18 
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 Quick 
Reference 
To Copy Text or Web 
Addresses from a Web 
Page: 
1. Select the text or URL 

you want to copy. 
2. Select Edit → Copy from 

the menu. 
 Or… 
 Press <Ctrl> + <C>. 
 Or… 
 Right-click the selected 

text or URL and select 
Copy from the shortcut 
menu. 

To Copy an Image from a 
Web Page: 
1. Right-click the image you 

want to copy. 
2. Select Copy from the 

shortcut menu. 

To Paste Text, an Image, 
or a URL into a Document: 
• Click the Paste button on 

the Standard toolbar. 
Or… 
• Select Edit → Paste 

from the menu. 
Or… 
• Press <Ctrl> + <V>. 
Or… 
• Right-click the document 

and select Paste from the 
shortcut menu. 

33.. Open Microsoft Word by clicking the Windows Start button and 
selecting Programs → Microsoft Word from the menu. 
Your computer may be set up differently, so if you have trouble finding the program, 
ask your instructor for assistance.  
You need to display your browser window again. 

44.. Click the Internet Explorer icon on the Windows taskbar to make the 
browser window active. 
First, let’s copy some text. You are going to select the text that appears above the 
picture on the CustomGuide home page. 

55.. Select the paragraph that begins with Welcome! and ends with blended 
learning curriculums. 
The text will be highlighted when it has been selected. Next, you need to copy the text.  

66.. Select Edit → Copy from the menu. 
Nothing appears to have changed, but the selected text has been copied to the Windows 
clipboard and is ready to be pasted. 

77.. Click the Microsoft Word icon in the taskbar to make the program 
active. 
Now, all you have to do is paste the copied text into the document. 

88.. Click the Paste button on the Standard toolbar. 
The copied text is inserted. Copying images is just as easy. 

99.. Click the Internet Explorer icon to make the browser active. 
In order to copy the image itself, and not the link, you need to use the shortcut menu. 

1100.. Right-click the Questions? Click for live help. icon located in the upper 
right-hand corner of the CustomGuide, Inc. Web page and select Copy 
from the shortcut menu. 
The selected image has been copied to the Windows clipboard. 

1111.. Click the Microsoft Word icon in the taskbar to make the program active 
and press <Ctrl> + <V>. 
The image is pasted into the document. The last thing you’ll learn to copy is a Web 
address, or URL. 

1122.. Click the Internet Explorer icon to make the program active. Then select 
the entire Web address that is displayed in the address bar. 
This time, you’re going to use a keyboard shortcut to copy. 

1133.. Press <Ctrl> + <C>. 
The URL has been copied to the Windows clipboard. 

1144.. Click the Microsoft Word icon in the taskbar to make the program active 
and select Edit → Paste from the menu. 
The URL is pasted into the document. Compare your document to the one pictured in 
Figure 3-18.  
That’s all there is to copying text, images, and Web addresses from Web pages. You do 
not want to save the items that you copied from the CustomGuide, Inc. Web site, so… 

1155.. Close the Microsoft Word program without saving your changes. 

 
Paste button 

Other Ways to Paste: 
• Select Edit → Paste 

from the menu. 
• Press <Ctrl> + <V>. 
• Click the right-mouse 

button and select Paste 
from the shortcut menu. 
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Lesson 3-13: Previewing and 
Printing a Web Page 
 

You can create a printed copy of just about any Web page (if your computer is connected to a 
printer). Before you print a Web page, it’s a good idea to preview it on a screen to make sure 
that all of the properties you changed look okay. This way, you will not have to print the page 
numerous times (wasting paper). 

The last thing that you need to do before you send the Web page off to the printer is change 
some of the output options. In this lesson, you’ll learn how to print an entire Web page, print 
specific pages, print a specific frame, print selected text, change the number of copies, and 
most importantly, how to print! 

To preview the Web page, you must once again go to the File menu. 

Figure 3-19 

The Print Preview screen. 

Figure 3-20 

The Print dialog box. 

 IC3 

Objective: 3.3.2.9 
Req. File: None 

Figure 3-19 

Figure 3-20 
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 Quick 
Reference 
To Preview a Web Page on 
Screen: 
• Select File → Print 

Preview from the menu. 

To Change Print Output 
Options: 
1. Select File → Print from 

the menu. 
 Or… 
 Press <Ctrl> + <P>. 
2. Change the options in the 

Print dialog box. 

To Print a Web Page: 
• Click the Print button on 

the Internet Explorer 
toolbar. 

Or… 
• Select File → Print from 

the menu. 
Or… 
• Press <Ctrl> + <P>. 

11.. Select File → Print Preview from the menu. 
A print preview of the Web page appears on the screen, as shown in Figure 3-19. 
Unless you have eyes like a hawk (or a very large monitor) you probably won’t notice 
the small changes you made to the Web page’s margins, but you can certainly tell that 
the page is using landscape orientation. 

22.. Click the Close button on the Print Preview toolbar. 
You return to the Web page. Now that everything has been previewed and you have 
changed the Web page’s properties, you are ready to print. 

33.. Click the Print button on the Internet Explorer toolbar. 
The Web page is sent to the default printer connected to your computer using default 
settings (entire Web page, print on one side). 

NOTE: If you are covering this lesson in a classroom setting, your computer may not 
be set up for printing ability 

If you don’t want to use the default settings, use the Print dialog box to specify print 
options such as which pages you want to print, or number of copies. 

44.. Select File → Print from the menu. 
The Print dialog box appears, as shown in Figure 3-20. Using the print keystroke 
<Ctrl> + <P> will open the Print dialog box as well. 
Let’s explore some of the options in the Print dialog box. 

55.. Let’s look at the Page Range section of the dialog box. 
This area contains options that will allow you to specify exactly what you want to print 
from the Web page. There are four options in this area: 
• All: Prints all the pages in the Web page. 
• Current Page: Prints only currently active page. 
• Selection: Prints only selected text or frame; this option is not available if you 

haven’t selected anything within the Web page. 
• Pages: Prints only the pages of the Web page that you specify in the Pages text 

box. 
Once you’ve specified what you want to print, you can specify how many copies you 
want to print. 

66.. Look at the Copies section of the dialog box.  
Specify how many copies of the Web page you want to print here. Check the Collate 
checkbox to print the copies in binding order. 
If you are hooked up to a network that has multiple printers, you can also choose which 
printer you want to print from. The default printer is the one that appears in the dialog 
box, but you can print from a different printer if you have multiple printers installed on 
your computer. 

77.. In the Printer section at the top of the dialog box, click the Name list 
arrow.  
If you have multiple printers installed on your computer, you will have multiple 
options in the list. 
Once you have chosen your print options, you can click OK to print the Web page, or if 
you choose not to print, click the Cancel button. 

88.. Click the Cancel button. 
The Print dialog box closes, and you return to the Web page.  

Other Ways to Print: 
• Press <Ctrl> + <P >. 
• Click the Print button 

on the toolbar. 



114 IC3 Module 3 – Living Online 

© 2005 CustomGuide, Inc. 

Lesson 3-14: Downloading 
Images and Files 
 

Another common way people use the Internet is to download files from a Web server on the 
Internet and save them onto their local hard drive. Some of the most common types of files 
people download from the Internet include: 
• Text: You can save any text that you find on a Web page. Usually, these are word-

processor files, like Microsoft Word. 
• Images: You can save any picture that you see on a Web page, print it, use it as your 

Windows wallpaper, or anything else you can think of. 
• Programs: Many software companies have demo versions of their programs available 

on the Internet that you can download and evaluate. In addition, thousands of shareware 
programs are available for you to download for free! 

• Patches, Fixes, and Drivers: One of the great things about the Internet is how you 
can find and download bug fixes for your programs, and drivers for your hardware 
devices, such as a driver for a discontinued foreign printer. 

• Music: A new file format called MP3 is revolutionizing the music industry. MP3 files 
are sound files that you can listen to on your computer. They have digital CD quality 
sound, but use compression so they are eleven times smaller than the CD equivalent and 
small enough to be downloadable from the Internet. 

• Videos: Movies are becoming almost as widely available online as music has become. 
You can download some of your favorite flicks from the Internet, but beware – video files 
tend to run on the larger side and can take an extremely long time to download. 

Figure 3-21 

Specify where on your 
hard drive you want the 
downloaded file to be 
saved. 

Figure 3-22 

Windows displays the 
progress of a download. 
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Figure 3-22 

Figure 3-21 
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 Quick 
Reference 
To Save an Image from a 
Web Page: 
1. Right-click the image you 

want to save and select 
Save Picture As from the 
shortcut menu. 

2. Navigate to the drive and 
folder where you want to 
save the image, give the 
image a different name (if 
you want to), and click 
OK. 

To Download a File: 
1. Right-click the file you 

want to download and 
select Save Target As 
from the shortcut menu. 

2. Navigate to the drive and 
folder where you want to 
save the file, give the file 
a different name (if you 
want to), and click OK. 

• Viruses: Just kidding – the last thing in the world you want to download from the 
Internet is a computer virus! Since you won’t always know where a program or file you 
want to download comes from, you should make sure that your computer has a virus 
protection program installed before you download anything from the Internet. 

Other than the slight risk of contracting a virus (if you don’t have virus protection software 
installed), the only other downside of downloading files off the Internet is how long it can 
take. Also, make sure that you are aware of the laws that govern downloaded files from the 
Internet. Some files may be copyrighted, and therefore are illegal to download onto your 
computer. Remember, just because the file is available to download, that does not necessarily 
make it legal! 

In this lesson, you’ll learn how to download files and images from the Internet and save them 
to your hard disk. When you come across a picture or image on the Internet that you really 
like, here’s how you can permanently save it to your computer’s hard drive: 

11.. Right-click the image you want to save and select Save Picture As from 
the shortcut menu. 
Windows asks where you want to save the image by presenting you with the Save As 
dialog box, as shown in Figure 3-21. 

22.. Navigate to the drive and folder where you want to save the image, give 
the image a different name (if you want to), and click OK. 
Windows saves the image to the specified drive and folder. 
The procedure for downloading and saving programs and other files from the Internet 
is almost the same as downloading and saving an image. Here’s how… 

33.. Find the file you want to download, right-click it and select Save Target 
As from the shortcut menu. 
Also, you can usually just click a file that you want to download, but doing this will 
sometimes open the file in Internet Explorer instead of saving it to your computer.  
As with images, you have to specify where you want to save this file. 

44.. Navigate to the drive and folder where you want to save the file, give the 
file a different name (if you want to), and click OK. 
Windows will download the file and save it to the drive and folder you specified. It 
may take several minutes, hours, or sometimes even days to download the file, 
depending on the file’s size and how fast your connection to the Internet is. Windows 
displays a dialog box that shows the progress of the download, as shown in Figure 
3-22. 

NOTE: Make sure you remember where you save your downloaded files! Many 
people download software without thinking about where they’re saving it, 
only to be unable to find the file once it’s finished downloading. It makes 
sense to create and use a folder named “Downloads” or something similar 
where you can save your downloaded files. 

One more note about downloading files and programs off the Internet: a large percent of the 
programs you can download off the Internet are stored in ZIP files. ZIP files package 
programs and files together to make them much easier to download. 

ZIP files do two things:  
• Compress Information: Instead of downloading a 2 MB file, you can download a 1 

MB file in half of the time. 
• Store multiple files together in a single ZIP file: Instead of downloading 20 or so 

files that a program needs to run, you only have to download a single ZIP file. 
If your version of Windows does not unzip the files for you, there is another program called 
WinZIP. You can find and download this program for free at www.winzip.com. 

 
Internet 
Explorer 

shortcut menu
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Lesson 3-15: Changing Your 
Home Page 
 

Is there a Web page that you really like and use almost every time you’re on the Internet? You 
might consider making that Web page your Home page—the Web page that appears each time 
you start Internet Explorer. Some of the Search Engines we discussed in a previous lesson 
make excellent home pages. Here’s how to make a Web page your home page: 

11.. Make sure you’re connected to the Internet and that your Web browser is 
open. 

22.. Go to a Web page that you want to set as your home page and select 
Tools → Internet Options from the menu. Click the General tab, if 
necessary. 
The Internet Options dialog box appears, as shown in Figure 3-23. The address of your 
current home page appears in the Address text box that appears in the Home page 
panel. 

33.. Click the Use Current button to set the Web page that is displayed on 
your screen as your new home page. 
Or, you could change your home page manually by clicking the text that appears in the 
Address text box and typing in the address. 

44.. Click OK. 
The Internet Options dialog box closes. The next time you start Internet Explorer, the 
Web page you just selected will appear as your start page. 
Go ahead and try it out. 

55.. Close Microsoft Internet Explorer by clicking the Close button. 
The program closes. Now go ahead and start it up again to see your new home page. 

66.. Double-click the  Internet Explorer icon on the Window’s desktop. 
The Internet Explorer program opens, displaying your new home page. 

Figure 3-23 

You can change your 
home page in the Options 
dialog box. 

 IC3 

Objective: 3.3.1.1 and 
3.3.2.11 
Req. File: None 

 Quick 
Reference 

To Change Your Home 
Page: 
• Go to the Web page that 

you want to set as your 
home page, select Tools 
→ Internet Options from 
the menu and click the 
Use Current button. Or, 
type the address into the 
Address text box that 
appears in the Home 
Page panel. 

Figure 3-23 

Enter the address of the Web page that 
you want to set as your home page here. 
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Lesson 3-16: Changing 
Privacy Settings 
  

In addition to changing a browser’s default home page, you can also change a browser’s 
privacy settings such as “cookies,” or files that track your activity on the Web. 

In this lesson, you’ll learn how to manage the privacy settings for your Web browser. 

11.. Make sure you’re connected to the Internet and that your Web browser is 
open. 

22.. Select Tools → Internet Options from the menu and click the Privacy 
tab. 
The Internet Options dialog box appears with the Privacy tab in front, as shown in 
Figure 3-24. Let’s take a look at some of these settings. 

33.. Click the Sites button. 
The Per Site Privacy Actions dialog box appears. Here, you can manage sites that use 
cookies. Simply type the address of the Web site you wish to manage in the text box, 
then click the Allow button or the Block button to allow or block cookies, respectively. 
We don’t want to make any changes here, so let’s close the dialog box.  

44.. Click the dialog box Close button. 
You are now back at the Internet Options dialog box. Refer to Figure 3-24 for more 
privacy settings.  
When you are finished navigating the Internet Options dialog box, close it. 

55.. Click the Cancel button to close the Internet Options dialog box.  

Figure 3-24 

The Internet Options 
dialog box with the Privacy 
tab selected. 

 IC3 

Objective: 3.3.2.11 
Req. File: None 

 Quick 
Reference 

To Manage Privacy 
Settings for a Web 
Browser: 
1. Select Tools → Internet 

Options from the menu 
and click the Privacy tab. 

2. Specify your options, and 
when you’re finished, click 
OK. 

Figure 3-24 

Click the Privacy Tab 

Click here to view 
settings for the pop-up 
blocker

Move the slider to 
select a privacy 
setting for the 
Internet zone 

Click here to override 
automatic cookie handling

Click here to specify which 
Web sites are always or 
never allowed to use cookies 
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Lesson 3-17: Selecting a 
Search Engine 
 

The Internet’s greatest strength is also its greatest weakness: with so much information—
literally millions of Web pages—it can be extremely difficult to find what you’re looking for. 
Fortunately, there are many Search Engines that catalog the millions of Web pages on the 
Internet so that you can find Web pages on topics that interest you. There are many Search 
Engines available on the Internet—you’ve probably heard of some of the more popular ones, 
like Google, Yahoo, Excite, and HotBot. In this lesson, you’ll learn how you can search the 
Web to find information on specific topics. 

11.. Make sure you are connected to the Internet and that your Web browser 
is open. 

Figure 3-25 

You can search the Web 
with Internet Explorer’s 
integrated search function. 

Figure 3-26 

You can also search the 
Web with Yahoo or any 
other Search Engine of 
your choice. 

 IC3 

Objective: 3.3.3.1, 3.3.3.2, 
3.3.3.3, and 3.3.3.4 
Req. File: None 

 
Search button 

Enter a word or phrase you 
want to search for here and 
click Search. 

Figure 3-25 

Enter a word or phrase 
you want to search for 
here and click the 
Yahoo! Search button. 

Figure 3-26 

Your search results 
appear here. 
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 Quick 
Reference 
To Search the Web for 
Information Using Internet 
Explorer: 
1. Click the Search text box 

and type in the keyword 
or phrase you are looking 
for. 

2. Click the link for the Web 
page you want to look at. 

To Search the Web for 
Specific Information using 
a Search Engine: 

• Type the Web address for 
the Search Engine in the 
Address bar and press 
<Enter>. Type the word 
or phrase you want to 
search for in the Web 
page’s Search text box 
and press <Enter>. 

22.. Click the Search text box and type in the keyword or phrase you want to 
search for. 
For better search results, use complete sentences or several keywords that describe 
what you’re looking for. For example, typing “Where can I find a good oyster 
restaurant in Chicago?” would yield better results than simply “oysters”. 

33.. Click the Search button. 
The Security Alert dialog box may appear (it appears almost every time you send 
information over the Internet, unless you check the “In the future do not show the 
warning” check box). If it does, you can safely click OK. 
Microsoft Internet Explorer returns a list of Web pages, ranked by relevance, which 
contain the word or phrase you specified. You may have to scroll down to view the 
entire list. 

44.. Click the Web page you want to view. 
Are you finding mostly irrelevant information in your search results? Then you may 
have to refine your search. For example, a search on the word “Windows” may result 
in links to “Anderson® Windows,” “Stained Glass Windows,” and “Microsoft 
Windows”, while a search on the phrase “Microsoft Windows” will result in links to 
“Microsoft Windows.” Some Search Engines will let you search within your results. 
For example, you could do a search for “Microsoft Windows” and then further refine 
your search by searching results for the word “Networking.” 
You don’t have to use Microsoft Internet Explorer’s Search feature to look for 
information on the Web—you can also go directly to a Web site and use its indexes or 
lists of links to help you find related information located on other Web sites. Some Web 
sites even have their very own Search feature, allowing you to search the site itself.    
The table below is by no means a definitive inventory of the dozens of Search Engines 
that are currently available on the Web, but it lists the best and most popular Web 
Search Engines and their Web addresses. 

Table 3-5: Popular Search Engines on the Web 
Site Web Address Description 
AltaVista www.altavista.com Operated by Digital, AltaVista claims to catalog and 

index more Web pages than any other search engine. 

Excite www.excite.com Excite has a powerful, highly rated search engine, and it 
also has one of the best customizable home pages on 
the Internet. 

Google www.google.com Google is consistently ranked as the best and most 
relevant search engine. However, it doesn’t contain 
many other features other than search. 

Hotbot www.hotbot.com Though not as popular as some of the others, HotBot 
consistently ranks as one of the best, most relevant 
search engines. 

Lycos www.lycos.com Lycos is another powerful search engine, especially if 
you’re looking for information in formats other than Web 
pages, such as MP3 sound files. 

Yahoo www.yahoo.com The mother of all Web pages, Yahoo is actually more of 
a directory service than a search engine, but it makes it 
very easy to find topics, especially if you’re new to the 
Internet. 

 
Search Box
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Lesson 3-18: Performing an 
Advanced Search 
 

Performing a search using a keyword or phrase is definitely effective; in fact sometimes it can 
be too effective. If you are too vague with your request, or if the subject area is too broad, the 
Search Engine could produce hundreds of thousands of results. You certainly don’t want to 
have to waste your time searching through a bunch of fluff to find the information that you are 
really looking for, do you? That’s why each Search Engine is equipped with an Advanced 
Search feature. Advanced searches allow you to incorporate multiple different types of 
selection criteria in one search. Using an advanced search is one of the best ways to narrow 
down your search results. 

In this lesson, you will learn how to perform an advanced search. You will not use all of the 
selection criteria available, but take a look at Table 3-6: Advanced Search Selection Criteria 
Options for a description of each selection criteria option available. 

11.. Make sure you are connected to the Internet and that your Web browser 
is open. 
First, you need to choose a Search Engine. 

22.. Navigate to a search engine’s Web site by typing the Web address into 
the Address bar. 
The search engine’s home page appears. To perform an advanced search, you need to 
click the Advanced or Advanced Search hyperlink. 

33.. Click the Advanced or Advanced Search hyperlink. 
As an example, Yahoo’s Advanced Web Search page is shown in Figure 3-27. This is 
where you enter the desired selection criteria in order to refine your search. 

44.. Enter the desired selection criteria into the appropriate text boxes. 
Make sure to choose the most effective keywords when performing a search. When you 
are finished, click the Search button. 

Figure 3-27 

Yahoo’s Advanced Web 
Search page. 
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Figure 3-27 
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 Quick 
Reference 
To Perform an Advanced 
Search: 
1. Navigate to any Search 

Engine’s home page. 
2. Click the Advanced or 

Advanced Search 
hyperlink. 

3. Enter the desired 
selection criteria into the 
appropriate text boxes. 

4. Click the Search button. 

55.. Click the Search button. 
The advanced search produced more specific Web sites ensuring that you have less 
information to have to sift through in order to find meaningful information. Pretty neat, 
huh? 

NOTE: Another way to search for information strategically is to perform a Boolean 
search. Boolean search strings (such as AND, &, +, OR, NOT) can be used to 
effectively narrow or refine a search on an Internet search engine. For 
example, typing “college OR university” would collate the results of both 
“college” and “university” to retrieve all unique records containing one term, 
the other, or both. Typing “poverty AND crime” would retrieve records only 
in which both of the search terms are present. The more terms or concepts you 
combine in a search with AND, the fewer records you will retrieve. 

Take a look at the following table to learn more about the selection criteria options 
available for advanced searches. All search engines contain selection criteria similar to 
these. However, be aware that the wording may be somewhat different. 

Table 3-6: Advanced Search Selection Criteria Options 
Selection Criteria Description 
All Words The Web page must contain all of the words listed, in no particular order. 

The words do not have to appear together. 

Exact Phrase The Web page must contain an exact phrase, in a specific order. The 
words must appear together. 

Any Words The Web page can contain any of the words listed. 

Not These Words The Web page cannot contain any of the words listed. 

Where Words Occur The Web page must contain the words listed in certain parts of the page 
that you specify. For example, in the title, in the URL, or in the body. 

Date Select a time period that the Web page must have been updated within. 

Site or Domain Type Specify a domain type that the Web page must be. For example, .com, 
.org, or .edu. 

File Format Specify a file format that the Web page must use. For example, .doc, .xls, 
or .pdf. 

Country The Web page must originate from the country you specify. 

Language The Web page must be written in the language(s) you specify. 

Filter Most search engines allow you to enable a filter that automatically discards 
Web pages with explicit content. 

Number of Results Specify the number of results that you would like displayed on the screen 
at one time. 
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Chapter Three Review 

Lesson Summary 

Understanding Key Terms 

• HTTP: HTTP stands for Hypertext Transfer Protocol. It is a set of rules for transferring files on the 
World Wide Web. HTTP files can be text, graphics, sound, video, or any other multimedia file type. 
HTTP works like this: your browser (for example, Internet Explorer) sends an HTTP request to a 
server for a certain group of Web pages. The server receives this request and sends the page(s) 
back to your computer. 

• URL: URL stands for Uniform Resource Locator. This is an address for a file that is located 
somewhere on the Internet. Each URL is unique to the Web page that it links to. Each URL 
contains a protocol, domain name, resource, and extension. Don’t worry about these terms for 
now, because URLs will be covered more extensively in another lesson. 

• Hyperlink: A hyperlink is a link from one word or image to another. Most commonly, a hyperlink will 
appear on a page as a blue underlined word or phrase, but they can also be images or animations. 
To use a hyperlink, you simply click on it with your mouse and it will instantly take you to the 
destination. 

• ISP: ISP stands for Internet Service Provider. An Internet Service Provider is a lot like a phone 
company, except instead of letting you make telephone calls to other people, an Internet Service 
Provider lets your computer connect to the Internet. Just like your telephone company, Internet 
Service Providers charge for their services – currently the average rate seems to be about $20 per 
month for unlimited usage. You’ve probably already heard of the most famous Internet Service 
Provider – America Online, or AOL. 

• Plug-in: A plug-in is a small piece of software that enriches a larger piece of software by adding 
features or functions. For example, a plug-in extends the capabilities of a Web browser, such as 
Microsoft Internet Explorer, by allowing the browser to run multimedia files. 

• FTP: FTP stands for File Transfer Protocol. Like HTTP, FTP is a set of rules for transferring files on 
the World Wide Web.  FTP is commonly used to transfer Web page files from the creator’s 
computer to the server. FTP is also used to download files to your computer from another server. 

• Cookie: Cookies have a bad rep! A cookie is simply one or more pieces of information that are 
stored as text files on your computer. A Web server sends the cookie and the browser stores it. 
Each time the page is referenced, the browser resends the cookie to the original server. Cookies 
are most commonly used to store frequently used information, such as a user ID number. They are 
not harmful, as their rotten reputation implies. They cannot transmit viruses, nor can they take any 
information from your computer back to the server. In fact, cookies can be helpful because they 
allow a server to recall any user-specific information. This can save you tons of time! 

• Cache: You automatically request files when you look at a Web page. These files are stored in a 
cache. A cache is simply a temporary storage place that is located in a subdirectory beneath the 
main directory for your browser. Caches are created so that when you return to a page that you 
have recently visited, the browser can get the page from the cache, rather than going back to the 
server. This saves time and reduces the amount of Internet traffic. Most Web browsers will allow 
you to manipulate the size of your cache. 
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• Encryption: When you encrypt something, you are putting it into a code that only authorized 
people can understand. This prevents unauthorized users from accessing personal or confidential 
information. 

• Firewall: A firewall is a group of related programs that protect a private network from users in other 
networks. Basically, a firewall screens all incoming information before sending it off to its intended 
destination so the network stays secure - free from hackers and viruses. 

Understanding Web Browsers 

• A Web browser is a program that allows your computer to view and navigate the World Wide Web. 

• If you are having trouble viewing certain images or animations with your browser, it means that 
your browser is not compatible with specific software applications or that the browser is out-of-date. 

• The two most commonly used Web browsers are Microsoft’s Internet Explorer and AOL’s Netscape 
Navigator. 

Understanding Web Addresses 

• Protocol: The protocol tells the server which type of resource you are trying to locate. 

• Domain Name: The domain name indicates the company or individual that maintains the site. 

• Resource:  The resource can be almost any item, including files, programs, and data. 

• Extension: An extension indicates what type of program or code is running the Web site. .htm and 
.html are the most commonly used extensions. 

Understanding Secure Web Sites and Information Quality 

• Secure Web Site: A secure Web site contains information not available to everyone. 

• User Name: A name, either assigned or chosen by the user, that a person must enter along with a 
password in order to gain access to a secure Web site. 

• Password: A group of characters (usually 4-16 depending on the site) used to determine whether 
or not the user trying to gain access to a secure Web site is who they claim to be. 

• Criteria for evaluating the quality of information found on the Internet include: Relevance, 
Reliability, Validity, Potential bias, and Sufficiency. 

Opening and Closing a Web Browser 

• To Connect to the Internet: Double-click the Internet Explorer icon on the desktop. Or, click 
the Internet Explorer icon on the Quick Launch toolbar. Or, click the Windows Start button and 
select Internet Explorer from the menu. If necessary, enter your user name and password and 
click Connect. 

• To Close a Web Browser: Click the Internet Explorer window’s Close button. Or, select File → 
Close from the menu. 

Displaying a Specific Web Page 

• To Display a Specific Web Page: Type the Web address in the Address bar and press <Enter>. 
Or, press Ctrl + <L>, type the Web address, and press OK.  

• To Refresh a Web Page: Click the Refresh button on the toolbar. 
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Navigating a Web Site and Using Hyperlinks 

• To Use a Hyperlink: Click the hyperlink with the  pointer. 

• To Go Back to the Previous Page: Click the Back button on the toolbar. 

• To Go Forward to an Already Viewed Page: Click the Forward button on the toolbar. 

Displaying and Deleting a History of Visited Web Pages 

• To Display a History of Visited Web Pages: Click the History button on the toolbar. Click the 
day or week you last viewed the Web page. Click the Web site you want to view again. Click the 
specific Web page you want to view. Click the History button on the toolbar when you’ve finished 
working with your history of recently view Web pages.  

• To Delete a History of Visited Web Pages: Select Tools → Internet Options from the menu. If 
necessary, click the General tab. In the History folder, click the Delete History button. Click Yes. 
Then click OK to close the Internet Options dialog box. 

Adding a Web Page to Favorites 

• To Add a Web Page to Favorites: Go to the Web page, select Favorites → Add to Favorites 
from the menu and click OK. Or, go to the Web page, right-click anywhere on the Web page and 
select Add to Favorites from the shortcut menu. 

• To Go to a Favorite Web Page: Click the Favorites button on the toolbar and select the Web 
page from the left side of Internet Explorer. Click the Favorites button when you’re finished. Or, 
select Favorites from the menu and select the Web page. 

Creating Favorite Folders and Deleting Favorites 

• To Add a Folder to Favorites: Select Favorites → Organize Favorites from the menu. Click the 
Create Folder button. Type a name for the folder. Press the <Enter> key. 

• To Add Web Pages to a Folder: Click and drag the Web site until it is positioned over the folder 
and release the mouse button. Or, select the Web site, click the Move to Folder button, select the 
desired folder from the list, and click OK. 

• To Delete a Web site from Favorites: Select the Web site. Click the Delete button or press the 
<Delete> key. Click Yes when asked if you really want to delete the Web site. 

Saving a Web Page 

• To Save a Web Page: Select File → Save As from the menu. Type a name for the Web page in 
the File name text box. Click the Save as type list arrow and select the desired file type. Click the 
Save button. 

Copying and Pasting Images, URLs, and Text 

• To Copy Text or Web Addresses from a Web Page: Select the text or URL that you want to copy. 
Select Edit → Copy from the menu. Or, press <Ctrl> + <C>. Or, Right-click the selected text or 
URL and select Copy from the shortcut menu. 

• To Copy an Image from a Web Page: Right-click the image you want to copy. Select Copy from 
the shortcut menu. 

• To Paste Text, an Image, or a URL into a Document: Click the Paste button on the Standard 
toolbar. Or, select Edit → Paste from the menu. Or, press <Ctrl> + <V>. Or, right-click the 
document and select Paste from the shortcut menu. 
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Previewing and Printing a Web Page 

• To Preview a Web Page on Screen: Select File → Print Preview from the menu. 

• To Change Print Output Options: Select File → Print from the menu. Or, press <Ctrl> + <P>. 
Change the options in the Print dialog box. 

• To Print a Web Page: Click the Print button on the Internet Explorer toolbar. Or, select File → 
Print from the menu. Or, press <Ctrl> + <P>. 

Downloading Images and Files 

• To Save an Image from a Web Page: Right-click the image you want to save and select Save 
Picture As from the shortcut menu. Navigate to the drive and folder where you want to save the 
image, give the image a different name (if you want to), and click OK. 

• To Download a File: Right-click the file you want to download and select Save Target As from the 
shortcut menu. Navigate to the drive and folder where you want to save the file, give the file a 
different name (if you want to), and click OK. 

Changing Your Home Page 

• To Change Your Home Page: Go to the Web page that you want to set as your home page, select 
Tools → Internet Options from the menu and click the Use Current button. 

Changing Privacy Settings 

• To Manage Privacy Settings for a Web Browser: Select Tools → Internet Options from the 
menu and click the Privacy tab. Specify your options, and when you’re finished, click OK. 

Selecting a Search Engine 

• Search Engines are Web sites that are specially designed to help you find information stored on 
other sites on the Web. 

• To Search the Web for Information Using Internet Explorer: Type the word or phrase you want 
to search for in the Search text box and click the Search button. Click the link for the Web page 
you want to look at.  

• To Search the Web for Specific Information Using a Search Engine: Type the Web address for 
the search engine in the Address bar and press <Enter>. Type the word or phrase you want to 
search for in the Web page’s Search text box and press <Enter>. 

Performing an Advanced Search 

• To Perform an Advanced Search: Navigate to a search engine’s home page. Click the Advanced 
or Advanced Search hyperlink. Enter the desired selection criteria into the appropriate text boxes. 
Click the Search button. 
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Quiz 

1. When referring to the Internet, what is a cookie? 
A.  A small piece of software that enriches a larger piece of software by adding features 

or functions. 
B. One or more pieces of information that are stored as text files on your computer. 
C. A tasty piece of computer hardware. 
D. A temporary storage place. 

2. A Web browser is: 
A. The world’s largest supercomputer that contains and runs the Internet. 
B. A spider at the shopping mall. 
C. A software application that helps you search for information on the World Wide Web. 
D. A software application that allows you to connect with the Internet. 

3. Which of the following is NOT a part of a Web address? 

A. Resource 
B. Extension 
C. Domain Name 
D. Connection Site 

4. What does the extension “.uk” stand for? 

A. Ukulele 
B. University of Kentucky 
C. United Kingdom 
D. Ukraine 

5. A secure Web site contains information available to everyone. (True or 
False?) 

6. It is recommended that you use your social security number or birth date 
as your password. (True or False?) 

7. The easiest way to display a specific Web page is to: 

A. Send a letter to the Web address. 
B. Type the Web address in the Address bar and press <Enter>. 
C. Type the Web address in the Navigation Pane and press <Enter>. 
D. Select File → Address bar from the menu.  

8. A Home page is the first Web page you see when you connect to the 
Internet. (True or False?) 
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9. Which button on Internet Explorer’s toolbar brings you back to the page 
you last viewed? 
A. Home 
B. Stop 
C. Refresh 
D. Back 

10. Which of the following statements is NOT true? 

A. You can add a Web page to Favorites by right-clicking anywhere on the Web page 
and selecting Add to Favorites from the shortcut menu. 

B. You can add a Web page to Favorites by navigating to the page and selecting 
Favorites → Add to Favorites from the menu. 

C. You can view your Favorite Web pages by selecting Edit → Favorites from the 
menu. 

D. You can view your Favorite Web pages by clicking the Favorites button on the 
toolbar. 

11. When you add a Web page to Favorites, you must keep the original name of 
the site. (True or False?) 

12. All of the following are file types that are available when saving a Web 
page, except: 
A. Web Page, complete 
B. Web Page, images only 
C. Web Page, HTML only 
D. Text Only 

13. All of the following are ways to paste text, images, or URLs into a 
document, except: 
A. Click the Paste button on the Standard toolbar. 
B. Select Edit → Paste from the menu. 
C. Right-click the document and select Paste from the shortcut menu. 
D. Press <Ctrl> + <P>. 

14. There are very few search engines available on the World Wide Web. (True 
or False?) 

15. Which of the following is NOT an advantage of conducting an advanced 
search?  

A. The results of an advanced search cost less than those of a standard search. 
B. The results of the search will contain more specific information.  
C. You can incorporate multiple types of selection criteria into one search. 
D. There will be fewer results to sort through to find the information that you are 

searching for. 
 

Homework 
1. Open Microsoft Internet Explorer. 

2. Go to the Yahoo Web site (www.yahoo.com). 
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3. Add the Yahoo Web site to Favorites. 

4. In Favorites, create a folder named “Search Engines.” 

5. Move the Yahoo Web site to the new folder. 

6. Change Internet Explorer’s home page to the Yahoo Web site. 

7. Choose a search engine and navigate to its home page.  

8. Perform a basic search by entering the words “chocolate bars” into the Search the 
Web text box and press <Enter>. 

9. Select the URL that appears in the address bar and copy it. 

10. Open a word-processing program and paste the copied Web address into a blank 
document. 

11. Close the word-processing program without saving any changes. 

12. Save the Web page as an HTML only file. 

13. Change the Web page’s orientation to Landscape and the paper size to Legal. 

14. Print the Web page. 

15. Close the Internet Explorer program. 

Quiz Answers 
1. B. A cookie is one or more pieces of information that are stored as text files on your 

computer. 

2. D. A Web browser is a software application that enables you to connect to the Internet. 

3. D. A connection site is not part of a Web address. 

4. C. The extension “.uk” stands for United Kingdom. 

5. False. A secure Web site contains information not available to everyone. 

6. False. You should never use information that could be easily guessed by someone that 
you know as your password. 

7. B. The fastest way to display a specific Web page is to type the Web address in the 
Address bar and press <Enter>. 

8. True. A home page is the first page you see when you log onto the Internet. 

9. C. The Back button returns you to the Web page you just left. 

10. C. There is no Favorites option under the Edit menu. 

11. False. You can change the name of the site so that it is more meaningful, if you would 
like. 

12. B. It is not an option to save only the images that are contained within a Web page. 

13. D. Pressing <Ctrl> + <P> would make the Web page print. The shortcut keystroke for 
pasting text, images, or URLs into a document is <Ctrl> + <V>. 

14. False. There are lots of good search engines available on the World Wide Web. 

15. A. Using a search engine does not cost anything, regardless of the type of search you are 
conducting. 

 







Chapter Four: The 
Impact of Computing 
and the Internet on 

Society 

Chapter Objectives: 

• The E-world 

• People vs. computers 

• Computers in business 

• Computers in government 

• Understand good working conditions 

• Understand information security (passwords, backing up 
data, etc)  

• Understand computer viruses 

• Understand copyright concepts, Freeware, Shareware, and 
EULAs 

• Understand how computers affect the environment 

“Computing is not about computers anymore. It is about living.” –Nicholas Negroponte  
Since the Industrial Revolution, technology continues to change the way we live, work, and 
play. The most influential modern technology is the computer, which allows communication, 
information processing, and production to occur much faster. For example, computers have 
made industrial manufacturing more accurate and efficient and the disposal of hazardous 
waste safer. However, there are still many instances where a computer could not replace a 
human. 

This chapter will highlight areas in which the computer has changed and enhanced everyday 
life, and examine how modern technology has changed the quality of life in work, 
government, education, homes, and daily life, and discuss instances where computers or 
people are appropriate. You will also learn about health and environmental issues, and what 
you can do to help prevent any injuries or problems. 

 Prerequisites 
• Basic knowledge about 

computers. 
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Lesson 4-1: The E-world 
 

The last chapter taught us the basics of using the Internet. This chapter focuses on how 
computers and the Internet affect our everyday lives.  

The following list acknowledges several of the many activities and services that computers 
and the Internet help facilitate: 
• Collect information: Search the Web and/or conduct interviews via e-mail to collect 

information for a school paper. 
• Organize information: Utilize your bank’s Web site and/or financial management 

software to keep track of all your accounts.  
• Evaluate information: Search the Web and utilize spreadsheet software to evaluate 

potential prices for a new product against those of competing products. 
• Communicate information: Use e-mail or an Instant Messaging program to 

communicate with others no matter what their geographical location. 
• Increase productivity: Computers allow you to complete things quickly and easily, 

thus increasing your productivity in the workplace. 
• Collaborate with others: Utilize Message boards, chatrooms, and e-mail to keep in 

touch with others no matter what their geographical location. 
• Solve real-world problems: Search the Web to find information regarding anything 

you can imagine! Health, finance, relationships, snow shoeing—there’s a Web site for 
just about everything these days.  

• Facilitate learning and promote critical thinking: Learn for fun at home or strive 
for your college degree via online programs and Computer-based training (CBT). 

• Promote creativity: Suffering from Artist’s Block? Look up your favorite artist online 
for inspiration. Need help creating a Web site? Utilize Web-authoring software. 

Over the past few years, a whole new prefix has been added to language, thanks to computers 
and technology: e for electronic. There are e-mails, e-commerce, e-books, e-businesses, and 
anything else that can now be done electronically. E-mail is probably the most popular of all 
of these words. Millions of people across the world communicate using e-mail, where a 
message can be sent to another person instantly, to or from anywhere in the world. Another 
advantage with e-mail is that files can be sent to others as attachments to the message.  

Figure 4-1 

Messages can be sent 
across the world in 
seconds with e-mail. 

Figure 4-2 

Secure servers help make 
online shopping more safe 
and convenient. 
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E-commerce is also growing in popularity. E-commerce is a collection of Internet features and 
services that allow individuals and organizations to perform commercial transactions using 
the Internet. Companies see the appeal in selling more products and services with less of an 
overhead cost, while people are choosing to avoid the crowds at malls and supermarkets 
altogether by shopping online. E-commerce also gives individuals the ability to comparison 
shop and find the best quality product without having to leave home. Individuals can also find 
rare and discontinued items from sites such as online vendors and auction sites. Organizations 
can benefit from e-commerce as well, given that selling products over the Internet eliminates 
the need to maintain physical sales locations, thus allowing organizations to sell more 
efficiently and cost-effectively. 

E-learning is another popular electronic trend. E-learning provides inexpensive training and 
learning opportunities for people of all ages, income levels, and backgrounds. Children now 
can learn to read by utilizing a computer, and stay-at-home moms can obtain a college degree 
or certification through online programs. 

Computers and the Internet provide many public services to the community as well, such as 
Web cafes and public Internet centers, which allow people looking for work to take part in 
online training, resume creation, and online job searches.  

 Quick 
Reference 

The E-world: 
• Common daily economic 

practices are becoming 
available electronically, 
such as shopping, 
business, and trade. E-
mail communication is 
growing in importance all 
the time, as well as e-
learning, which provides 
inexpensive training and 
learning opportunities for 
people of all ages, income 
levels, and backgrounds. 
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Lesson 4-2: People vs. 
Computers 
 

Science fiction has been predicting how computer technology will someday equal and even 
surpass human intelligence for years. Characters such as Lieutenant Data in Star Trek 
illustrate an artificial intelligence that surpasses the human mind in storing information and 
the ability to learn new things, such as languages and procedures. In some cases, the 
possibility of artificial intelligence ultimately overpowering humans is explored, as seen in the 
Terminator movies. We do not yet see the limit of technology’s abilities, but science is still a 
long way from producing a computer that matches the human mind’s processing power. 

Over the past few decades, we have watched computers advance and grow into every facet of 
our daily lives. Today, computers replace many jobs that required human work in the past. On 
the other hand, many jobs have been created to help develop and maintain computer 
technology. The question of sheer processing superiority of man vs. computer is still in 
debate. But in the end, no matter how far technology advances, it will never have the ability to 
have feelings, to adapt to our surroundings, or to think creatively as we do. 

Here are a few examples of situations where a computer or a person is most appropriate. 

Table 4-1: People vs. Computers 
Tasks for People Tasks for Computers 
Human Touch: Tasks that deal with emotion, 
such as discussing personal matters in 
counseling or at the hospital. Artificial intelligence 
cannot relate to feelings or emotion. People 
naturally desire to speak with other people; not a 
computer. 

Dangerous Situations: Tasks that could 
jeopardize human safety, such as the disposal of 
hazardous waste or space exploration. 
Computerized machines can perform in places and 
conditions that a human body can not endure. 

Creativity: Tasks that require imagination or 
abstract thought, such as art or problem solving. 
Computers are limited; they cannot deviate from 
the information programmed into their systems. 

Repetition: Tasks that require repetitive actions, 
such as tasks in factory assembly lines. Humans 
can endure physical and mental fatigue from 
repetitive tasks, and are not as efficient or accurate 
as computers. 

Figure 4-3 
The debate over whether 
computers or humans 
have superior intelligence 
is ongoing. 
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Tasks for People Tasks for Computers 
Environment: Tasks that require processing 
unexpected data from the immediate 
environment, such as combat or security 
enforcement. Computers do not have senses or 
intelligence to process data from their 
surroundings. 

Calculations: Tasks that require mathematical 
calculation, such as accounting. In spreadsheets, a 
computer can calculate and recalculate figures in 
seconds what might take hours or days to do 
manually. 

Shape Recognition: Tasks that require shape 
recognition, such as lab work or research. For 
example, computers cannot discern pattern 
differences between healthy and cancerous 
tissue. 

Automation: Tasks that can be programmed to 
deal with anticipated input, such as a telephone 
answering service or Automated Transaction 
Machine (ATM). Business can save a lot of money 
by using computers instead of people for these 
tasks. 

Computers may eventually be able to do more “human” things as technology develops. One 
reference point for man vs. computer intelligence is in chess, which compares human strategy 
and intuition to cold computer calculation. The first man vs. machine chess contest, 
grandmaster Garry Kasparov vs. Deep Blue was won by the IBM supercomputer in 1997. 
However in February 2003, the first annual FIDE (International Chess Federation) Official 
World Chess Championship of Man vs. Machine gave Kasparov another chance against a 
computer, the Israeli-programmed Deep Junior. This time the match ended in a draw, proving 
that computer intelligence is not yet superior to humans.  

Even with time for advancement, Kasparov believes that humans will prevail on the 
chessboard. “In my view, in 10 years' time, the best human player could beat a machine one 
single game on our best day. It proves we are still better, because we cannot guarantee the 
same intact performance for six or eight playing games, while a machine could play for 100 
games,” he said. 

 Quick 
Reference 

People vs. Computers: 
• There are many 

differences between 
artificial and human 
intelligence, though each 
has its own niche and 
purpose in society. For 
example, computers are 
good for repetitive tasks, 
while humans think 
creatively and intuitively, 
unlike a computer’s 
calculation. 
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Lesson 4-3: Computers in 
Business 
 

Computers operate “behind the scenes” in many everyday situations. This day and age, we 
rely on computers more than we might realize. Take a step back for a moment and imagine 
what an office would be like without computers. How would you communicate with co-
workers? What would you use to present a business proposal or marketing strategy? How 
would you keep track of communication with clients? If your working environment is similar 
to the majority of businesses today, the tasks mentioned above seem tedious and nearly 
impossible without a computer at your fingertips. The table below elaborates on a few of the 
specific areas that have changed significantly with the introduction of computers. 

Table 4-2: Computers in Business 
Business Areas Changes and Improvements 
Banking Automatic Transaction Machines (ATMs) allow clients to do their banking 

without a bank teller. 

Internet banking allows bank clients to make deposits, transfers, and check 
on balances. 

Transferring or wiring money is possible both nationally and internationally. 

Increased automation in banks decreases employee overhead, saving 
banks a lot of money; however, there is a level of insecurity in online 
banking. 

Stock exchange  Buying and trading of stocks is available online. 

Checking on the status of stocks and bonds through the Internet is very 
popular. 

Advertising Web page ad banners, pop-up windows, and mass e-mails add a new 
dimension to advertising. 

Bidding for top spots on search engines is a popular and successful way to 
gain exposure. 

Accounting Spreadsheet programs with capability of automatic calculations have 
reduced human error, and make it easier to plan strategy. 

Management Software has been produced to help manage productivity and assessment, 
such as time clocks. 

Figure 4-4 

Many companies have 
found that advertising on 
the Internet increases 
sales dramatically. 

Figure 4-5 

Computers increase 
efficiency, but this often 
means that people have 
more work to do as well. 
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Business Areas Changes and Improvements 
Project 
management 

Software has been produced, such as Microsoft Project, to help manage 
and assess project costs, deadlines, and progress. 

Group working Programs that facilitate e-mail and project networking help group 
communication and assessment stay up to date. 

Office automation Calendars, customer administration, electronic contacts and production 
keep office communication efficient and inexpensive. 

Transportation/ 
Airline traveling 

Many airlines provide the option to purchase tickets online on their Web 
sites. 

Computerized booking systems enable e-tickets (which eliminate the need 
for paper tickets) and other features that make air travel more friendly and 
convenient for customers. 

Insurance Most insurance companies use large-scale computer systems and 
specialized software to manage insurance policies and file insurance 
claims. 

Computer systems owned by schools, businesses, and other organizations are normally 
governed by laws or rules of proper use, and every user has an obligation to know and 
understand these rules. For example, some computer systems owned by businesses may have 
rules or guidelines regarding when information can or cannot be considered personal, such as 
who owns data that is stored on the system. While rules covering employer-employee 
relations regarding computer use may vary, an individual has more rights to information 
created on a computer that they own than they do on equipment that is owned by someone 
else. If you are unsure of your company’s policies, make sure to contact your system 
administrator. 

 Quick 
Reference 

Computers in Business: 
• Computers operate 

“behind the scenes” in 
many everyday situations.  

• Computers have changed 
a lot about the conduct of 
business. For example, 
online banking, airline 
booking systems, and 
administration systems 
are all available and 
improved with computers.  
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Lesson 4-4: Computers in 
Education 
 

A college campus is probably the only place where it is acceptable walk around in public in 
your pajamas. But with today’s technology, students don’t even have to leave their room. 

Computers are becoming helpful tools in classrooms of all levels and ages, allowing educators 
to teach in new and exciting ways. For example, instead of printing and evaluating write-in 
tests, teachers can use specialized software programs to create, administer, and evaluate tests 
on a computer. Administrative branches are using software to improve student registration and 
class scheduling or timetabling as well.  

In some cases, computers are actually replacing the need for an instructor, as in computer-
based training (CBT). In CBT, an individual uses his or her computer to learn a subject from a 
CD or DVD. This is especially popular for individuals who wish to learn without actually 
taking a course. 

Another growing trend is distance learning, which dissolves the need for a classroom setting. 
This can take place through e-mail correspondence, or by the use of Webcast technology 
which allows a student to watch and hear a lecture over the Internet in real-time.   

Students are experiencing advantages to using the computer in homework as well. Word 
processing makes writing papers and class presentations much easier, while software 
programs are available to reinforce and exercise learning outside of the classroom. The 
Internet is also a great tool for researching homework assignments. However, because many 
informative sites require a user account or fee, it’s sometimes easier and cheaper to use library 
resources. 

Currently, most schools have access to basic computer and Internet technology. However, as 
technology advances and becomes more prevalent in education, a balance between some of 
the advantages and disadvantages of computers should be considered. Take a look at the 
following table for some advantages and disadvantages of incorporating technology into the 
classroom. 

Figure 4-6 

The Three R’s and One C: 
computer literacy skills 
have become as important 
as reading, writing, and 
arithmetic. 
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Figure 4-6 
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Table 4-3: Pros and Cons of Computers in Education 
Advantages Disadvantages 
Independent learning: Students can learn at 
their own pace, at any time of the day. 

Limited feedback: If students are confused or 
want more information, the computer offers 
limited or no feedback. 

Distance learning: Students can take part in a 
class that takes place miles away from the 
actual classroom. One person can also reach 
more people this way. 

Peer absence: Students don’t experience the 
support of peers in their learning. 

Homework is easier: Computers make it 
easier to research and finish assignments, and 
educational software programs make learning 
fun. 

One point-of-view: If students do not initially 
grasp a concept, a computer cannot offer an 
alternative method or a creative analogy to help 
students understand. 

Computer systems owned by schools, businesses, and other organizations are normally 
governed by laws or rules of proper use, and every user has an obligation to know and 
understand these rules. For example, some computer systems owned by schools may have 
rules or guidelines regarding when information can or cannot be considered personal, such as 
who owns data that is stored on the system. While rules covering school-student relations 
regarding computer use may vary, an individual has more rights to information created on a 
computer that they own than they do on equipment that is owned by someone else. If you are 
unsure of your school’s policies, make sure to contact your system administrator. 

 Quick 
Reference 

Computers in Education: 
• Computers are affecting 

how teachers and 
students interact, are 
making education more 
available with distance 
learning and online 
classes, and students are 
using them to do 
homework. Administrative 
tasks like timetabling and 
class scheduling are 
improved as well. 
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Lesson 4-5: Computers in 
Healthcare 
 

Computers are helping the healthcare industry take long strides in treating, diagnosing and 
preventing almost any ailment. We already know about computers that monitor the vitals, like 
pulse, breathing, and blood pressure in hospital rooms, but the more advanced technology is 
what is really changing lives. Technology like CAT (Computer Axial Tomography) scans let 
us look inside people without making an incision. LASIK (Laser-Assisted In Situ 
Keratomileusis) eye surgery changes the cornea to correct vision. Research is even being done 
for Internet surgery, which would enable a doctor to perform surgery from a distance through 
a system of computers, fine-tuned robots and a fast connection. 

Hospitals are using computers increasingly to keep track of appointments for the day, and to 
store patient information and records. Electronic files are not only easy to update and retrieve, 
they are easy to save and they require less storage space. Electronic files are also easier to 
access from other locations. Some doctors even use handheld computers like Palm Pilots to 
keep track of their schedule, which can also upload patient information. However, because it 
is critical to keep patient information confidential, system security is very important. 

Computers are helping to treat and control emergency situations as well. Global positioning 
systems and navigation technology are helping ambulances and emergency vehicles get to 
where they need to be faster. Technology used in the ambulance can also help emergency 
rooms know exactly what to expect before the ambulance arrives. 

Technologies have also been developed to help the physically handicapped to live, work, and 
communicate. Voice recognition software for the blind is just one of the many ways 
technology has evolved in order to support and provide opportunities for the disabled and 
disadvantaged. 

Figure 4-7 

Technology like the CAT 
scan is helping doctors 
treat patients with more 
accuracy and skill than 
ever before. 
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Objective: 3.4.1.2 and 
3.4.1.4 
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Figure 4-7 

 Quick 
Reference 

Computers in Healthcare: 

• Computers in healthcare 
make diagnosis and 
treatment much easier for 
the patient and doctor. 
Electronic files and 
administrative tasks are 
also easier using 
computers. 

• Technologies have also 
been developed to help 
the physically 
handicapped to live, work, 
and communicate. 
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Lesson 4-6: Computers at 
Home  
 

Though we don’t have robots to do our work like the futuristic Jetsons, people are using the 
computer to help complete daily tasks—all without having to leave home! Individuals and 
families use the computer for a number of purposes, such as bill paying, entertainment, or 
research and study. Here are a few ways people use computers in the home: 
• Entertainment: Computer games have become so advanced that PCs are often built with 

their ability to support games in mind. In fact, Sony’s PlayStation and Microsoft’s Xbox 
are computer systems made exclusively for playing games. 

• Banking: Software programs that keep detailed records of finances and budgets are 
available. Most banks also offer online banking to perform transactions, pay bills, or 
check on balances.  

• Communication: Computers are useful tools for keeping in touch with family and 
friends with e-mail, or to write and print letters. 

• Internet: The Internet can be used for shopping, entertainment, research, or 
communication. 

• Teleworking: Computers were first brought into the home for entertainment or to help 
with household business, but teleworking—also known as telecommuting or working 
from home—is a growing trend in businesses. Teleworking refers to an arrangement 
between a company and employees where employees are allowed to work from another 
location via a computer connection. There are many advantages and disadvantages for 
both parties in such an arrangement. 

Table 4-4: Teleworking Advantages and Disadvantages 
Advantages Disadvantages 
No commuting time Decreased employee interaction and 

camaraderie 

Reduced company costs for office or desk 
space 

Less emphasis on teamwork 

Flexible schedule High self-discipline is necessary 

Figure 4-8 

Using computers for 
entertainment is very 
common. 

Figure 4-9 

The Internet and online 
baking systems allow you 
to check your bank 
accounts from home. 
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Objective: 3.4.1.2 and 
3.4.1.3 
Req. File: None 

Figure 4-8 Figure 4-9 

 Quick 
Reference 

Computers at Home: 

• Computers make many 
home functions easier, 
such as banking, 
communication, and 
entertainment. Some 
companies even offer the 
option for teleworking,  
(working from home) to its 
employees. 
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Lesson 4-7: Computers in 
Industry 
 

Over the past few decades, industry is an area that has seen substantial change with the use of 
new technology. Not only do computers and robots keep humans out of dangerous areas, they 
are more efficient and require a fraction of the time and human personnel to do the same 
amount of work. For example, computers and robots, not humans, do most of the 
manufacturing and assembly work in automobile plants.  

Here are some advantages and disadvantages of computers in industry. 

Table 4-5: Computers in Industry 
Advantages Disadvantages 
Efficiency: Computers and robots do not 
experience fatigue or injury from repetitive 
actions. 

Loss of Employment Opportunities: Jobs are 
being replaced by robots and computers, 
resulting in higher unemployment rates.  

Accuracy and Speed: Actions are consistently 
performed accurately and quickly. 

Reaction: Computers cannot react to 
unforeseen circumstances or process new 
information. 

Re-programming: If changes are introduced, 
robots and computers are easy to re-program to 
implement changes. 

More Employment Opportunities: Computers 
have replaced some jobs, but have created 
many jobs as well. 

Safety: Some tasks, such as hazardous waste 
disposal, are much safer and easier with the 
use of technology. 

Cost: Some tasks are so short that it would not 
be cost-effective to program a robot or 
computer for the task. 

Figure 4-10 

One engineer can control 
many computers or robots 
on an assembly line. 

Figure 4-11 

Machines powered with 
computer intelligence help 
factory workers in their 
jobs. 
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 Quick 
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Computers in Industry: 
• Many tasks in factories 

and industry-related jobs 
have been made safer 
and more human-friendly 
because of computers. 

Figure 4-10 

Figure 4-11 
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Lesson 4-8: Computers in 
Government 
 

We all know that governments can be inefficient and bogged down with bureaucracy and that 
they sometimes lack the funds to fix their own internal and managerial problems. In many 
cases around the world, governments are learning to use the computer to their advantage, 
eliminating some levels of bureaucracy and helping others to be more efficient and effective. 
Here are a few ways governments are using computers and technology to help do their work. 

Table 4-6: Computers in Government 
Gov. Function  Description 
Public records Instead of storing files in rooms upon rooms of file cabinets, public records 

can be kept electronically, which also makes them easier to retrieve and 
search through. For example: 

Census: Census results are entered in a database which makes the 
information easy to access and process, such as predicting and 
researching trends in the population. Sometimes this information is also 
available online. 

Vehicle registration: All registered vehicles are stored in a central 
database, which makes the information easily accessible for security 
services, such as the police and customs. 

Revenue 
collection/ Taxes 

Many people choose to file their taxes electronically through the Internet, 
which is faster and easier to process than paper and mail. Tax refunds or 
pay-ins can also be executed electronically, which eliminates mailing time 
and is convenient. 

Voting Electronic voting is being tested with hopes to increase voter participation. 
Security considerations need to be perfected before this option is widely 
available.  

Figure 4-12 

Central computer systems 
with public information like 
vehicle registration helps 
police and other branches 
of the government do their 
jobs. 

 IC3 

Objective: 3.4.1.2 and 
3.4.1.3 
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To Computers in 
Government: 
• Governments are using 

computers to help store 
records, collect taxes, and 
some are even trying to 
make voting available 
electronically. 

Figure 4-12 
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Lesson 4-9: Ergonomics 
 

We’ve all heard of ergonomics, but have probably brushed it off as old information: sit up 
straight, take breaks, etc. But ergonomics is more than just sitting with both feet on the floor; 
it is the application of scientific information concerning humans to the design of objects, 
systems and environment for human use. In other words, whenever something is created or 
designed, ergonomists want to make sure it is friendly to the way we operate. And, they want 
to make sure that people understand the best way to use that equipment. 

So why should you care about ergonomics? In the case of computers, good practice of 
ergonomics keeps you healthy and injury-free, which makes long hours at the office not seem 
very long. Keeping you comfortable will raise your productivity and increase job satisfaction, 
which will make you and your boss very happy as well. 

In addition to the diagram above, here are a few tips the experts have to say about good 
working form.  
• Work smarter, not harder: Your eyes and body need a break from the computer just as 

much as your mind, because we are not designed to sit at such a close distance for a long 
period of time. The following is a suggested break schedule to maximize your eyes and 
body safety. 

Micro-Break: This break is only for about 10 seconds and should be taken about every 
10 minutes. Look far away from your terminal (at least 20 feet) and breathe and blink 
easily. Keep your eyes moving while looking at different distant objects. This should 
not interfere with your work or your concentration.  
Mini-Break: Take this break about every hour; it should last about five minutes. Stand 
up and stretch. Try doing eye exercises during this break so the eyes can flex and be 
used in different seeing situations.  
Maxi-Break: This could be a coffee break or lunch. The maxi-break is a “get up and 
move” type of break that will allow your blood to start flowing again and get you more 
energized. This kind of break should be taken every few hours.  

Figure 4-13 

A few examples of good 
ergonomics. 
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Objective: 3.4.2.1 and 
3.4.2.2 
Req. File: None 

Figure 4-13 

The monitor should be 
viewed at a slight 
downward angle. 

Elbow angle should 
be at 90 to 70 
degrees. 

The monitor should sit 
back on the desk to 
prevent eyestrain. 

The chair should be 
adjustable for the 
individual’s 
ergonomic needs. 
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• Lighting: Bright surrounding lights are the source of many eye strain complications. Dim 
your work area's lighting to reduce glare, and shield your eyes from bright light sources. 
Doing this will reduce competition from surrounding light sources, so your eyes can 
focus on light from the computer screen.  

• Seating: Chairs should have adjustable features for the chair’s height, the armrests, and 
the backrest. This should accommodate each individual’s ergonomic needs. 

• Monitor: The monitor should be viewed at a slight downward angle. A good reference 
point is if your eyes are level to the top of the screen or higher. You may also want to use 
a monitor filter to reduce the glare on your eyes. 

• Keyboard: Use a responsive keyboard so that you don’t have to pound the keys to type. 
Using a keyboard pad will also help reduce the pressure in your wrists. 

• Mouse: Mouse mats ease the use of a mouse; mouse pads are also available on which to 
rest the wrist to alleviate pressure while using a mouse. 

• Feet: A footpad or step on which to rest your feet may help individuals with short legs or 
in situations where the desk or chair cannot be adjusted. 

• Environment: In addition to using your computer equipment correctly, the environment 
in which you work should be conducive to your human needs. The work area should be 
comfortable with a moderate temperature and adequate ventilation.  

 Quick 
Reference 

Ergonomic: 
• Practice good ergonomics 

when using the computer 
to prevent injury and 
enhance productivity. 
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Lesson 4-10: Computer-
related Injuries 
 

Computers are meant to increase productivity, but not at the expense of our health. Years of 
computer use have taught us that some injuries are common for individuals who use 
computers. Because most computer use is work-related, many countries have laws that require 
employers to pay for the prevention of these injuries, such as buying ergonomic devices or 
seminars, and the treatment of these injuries, such as wrist braces or surgery. Check the laws 
in your country so you can avoid and/or treat this debilitating condition.  
• RSI (repetitive strain injury): This type of injury is caused when certain muscles are 

used repeatedly over a long period of time, resulting in muscular strain or damage. The 
wrists and forearms are especially susceptible. A keyboard or mouse used at the wrong 
level, or a poorly placed monitor can also cause these injuries. 
Prevention: Take frequent breaks and make sure the workspace is ergonomically 
adjusted for individual needs. 

• Eye strain: Our eyes are not meant to focus on close objects, like monitors, for long 
periods of time. Other factors like glare from the screen or reflections from other objects 
in the room can further irritate vision.  
Prevention: Don’t stare at the screen for hours on end; look away and focus on far 
distances to exercise your eyes, in addition to taking frequent breaks. You can also use 
eye-friendly hardware, like monitor filters, or LCD screens to reduce glare. Also, 
monitors with higher resolutions and more pixels per inch (ppi) are better for the eyes. 

• Back strain: Prolonged sitting with poor posture can cause a number of back and 
shoulder ailments. 
Prevention: Good chairs that are adjustable can help correct posture. Again, taking 
breaks helps alleviate some of the strain of sitting in the same position for extended 
hours. 

Figure 4-14 

Eye strain is a common 
ailment for computer 
users. 

Figure 4-15 

A sore back can result 
from poor posture or 
sitting for prolonged 
periods. 
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 Quick 
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Health Issues: 
• Computers are meant to 

increase productivity, but 
not at the expense of 
health. Common injuries 
sustained from prolonged 
computer use are 
repetitive strain injury, eye 
strain, and back strain. 

Figure 4-14 Figure 4-15 
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Lesson 4-11: Maintaining a 
Safe Working Environment 
 

In addition to practicing good ergonomics, it is essential that you maintain a safe working 
environment that complies with legal health and safety rules. Nobody wants to leave their 
office with a broken limb or electric burns; that’s why keeping a tidy workspace and office is 
important.  

Computers are notorious for the jumble of cables and wires that are required to make them 
run, and it’s not unusual for a computer to have ten connections running from it at one time. 
Such wires and cables around the desk space are accidents waiting to happen. It’s a good idea 
to take precautions to prevent tripping or equipment damage that could result from getting 
caught in one of these cables or cords by shortening them to the necessary length and by 
taping down cables that run along the floor. 

The holes and sockets that these many cables connect to should be examined as well. For 
example, examine plugs, sockets, and leads for defects and repair any irregularities. And, if 
there are a lot of electrical devices plugged into one outlet, have a professional install another 
outlet nearby to spread out the power demands evenly. Make sure to leave proper air 
circulation around electrical equipment as well, to prevent over-heating. 

Common sense is the simplest and most basic precaution. Leaving clutter around the office 
and blocking pathways is not only counter-productive and discourteous to co-workers, it is 
also not in compliance with fire and safety codes. 

Figure 4-16 

Too many plugs in one 
outlet can be dangerous. 

Figure 4-17 

Cords are potential 
hazards for individuals 
and computers. 
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Prevention: 
• In addition to practicing 

good ergonomics, prevent 
broken equipment or 
bodily injury by keeping 
your workspace and 
walking areas clear and 
distributing electrical plug-
ins wisely. 

Figure 4-16 
Figure 4-17 
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Lesson 4-12: Information 
Security 
 

Security is a sensitive issue. We hire security officers to protect our workplaces, analyze 
national security efforts, and install security systems in our homes. Information security is 
another type of security that isn’t widely understood, but is just as important as protecting the 
valuables in your home.  

The U.S. National Information System Security Glossary defines Information security 
(INFOSEC) as:  

 “the protection of information systems against unauthorized access to or 
modification of information, whether in storage, processing or transit, and 
against the denial of service to authorized users or the provision of service to 
unauthorized users, including those measures necessary to detect, document, 
and counter such threats.” 

In short, information security is taking measures to protect your computers and network 
systems from tampering by hackers or viruses. This includes creating passwords and security 
policies, backing up information, and using security features like Firewalls. If information 
security is neglected and someone breaks into your system, they can easily access the 
sensitive information on your computer and other computers on the network, such as account 
numbers, passwords, and e-mails. Once they gain access, not only can they steal information, 
but they can also embed a virus or program that damages information on the entire network, 
possibly resulting in huge financial loss by the victimized organization. 

Some organizations may restrict access to certain data in order to protect secure or important 
data; such as confidential information in a school, hospital, or government agency; or 
customer credit card information stored by a business. Such restrictions include barring access 
to files, storage devices, computers, networks, the Internet, or certain Internet sites. The types 
of tools and strategies used to restrict access to data include keeping restricted information on 
secure computers, or keeping information behind firewalls or other security systems. 

Figure 4-18 

Information Security is 
very important in 
protecting your computer 
and its contents. 

Figure 4-19 

Firewalls protect your 
organization’s network 
from harmful viruses and 
hackers on the Internet. 
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Figure 4-18 

Figure 4-19 
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Some users may want to restrict access to portions of the Internet as well, such as parents 
trying to prevent children from accessing adult Web sites or companies that want employees 
to avoid shopping while at work. The types of tools and strategies used to restrict access to 
certain Internet sites include installing Internet-blocking software, or personally supervising 
computer users. 

One of the most important preventative measures that an organization can take is to adopt an 
enforced information security policy. Though each organization has different security 
requirements, the need for security policies to provide standards and actions is definite. When 
a security policy is implemented, everyone using the network handles information the same 
way, minimizing the number of loopholes where hackers can bypass the system. Security 
policies also make it easier to track individuals who do not adhere to policy rules. If an 
information security problem does occur with sensitive information, having proof that the 
organization took steps to try and prevent such an incident could reduce repercussions.  

It is also important that everyone knows how to report a security incident. If a computer is not 
working correctly, employees should be able to identify that there is a problem, know who to 
contact, and know what they should do with their computer so the situation doesn’t intensify. 
A standard procedure should also be to document the situation to prevent future occurrences.  

We know what an enforced information security policy can do, but what can you do to protect 
your privacy and personal security online? 

• Understand how Web sites track your activity online using “cookies” or other “behind-
the-scenes” systems.  

• Do not share personal or family information to unknown people or in public places while 
online. 

• Use code names or “aliases” when communicating in public forums. 

In the end, the best defense against a security problem is individual users. If everyone 
connected to the network is aware of security risks and how to handle them, security problems 
can be avoided and fixed quickly. Users should also be aware of the consequences if security 
policies and procedures are not heeded. 

 Quick 
Reference 

Information Security: 
• In short, information 

security is taking 
measures to protect your 
computers and network 
systems from tampering 
by hackers or viruses. 

• One of the most important 
steps an organization can 
take is to adopt an 
enforced information 
security policy. 

• Some organizations may 
restrict access to certain 
data in order to protect 
secure or important 
information. 

• It is important that 
individual users are aware 
of security risks and how 
to handle them. 
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 Quick 
Reference 
Privacy Issues: 
• User ID: A user ID 

uniquely identifies the 
user on a network. 

• Password: A password 
grants a user access to 
their individual account. 

• It is important for 
organizations to adopt a 
password policy because 
passwords are a main line 
of defense against 
attackers. 

Lesson 4-13: Working with 
Passwords and User IDs 
 

In a network of computers hooked up to one another, ensuring privacy for every user is a very 
serious issue. Proper security measures must be taken in order to secure your computer from 
“hackers,” or unauthorized personnel attempting to gain access to your computer or network. 
Hackers can wreak havoc on your computer or network by passing along viruses or even 
spying on personal files that you assumed were secure.  

One precaution that is being taken in order to protect computer systems from hacker attacks is 
by assigning user IDs and passwords to each user in the network. User IDs uniquely identify 
the user on the network, while the password, known only by the user, grants access to the 
individual account. This combination of unique information opens the account to its 
individual settings and access rights on the network.  

Access rights also control privacy. Access rights determine where you can go in the network 
and are different for each individual. For example, the site administrator has access to just 
about every computer or printer in a network, but most individuals are limited to specific 
folders and printers, as defined by the site administrator. Access rights are often helpful in 
managing the information of different departments: individuals in the engineering department 
wouldn’t have access to human resources files.  

Since a password is a main line of defense against attackers, it is important to adopt a 
password policy. A password policy sets standards for strong passwords, or passwords that 
aren’t easily compromised or guessed by others. Passwords are generally 4-16 characters 
long. They are used to determine whether or not the user that is requesting admittance to the 
secure Web site is actually the person they claim to be. Passwords generally do not have 
spaces. When you enter your password into the text box, it is usually replaced with bullets or 
another symbol so that no one else can read it off of your screen. A good password is a 
mixture of letters and numbers. This makes it much more difficult for someone to guess it. 
Also, don’t use a word or number that someone who knows you well could easily guess (for 
example, your social security number, pet’s name, or birth date). It’s also a good idea to 
change your passwords periodically.   

Figure 4-20 

In a computer network, it 
is important that each user 
has privacy. 

Figure 4-21 

Each user of a network 
should be assigned a user 
ID and password that is 
only known by the user 
and grants access to their 
individual account. 
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Figure 4-20 Figure 4-21 
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 Quick 
Reference 
• Backing up Data: 

Backing up data and 
software makes 
recovering from a security 
breach or a natural 
disaster much easier. 
Network administrators 
usually back up a 
network’s data from a 
centralized location, but 
individual users should 
also back up their own 
data on a regular basis. 

• Preventing Theft: 
Always report the theft of 
a computer, PDA, or 
mobile phone 
immediately. It is a good 
idea to create a startup 
password for your 
electronic device, but an 
even better idea to 
password protect any 
sensitive files that are 
contained on the device. 

Lesson 4-14: Backing up Data 
and Preventing Theft 
 

Back up data 
Everyone who has lost data because of a crashed computer knows how frustrating it is to redo 
all of your lost work, and what a relief it is to have a saved backup copy. Now imagine the 
agony of an entire organization losing their data because of a security breach. Taking a few 
moments to back up data on a storage device could save a lot of time and money.  

Backing up data and software to another storage device makes recovering from a security 
incident much easier, but it also protects you from uncontrollable factors, such as storms, 
fires, or other natural disasters that could ruin your equipment. Sometimes multiple copies of 
backup data are saved in different locations so if one copy is destroyed, another copy is saved 
safely elsewhere. Protective storage, such as a fireproof case, is also a wise investment. 

Everyone is responsible for backing up his or her own data, and this should be part of an 
information security policy. Usually network administrators back up the data on a network 
from a centralized location, but individual users should also back up their own data on a 
regular basis. Computers store a lot more information than is usually available on a storage 
device, so you’ll usually only want to backup data, not software. Site administrators can make 
backing up software automated by buying software that automatically backs up files on a 
computer. 

Preventing theft 
When organizations develop security policies, it’s easy to get so caught up in procedures and 
firewalls that they overlook how to protect their physical property. If a hacker can’t get the 
information they want electronically, they can do much more damage by acquiring the actual 
equipment in which the information is stored. 

Theft of a laptop computer, desktop computer, PDA, or mobile phone should always be 
reported to your company’s technical support department immediately, and your service 
provider should also be contacted in case of a missing phone. Computers with startup 
passwords have some protection, but determined attackers can still get through these barriers. 
Sensitive files with password protection are another crucial line of defense against theft. The 
contact information on a PDA or mobile phone is also valuable, and your professional image 
could be damaged if the contact information of business associates or clients is abused. 

Figure 4-22 

Backing up data makes it 
easier to recover from 
natural disasters – such 
as a power outage. 

Figure 4-23 

Prevent the theft of your 
sensitive files by password 
protecting them. 
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Lesson 4-15: Computer 
Viruses 
 

What is a virus? 
The average keyboard has thousands of germs on it, but that’s not how computers get viruses. 
A computer virus is a small computer program created by a malicious programmer for the 
purpose of damaging other computers. When viruses or WORMS become installed on a 
computer, the computer is infected and the virus or WORM carries out the damage it is 
programmed to do.  

There are many different types of viruses. Most viruses attack computer hard drives by 
erasing data and damaging system files (the only files that are safe are text files), but 
programmers can write the virus to do anything they want. If your computer isn’t working the 
way it usually does, you have probably been infected with a virus.  

One of the most devastating effects of a virus is that the virus often has the ability to spread 
from computer to computer. The most malicious viruses—such as the “I Love You” and 
“Melissa” viruses—have caused billions of dollars in damage worldwide. 

How are viruses spread? 
The most damaging computer viruses are programmed with the ability to reproduce and infect 
more computers. Many viruses invade computers through e-mail programs riding the backs of 
e-mail messages, or through networks and file sharing. Viruses can also be found in storage 
devices like diskettes, CD-ROMs, or zip disks. The Internet is a host to many viruses as well.  

What is an anti-virus program? 
The best way to protect your computer from a virus is to purchase a virus-scanning program. 
A virus-scanning program checks files that you download from the Internet, incoming and 
outgoing e-mails, and files stored on disks or other storage devices. A virus-scanning program 
is sort of like your computer’s white blood cells; it checks all the files and information that 
your computer processes and tries to eliminate a virus before it infects your computer. If a 
virus does infect the computer, the program also tries to erase the virus from the computer. If 
you’re even thinking about connecting to the Internet, you need to have anti-virus software 
installed on your computer. Using the Internet without protection is a sure way to contract a 
virus.  

Installing a virus-scanning program on your computer: 

Figure 4-24 

Malicious programmers 
create viruses that infect 
computers. 

Figure 4-25 

Computers are 
unresponsive and 
inefficient when infected 
with a virus. 
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• Protects your computer from becoming infected and from losing valuable information. 
• Prevents you from infecting other people and businesses. 
• Saves time and resources in recovering from a virus infection.  
• Increases computer efficiency. 

If your computer is infected with a virus, it’s not the end of the world. A virus-scanning 
program can not only prevent a virus infection, it can also “disinfect” files that contain a 
virus. When a file is disinfected, the anti-virus program eliminates the virus attacking the file. 

What else can I do to prevent a virus? 
Good judgement is the first line of defense against a virus. Installing and keeping up-to-date 
anti-virus software on your computer will keep out most viruses, but you can do a lot to 
prevent contracting a virus as well. Here are a few guidelines to keep in mind: 
• Don’t open messages from unknown senders. Viruses are often sent through e-mail 

messages. If you don’t know the sender, don’t open the message. 
• Don’t open attachments from unknown senders. A virus has to be opened to install 

itself on your computer. Even if the sender is familiar, think twice before opening the 
attachment.  

• Keep up to date on the latest virus threats. Make sure to keep your eyes and ears open 
for new viruses that are going around. If you know the name of a virus and what to watch 
for, you have a better chance of eluding an attack. 

• Stay informed regarding changes and advancements in technology. It is very 
important to keep yourself informed about the availability of product updates and 
upgrades. Often times, software companies will issue “patches” or updates for various 
programs in response to a virus or WORM that may be going around. Reading 
periodicals, reviewing online publications, or visiting the software company’s Web site 
on a regular basis are all ways to make sure you keep yourself up-to-date on the latest 
advancements and security measures. 

 Quick 
Reference 

Computer viruses: 
• A virus is a small 

computer program 
created by a malicious 
programmer for the 
purpose of damaging 
other computers. 

• Most viruses are 
programmed to reproduce 
and infect more 
computers through file 
sharing, networks, or e-
mail messages. 

• The best way to prevent a 
virus infection is to install 
a virus-scanning program 
on your computer, so 
viruses are detected 
before they attack your 
computer. 

• You are the first line of 
defense against viruses: 
don’t open messages or 
attachments that are 
unrecognizable. 
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Lesson 4-16: Copyright Concepts 
 

In most countries it is against the law to copy an original work and call it your own. A 
copyright is a form of theft protection for the author or authors of an original work. Most 
software is copyright protected. Somebody had to sit down and write the software, just like an 
author pens a book or an artist molds a sculpture. The following are examples of works that 
are typically copyright protected: 
• Books, magazines and newspapers 
• Plays and sporting events 
• Music and movies 
• Art and architecture 
• Software 
• Web sites 

In order to receive copyright protection, a work must be available in some recognized 
medium. In other words, you can’t copyright some idea you have in your head. You need to 
write it down or produce it first. 

Once a piece of software is copyright-protected, you cannot distribute it or change it in any 
way without the permission of the copyright holder, which is usually the author or the 
company that wrote the software. It is usually OK to copy a piece of software to a CD or disk 
for your own backup. It is not OK to copy a piece of software to a CD or diskette in order to 
hand it out to your friends or colleagues. Just because you own a piece of software does not 
mean that you control its copyright.  

Most software companies are pretty serious about copyright law. Here’s what Microsoft has to 
say about Word: “Warning: This computer program is protected by copyright law and 
international treaties. Unauthorized reproduction or distribution of this program, or any 
portions of it, may result in severe civil and criminal penalties, and will be prosecuted to the 
maximum extent possible under the law.” 

It is also important to note that Internet users are not granted permission to copy or download 
just anything off of the Web. Most information on the Internet is governed by laws and other 

Figure 4-26 
Microsoft Word is an 
example of a copyrighted 
work. 
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rules which protect information owners and promote the ethical use of data. Some Web pages 
are copyrighted, so be careful when you choose to use items from someone else’s Web site. 
There is such a thing called “fair use,” whereby copyrighted material can be used for specific 
purposes (such as a student research paper) without the permission of the copyright owner. In 
most cases, however, it is best to ask the Web administrator, or site creator, for permission 
before you copy or download anything from a Web page. 

If you do choose to use information from the Web, especially in an academic environment, it 
is absolutely essential that you understand plagiarism, the importance of citing source material 
accurately, and libel. Plagiarism occurs when one claims another person’s writing or work as 
one’s own by not providing proper sourcing. This is a very serious crime and the 
consequences are severe. Make sure to cite source material accurately, no matter how 
inconsequential it may seem. Libel is the deliberate communication of incorrect information 
in a way that causes harm to an individual or organization, and is also a very serious crime. 

Finally, don’t confuse a copyright with a patent or a trademark. A patent is used to protect a 
discovery or an invention. A trademark ™ is used to protect a word, slogan or insignia. For 
more information about copyright law, see the table below. 

Table 4-7: Common Misconceptions about Copyright Law 
Myth Truth 
Only artistic works like books, music 
and movies are covered under 
copyright laws.  

Wrong. Copyright laws apply to software and Web sites 
too, no less than it applies to books, music or movies.  

Once you buy a piece of copyrighted 
software, you are free to hand it out to 
your friends or modify the source code. 

Wrong. Doing so would probably violate the copyright law 
in your country. Most copyright laws prohibit the 
unauthorized reproduction or distribution of the original 
copyrighted material. There are a few exceptions in the 
case of shareware or freeware.  

Companies don’t really care about 
copyright violations. The copyright 
notices are simply a formality. 

Wrong. While companies don’t pursue every violation, 
they certainly go after the most brazen scofflaws. If you 
start selling copies of Word on the Internet, you’d better 
be ready to defend yourself in court. And be forewarned: 
Microsoft is a formidable legal opponent. 

A copyright is identical to a patent or a 
trademark. 

Wrong. While all three terms relate to intellectual 
property, they are distinct legal concepts. A patent is used 
to protect a discovery or an invention. A trademark ™ is 
used to protect a word, slogan or an insignia. 

A company must display a copyright 
notice in order to be protected under 
copyright law. 

Wrong. Just because you don’t see a copyright notice 
doesn’t meant that the work is not copyright protected. In 
some countries, like the United States, it is not necessary 
to include a copyright notice—although most companies 
do anyway. Always assume a piece of commercial 
software is copyrighted until you learn otherwise. 

Only large, multinational corporations 
can receive copyright protection for 
their work. 

Wrong. In most countries, anyone can receive copyright 
protection for any original work, including individuals. 
Consult your government’s copyright office for more 
information about obtaining a copyright. 

 

  

 Quick 
Reference 

Works that are Typically 
Copyrighted: 
• Books 
• Movies 
• CDs 
• DVDs 
• Sporting events 
• Artwork 
• Architecture 
• Software 
• Web sites 
• Plagiarism occurs when 

one claims another 
person’s work as one’s 
own. Make sure to cite 
source material 
accurately when using 
information found on the 
Web. 

• Libel is the deliberate 
communication of 
incorrect information in a 
way that causes harm to 
an individual or 
organization. 

• A patent is used to 
protect a discovery or 
invention. A trademark is 
used to protect a word, 
slogan, or insignia. 
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Lesson 4-17: Understanding 
Transactions on the Web 
 

You can purchase just about anything online these days. From groceries to grape-flavored lip-
gloss, it’s all there for the picking. Shopping via the Internet is quick and easy, the product is 
most often delivered right to your front door, and you can shop at all of your favorite “brick-
and-mortar” stores’ Web sites too. Also, online services are available 24 hours a day, and 
oftentimes you will find more products available online than in the actual store!  

Too good to be true? Well, there is one huge drawback to shopping online. There is an 
increased risk of credit card fraud. Because it is nearly impossible to pay with cash and most 
online retailers won’t let you choose a cash-on-delivery option, you are likely to make most, if 
not all, of your purchases online using a credit card. Thus, there is a lot of personal 
information floating around out there in cyberspace and hackers are champing at the bit to get 
a hold of your money. Although the risk of identity theft is ever present, Internet users have 
some methods of protection. 

Digital Certificate 
A digital certificate is like an electronic credit card that holds all of your personal information 
and presents it when you are conducting online business or any other online transaction that 
requires this type of information. A digital certificate contains the user’s name, a serial 
number, expiration dates, a copy of the holder’s public key (that when combined with a 
private key, can be used to encrypt messages), and a digital signature of the authority that 
issued the digital certificate. 

The Certification Authority (CA) issues digital certificates only after verifying the user’s 
information with the Registration Authority (RA). If, and only if, ALL of the information is 
correct, the user will receive their digital certificate. 

Encryption 
When you encrypt something, you are putting it into a code that only authorized personnel 
can understand. This prevents unauthorized individuals or networks from accessing 
confidential or case-sensitive information.  

Encryption is used most for things like online credit card sales, so that your credit card 
information is not read, copied, and abused by a hacker. Other things that might be encrypted 
include secret missions or operations, or any other sensitive information that you do not want 
anyone, except the intended receiver, to have access to. 

Here is a short list of precautions to consider before making purchases online: 

Figure 4-27 

Most often, you’ll use a 
credit card to pay for 
online purchases. 

Figure 4-28 

Learn how to prevent the 
theft of your personal 
information! 
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• Only give out credit card information on secure sites: A secure Web site should 
require you to enter a username and password in order for you to be able to access your 
personal account information. A secure Web site is often indicated by a tiny lock icon 
located in the lower-right corner of the window. 

• Do not share your credit card or account information: Make sure that you do not 
inform others of your credit card information, username, or password. Keep this 
information confidential. Refer to Lesson 4-13: Working with Passwords and User IDs 
for more information on password creation and protection. 

• Check your credit card fraud policy: Some Web sites are simply a lure set by criminals 
to steal your money or credit. It can be difficult to know if a Web site is fraudulent 
however, so be sure that you don’t have to pay if you get caught in a scam. 

• Check the company’s return policy: Most companies are lenient when customers want 
to return a purchase, but you might want to check their policy before making a purchase. 
Also, if the company is in another country, check the country’s consumer rights policies. 

• Check the company’s credibility: If the company is one you have not heard of before, 
you would do well to research the company’s credibility by calling the company’s contact 
numbers, looking for a client list, or checking customer references. Web sites that are 
familiar and have been in business for a long time, such as amazon.com, already have a 
solid, respectable reputation established. 

Beware that although there are methods available for fighting identity theft and fraud, it can 
still happen. Know that the site you’re shopping on is protected. Sites with protective 
measures will have their policies clearly stated. Make sure that you are well informed before 
you start handing out your confidential personal information online.  

 Quick 
Reference 

Understanding 
Transactions on the Web: 
• Digital Certificate: A 

digital certificate is like an 
online credit card that 
holds all of your 
information and presents 
it when you are 
conducting online 
business or any other 
online transaction that 
requires your personal 
information. 

• Encryption: Prevents 
unauthorized users from 
accessing personal or 
confidential information. 
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Lesson 4-18: Computers and 
the Environment 
 

Computers increase productivity but they also consume a lot of energy and materials. The 
influx of computer use has made many aware of how this new technology is not only 
changing our lives; it is also making us more aware of the resources we use to make them run.  

In order to keep our environment “healthy,” we must be responsible computer users and take 
action to protect the world around us. Recycling is a very positive and popular practice that 
can reduce a lot of waste. Paper recycling is an especially helpful cause, but other recycling 
measures are taking hold as well, such as recycling printer toner cartridges (printing quality 
may decrease when using recycled cartridges, however). Research is being done to find ways 
to salvage and recycle other computer parts, such as CPUs and monitors or at least parts of 
them. Another way to recycle is to donate used equipment to schools or needy organizations. 
Sharing your own personal knowledge and experience can help others in your school, place of 
employment, or community to learn how to benefit from technology.  

In addition, most computer hardware now has features to help reduce the amount of energy 
used to keep them running. For example, you can set your monitor to turn off if it hasn’t been 
used in a certain amount of time. You can turn it on again when it is ready to be used. 

With the Internet and networking technology, the need for paper can be dramatically 
decreased. In many cases, correspondence and information sharing can be done electronically 
through e-mail or a network instead of paper. This saves a marked difference in the amount of 
paper consumed, preserving many more natural resources and the environment. 

In the past, the manufacture of computers was a cause for some environmental concern. For 
example, microelectronic companies have used chlorofluorocarbons (CFCs), which are 
known to deplete the ozone, to make sure that computer components are free of dust or 
residue. Chemical rinses and coatings on parts in the computer also affect the environment 
because storage units for these hazardous chemicals can leak into the ground, contaminating 
the water wells. These chemicals can also cause problems when units are thrown away.   

Fortunately, most companies are embracing “green manufacturing” which means they are 
mindful of the environment’s safety when manufacturing electronics. For example, most 
companies have found an alternative to CFCs, and there are some organizations whose sole 
purpose is to dispose of computers safely.  

Figure 4-29 

Paper is a prime recycling 
opportunity. 

Figure 4-30 

It used to be that the 
disposal of old computers 
wreaked havoc on the 
environment, but today 
many companies embrace 
“green manufacturing” and 
proper disposal of 
chemical waste. 
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Chapter Four Review 

Lesson Summary 

The E-world 

• Common daily economic practices are becoming available electronically, such as shopping, 
business, and trade. E-mail communication is growing in importance all the time, as well as e-
learning, which provides inexpensive training and learning opportunities for people of all ages, 
income levels, and backgrounds. 

People vs. Computers 

• There are many differences between artificial and human intelligence, though each has its own 
niche and purpose in society. For example, computers are good for repetitive tasks, while humans 
think creatively and intuitively, unlike a computer’s calculation. 

Computers in Business 

• Computers operate “behind the scenes” in many everyday situations. 

• Computers have changed a lot about the conduct of business. For example, online banking, airline 
booking systems, and administration systems are all available and improved with computers. 

Computers in Education 

• Computers are affecting how teachers and students interact, are making education more available 
with distance learning and online classes, and students are using them to do homework. 
Administrative tasks like timetabling and class scheduling are improved as well. 

Computers in Healthcare 

• Computers in healthcare make diagnosis and treatment much easier for the patient and doctor and 
electronic files and administrative tasks are also easier using computers.  

• Technologies have also been developed to help the physically handicapped to live, work, and 
communicate. 

Computers at Home 

• Computers make many home functions easier, such as banking, communication, and 
entertainment. Some companies even offer the option for teleworking, (working from home) to its 
employees. 

Computers in Industry 

• Many tasks in factories and industry-related jobs have been made safer and more human-friendly 
because of computers. For example, computers and robots, not humans, do most of the 
manufacturing work in automobile plants. 
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Computers in Government 

• Governments are using computers to help store records, collect taxes, and some are even trying to 
make voting available electronically. 

Ergonomics 

• Practice good ergonomics when using the computer to prevent injury and enhance productivity. 

Computer-related Injuries 

• Computers are meant to increase productivity, but not at the expense of health. Common injuries 
sustained from prolonged computer use are repetitive strain injury, eye strain, and back problems. 

Maintaining a Safe Working Environment 

• In addition to practicing good ergonomics, prevent broken equipment or bodily injury by keeping 
your workspace and walking areas clear and distributing electrical plug-ins wisely. 

Information Security 

• In short, information security is taking measures to protect your computers and network systems 
from tampering by hackers or viruses. 

• One of the most important steps an organization can take is to adopt an enforced information 
security policy. 

• Some organizations may restrict access to certain data in order to protect secure or important 
information. 

• It is important that individual users are aware of security risks and how to handle them. 

Working with Passwords and User IDs 

• User ID: A user ID uniquely identifies the user on a network. 

• Password: A password grants a user access to their individual account. 

• It is important for organizations to adopt a password policy because passwords are a main line of 
defense against attackers. 

Backing up Data and Preventing Theft 

• Backing up Data: Backing up data and software makes recovering from a security breach or a 
natural disaster much easier. Network administrators usually back up a network’s data from a 
centralized location, but individual users should also back up their own data on a regular basis. 

• Preventing Theft: Always report the theft of a computer, PDA, or mobile phone immediately. It is a 
good idea to create a startup password for your electronic device, but an even better idea to 
password protect any sensitive files that are contained on the device. 

Computer Viruses 

• A virus is a small computer program created by a malicious programmer for the purpose of 
damaging other computers. 

• Most viruses are programmed to reproduce and infect more computers through file sharing, 
networks, or e-mail messages. 
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• The best way to prevent a virus infection is to install a virus-scanning program on your computer, 
so viruses are detected before they attack your computer. 

• Good judgement is the first line of defense against viruses: don’t open messages or attachments 
that are unrecognizable, keep up to date on the latest virus threats, and make sure to stay 
informed regarding changes and advancements in technology. 

Copyright Concepts 

• Books, movies, CDs, DVDs, sporting events, artwork, architecture, software, and Web sites are all 
examples of works that are typically copyrighted.  

• Plagiarism occurs when one claims another person’s work as one’s own. Make sure to cite source 
material accurately when using information found on the Web. 

• Libel is the deliberate communication of incorrect information in a way that causes harm to an 
individual or organization. 

• A patent is used to protect a discovery or invention. A trademark is used to protect a word, slogan, 
or insignia. 

Understanding Transactions on the Web 

• Digital Certificate: A digital certificate is like an online credit card that holds all of your information 
and presents it when you are conducting online business or any other online transaction that 
requires your personal information. 

• Encryption: When you encrypt something, you are putting it into a code that only authorized 
people can understand. This prevents unauthorized users from accessing personal or confidential 
information. 

Computers and the Environment 

• The paper use and hardware manufacturing of computers are affecting the environment. 

• You can be a responsible user of computers by recycling products such as paper and printer 
cartridges, safely disposing of hardware containing hazardous materials, and providing used 
equipment to schools or needy organizations. 

Quiz 

1. Computers and the Internet are used to: (Select all that apply.) 
A. Organize information 
B. Increase productivity 
C. Collect Information 
D. All of the above.   

2. Computers operate “behind the scenes” in many everyday situations. (True 
or False?) 

3. Businesses only use computers for their calculation skills. (True or False?) 
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4. Computers are changing the health care industry with: (Select all that 
apply.) 
A.  LASIK eye surgery 
B. Voice recognition software for the blind 
C. Free health insurance 
D. Electronically-stored patient files 

5. Humans do most of the work in industrial factories. (True or False?) 

6. What should you do to practice good ergonomics? (Select all that apply.) 
A. Take frequent breaks. 
B. Use an eye-friendly monitor. 
C. Sit at a height appropriate for your wrists and arms while typing. 
D. All of the above. 

7. RSI stands for: 
A. Repetitive Strain Injury 
B. Recreational Strain Injury 
C. Renewable Source Industry 
D. Retroactive Search Investigation 

8. You are complying with legal health and safety rules if computer cords and 
cables are lying all over your workspace. (True or False?) 

9. Which of the following is not a true statement about passwords? 

A. They are known only by an individual user. 
B. They grant access to an individual account. 
C. You should use your social security number as your password.  
D. They are generally 4-16 characters long. 

10. It is not important to back up your own data on a regular basis because 
your network administrator will do it for you. (True or False?) 

11. All of the following are advantages of installing a virus-scanning program 
on your computer, except: 
A. Prevents the loss of valuable information. 
B. Saves time and resources in recovering from a virus infection. 
C. Prevents you from getting sick. 
D. Increases computer efficiency. 

12. Make sure to stay up to date on the latest virus threats. (True or False?) 

13. Which of the following are examples of works that are typically 
copyrighted? (Select all that apply.) 

A. Books 
B. Software 
C. Web sites 
D. DVDs 
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14. Plagiarism is the deliberate communication of incorrect information in a 
way that causes harm to an individual or organization. (True or False?) 

15. Which of the following is NOT a precaution to consider before making 
purchases online? 

A. Only give out credit card information on secure sites. 
B. Use someone else’s credit card instead of your own. 
C. Do not share your credit card account information. 
D. Check the company’s credibility. 

16. You can be a responsible user of computers by: (Select all that apply.) 

A. Safely disposing of hazardous materials. 
B. Not supporting “green manufacturing.” 
C. Providing used equipment to schools or needy organizations. 
D. Recycling products such as paper and printer cartridges. 

Quiz Answers 
1. D. Computers and the Internet are used to do all of the above. 

2. True. Computers operate “behind the scenes” in many everyday situations. 

3. False. Businesses use computers for many other tasks, such as airline booking, insurance 
claims, and administration systems. 

4. A, B and D. Unfortunately, computers are not able to provide free health insurance. 

5. False. Computers or robots do most of the work in industrial factories.  

6. D. All of these things are required for good ergonomics.  

7. A. A Repetitive Strain Injury (RSI) is sustained when the same muscles are used over an 
extended period of time. 

8. False. Computer cords and cables are safety hazards.  

9. C. You should never use information for your password that could be easily guessed by 
someone that knows you well. 

10. False. Although most network administrators do back up the network on a regular basis, it 
is still essential that each individual user back up their own personal data. 

11. C. A virus-scanning program protects your computer from getting sick, not you! 

12. True. Keeping up to date on the latest virus threats could end up saving you from a virus 
attack. 

13. A, B, C, and D. All of these are examples of works that are typically copyrighted. 

14. False. Plagiarism occurs when one claims another person’s work as one’s own. Libel is 
the deliberate communication of incorrect information in a way that causes harm to an 
individual or organization. 

15. B. Using someone else’s credit card without their prior consent is considered credit card 
fraud and is absolutely illegal. 

16. A, C, and D. You can also be a responsible user of computers by supporting “green 
manufacturing,” which means you are mindful of the environment’s safety in the 
manufacturing of electronics.  
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